#opendaylight-docs: docs

Meeting started by colindixon at 19:01:42 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:01:46)
  2. the rest of xinghao_'s internship (colindixon, 19:08:15)
    1. here are some ideas (colindixon, 19:08:23)
    2. 1.) seeing if we could improve the theme so that there is an outline of the curren section on the left (or right) (colindixon, 19:08:51)
    3. this might not be very important, since you can get it from the page dropdown at the top (colindixon, 19:10:37)
    4. http://docs.opendaylight.org/en/latest/submodules/releng/builder/docs/jenkins.html a different exmaple of how to handle is to manually draw a table of contents (colindixon, 19:11:03)
    5. in particular it would be really cool to get your position in the full tree of content (colindixon, 19:11:35)
    6. for exmaple, above knowing that jenkins was under the infrasturcutre guide, which was under the root (colindixon, 19:12:31)
    7. 2.) right now, every rst file is an html page, which kind of sucks because some of them are very small (colindixon, 19:13:01)
    8. could we make it so that we aggregated some rst files into one html page (or even producted one big html document for everything?) (colindixon, 19:13:31)
    9. http://docs.opendaylight.org/en/latest/getting-started-guide/who_should_use.html for exmaple, this shouldn't be it's own page (colindixon, 19:14:03)
    10. http://docs.opendaylight.org/en/latest/getting-started-guide/index.html as slightly different idea, this page has no contnet, it would be nice if you could tell reST to combine all the toctree things here (colindixon, 19:15:10)
    11. 3.) probably lowest priroity, figure out if there's a way to produce one PDF per top-level section, e.g., user guide PDF, getting started guide PDF, etc. rather than just one big one (colindixon, 19:15:53)
    12. 4.) this is a stretch, but figuring out how to provide a way to give feedback, file a bug, or even edit the file in gerrit (which I don't think is possible), would be really cool (colindixon, 19:17:58)

  3. per-project documentaiton (colindixon, 19:19:57)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we continue to make progress (colindixon, 19:20:07)
    2. down to 21 projcts with no new docs in boron (colindixon, 19:24:08)
    3. down to 22 outstanding patches, only 3 f which are blocking on the documentation (colindixon, 19:24:31)

  4. migrating User Guide/Developer Guide to reST in boron (colindixon, 19:24:46)
    1. we had a TWS on this on Monday (colindixon, 19:24:54)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tws/opendaylight-meeting-tws.2016-08-08-17.01.html really, really sparse notes (colindixon, 19:25:15)
    3. it was recorded (colindixon, 19:25:23)
    4. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings the recording will be posted here (colindixon, 19:26:12)
    5. https://meetings.webex.com/collabs/url/2xCvZ-TWMBC_aEljHv55GW1tBGCg76qT5kd5RGrXwCa00000 <-- link to TWS meeting on Documentation (phrobb, 19:26:38)
    6. the most important thing that dropped out is that there are differnet projects that want to take different approaches for how and when to migrate their docs (colindixon, 19:27:01)
    7. some projects want to migrate already, others probably want to wait until after Boron to start producing reST (colindixon, 19:28:59)
    8. the result is that we might want to do partial migrations, e.g., ignore migrating some content (colindixon, 19:29:19)
    9. maybe by seeing if the section starts "This content has been migrated to:.." or something like that (colindixon, 19:29:52)
    10. 5.) this would be another thing which maybe xinghao_ could work on (colindixon, 19:30:05)
    11. the current plan of record, colindixon thinks should be to propose patches migrating everyone's content and ask them to opt-out or approve, if no interaction for some period of time, e.g., 2 weeks, we merge it anwyay (colindixon, 19:33:13)
    12. we need to deal with in flight patches, which could be a pain, but we're down to ~20 of those across 18 projects, so we could migrate ~30-35 without problems at all, which would still be a huge win (colindixon, 19:34:19)
    13. ACTION: colindixon to e-mail projects with no docs and no e-mail saying there won't be any (colindixon, 19:35:39)
    14. ACTION: colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work) (colindixon, 19:35:49)
    15. ACTION: colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:36:52)
    16. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:37:02)
    17. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc) (colindixon, 19:38:34)
    18. ACTION: colindixon to add fixing cross-projet links (and notes) as things to check for after automatic conversion (colindixon, 19:39:33)
    19. colindixon did e-mail people with seemingly abandoned patches and then formally abandoned them (colindixon, 19:40:32)
    20. ACTION: colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week (colindixon, 19:41:06)
    21. the key parts of creating one patch per project would be: (colindixon, 19:41:44)


Meeting ended at 19:44:55 UTC (full logs).

Action items

  1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
  2. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
  3. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  5. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
  6. colindixon to add fixing cross-projet links (and notes) as things to check for after automatic conversion
  7. colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week


Action items, by person

  1. colindixon
    1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
    2. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
    3. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    5. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
    6. colindixon to add fixing cross-projet links (and notes) as things to check for after automatic conversion
    7. colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week
  2. phrobb
    1. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)


People present (lines said)

  1. colindixon (51)
  2. odl_meetbot (5)
  3. phrobb (1)


Generated by MeetBot 0.1.4.