#opendaylight-docs: docs

Meeting started by colindixon at 19:09:18 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 19:09:24)
    1. migration of user and developer guide from asciidoc to rst (colindixon, 19:09:42)
    2. project-specific docs patches (colindixon, 19:10:04)

  2. migration to reST (colindixon, 19:10:07)
    1. we had the TWS not yesterday, but a week ago yesterday, nobody seemed to really object (colindixon, 19:10:28)
    2. colindixon has started pushing patches that migrate each project one by one (colindixon, 19:10:41)
    3. https://git.opendaylight.org/gerrit/#/q/topic:adoc2rst all patches have the topic adoc2rst in gerrit (colindixon, 19:11:10)

  3. project-specific docs patches (colindixon, 19:12:37)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we're staying at something like 8-10 patches inflight—mostly because projects are slow to update things (colindixon, 19:13:10)
    2. we have 5 "abandoned?" patches, that colindixon is going to really abandon at the end of the day, we had about 4-5 patcehs that were "abandoned?" that projects rescued (colindixon, 19:13:57)
    3. colindixon is trying to convert adoc to rst only on projects without in-flight patches at least for now (colindixon, 19:14:35)
    4. ACTION: colindixon to e-mail projects with no docs and no e-mail saying there won't be any (colindixon, 19:16:07)
    5. ACTION: colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work) (colindixon, 19:16:07)
    6. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:16:09)
    7. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc) (colindixon, 19:16:10)
    8. ACTION: colindixon to add fixing cross-project links (and notes) as things to check for after automatic conversion (colindixon, 19:16:11)
    9. ACTION: colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week (colindixon, 19:16:12)
    10. phrobb will jump on the call as soon as he is able. He has made contact with one of the leaders of RTD who seems very interested in helping us to bump up our limits (phrobb, 19:18:16)

  4. read the docs support (colindixon, 19:36:41)
    1. phrobb heard back from RTD people saying that they'd be happy to up our resource limits (colindixon, 19:36:57)
    2. we're waiting on taking next steps (colindixon, 19:37:43)
    3. phrobb asks how much time we'd need, right now 30-60 minutes will probably do us, if we try to do all javadoc for all classes, maybe 3-5 hours, we're not quite sure (colindixon, 19:40:32)


Meeting ended at 19:41:26 UTC (full logs).

Action items

  1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
  2. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
  3. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  4. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
  5. colindixon to add fixing cross-project links (and notes) as things to check for after automatic conversion
  6. colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week


Action items, by person

  1. colindixon
    1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
    2. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
    3. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    4. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
    5. colindixon to add fixing cross-project links (and notes) as things to check for after automatic conversion
    6. colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week
  2. phrobb
    1. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)


People present (lines said)

  1. colindixon (29)
  2. odl_meetbot (3)
  3. phrobb (3)


Generated by MeetBot 0.1.4.