#opendaylight-docs: docs

Meeting started by colindixon at 19:02:20 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:02:26)
    1. https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-08-30-19.05.html last week's meeting minutes (colindixon, 19:03:04)
    2. colindixon is in the process of e-mail projects which have no or no new documentation (colindixon, 19:03:34)
    3. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 logging that in the patch coments section of "MISSING" patches here (colindixon, 19:03:54)
    4. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:04:15)
    5. ACTION: colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version (colindixon, 19:04:32)
    6. ACTION: colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc (colindixon, 19:05:07)
    7. search in sphinx appears to be somewhat broken (colindixon, 19:07:45)
    8. ACTION: colindixon to help lisa caywood hunt people down and get the openstack docs updated (colindixon, 19:09:35)

  2. longer readthedocs times (colindixon, 19:10:43)
    1. how long do we expect readthedocs runs to take with sphinx javadoc enabled? do we want other domains? (colindixon, 19:11:20)
    2. zxiiro says that it would take hours, he'd recommend figuring something else out? (colindixon, 19:11:50)
    3. phrobb says they seem to be accommodating, colindixon and zxiiro say it will take autorelease style times, so 5-6 horus and maybe longer (colindixon, 19:13:38)
    4. colindixon notes that we're still at 4-5 minutes with pretty much everything migrated (colindixon, 19:14:15)
    5. three options: (1) do nothing, (2) ask them to run things that take many, many hours, (3) pre-builld javadoc on our side (colindixon, 19:15:19)
    6. zxiiro says that he's leaning toward (3), even if only because it will ensure less lag between patches being merged and showing up (colindixon, 19:18:06)

  3. Beau on the "beginner's guide" (colindixon, 19:19:47)
    1. this is as compared to getting started, which basically gets it installed, and runnig, but doing nothing (colindixon, 19:20:01)
    2. this would be the "how do you actually do something useful with your network and OpenDaylight" (colindixon, 19:20:24)
    3. Beau would like to lean on more knowledgeably OpenDaylight people to help him understand and document them (colindixon, 19:21:01)
    4. colindixon says that the best way to do that, would be to pick one scenario at a time and then finding the right people (colindixon, 19:23:33)
    5. beau says that NETCONF device management would be the first thing he'd like to do (colindixon, 19:23:46)
    6. CaseyODL was trying to gather scenarios like this at some point as well (colindixon, 19:26:15)
    7. ACTION: CaseyODL, colindixon, and beau to compare notes on what tutorials we're looking for and what we have (colindixon, 19:26:59)

  4. boron docs status (colindixon, 19:33:33)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 (colindixon, 19:33:34)
    2. we have some projects (~12) with no or no new documentation (colindixon, 19:34:14)
    3. we have 4 patches, 2 waiting for a +1 and 2 waiting for updates (colindixon, 19:34:26)
    4. https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open migration to rst (colindixon, 19:34:42)
    5. waiting for +1s from SNBI and OpenFlow plugin (colindixon, 19:34:58)
    6. SDNi is blcoked on an in-flight asciidoc patch (see above) (colindixon, 19:35:10)

  5. missing features in reST (colindixon, 19:38:56)
    1. cross-refernecing in reST: http://www.sphinx-doc.org/en/stable/rest.html#internal-links (colindixon, 19:39:19)
    2. http://www.sphinx-doc.org/en/stable/markup/inline.html#ref-role (colindixon, 19:39:54)
    3. https://sourceforge.net/p/numfig/wiki/Home/ this would allow for figure numbers (colindixon, 19:42:01)
    4. inline markup can't be nested, this is just true (colindixon, 19:43:34)
    5. http://www.sphinx-doc.org/en/stable/rest.html#inline-markup see here (colindixon, 19:43:35)
    6. ACTION: colindixon and/or zxiiro to file a bug and/or look into nested directives (colindixon, 19:44:43)
    7. ACTION: colindixon and/or zxiiro to look into a YANG pygment (colindixon, 19:49:49)


Meeting ended at 19:53:56 UTC (full logs).

Action items

  1. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  2. colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version
  3. colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
  4. colindixon to help lisa caywood hunt people down and get the openstack docs updated
  5. CaseyODL, colindixon, and beau to compare notes on what tutorials we're looking for and what we have
  6. colindixon and/or zxiiro to file a bug and/or look into nested directives
  7. colindixon and/or zxiiro to look into a YANG pygment


Action items, by person

  1. colindixon
    1. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    2. colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version
    3. colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
    4. colindixon to help lisa caywood hunt people down and get the openstack docs updated
    5. CaseyODL, colindixon, and beau to compare notes on what tutorials we're looking for and what we have
    6. colindixon and/or zxiiro to file a bug and/or look into nested directives
    7. colindixon and/or zxiiro to look into a YANG pygment


People present (lines said)

  1. colindixon (48)
  2. odl_meetbot (4)


Generated by MeetBot 0.1.4.