#opendaylight-docs: docs
Meeting started by colindixon at 20:02:06 UTC
(full logs).
Meeting summary
- agenda bashing (colindixon, 20:02:44)
- https://meetings.opendaylight.org/opendaylight-docs/2017/docs/opendaylight-docs-docs.2017-01-17-20.11.html
last week's meeting minutes (colindixon,
20:03:16)
- ACTION: colindixon to
help lisa caywood hunt people down and get the openstack docs
updated (colindixon,
20:05:37)
- ACTION: CaseyODL,
colindixon, Lisa and beau to compare notes on what tutorials we're
looking for and what we have (colindixon,
20:05:38)
- ACTION: colindixon to
work with anipbu to figure out how to provide new or updated
information for new projects and/or new features (colindixon,
20:05:40)
- ACTION: colindixon to
add a section to the release notes script to at least put in a TBD
for security advisories (colindixon,
20:05:41)
- ACTION: colindixon to
get notes on how to run the release notes generator and automate
it (colindixon,
20:05:42)
- CaseyODL says that we need to include all
publicly known security issues that are fixed in each release in the
relase notes to get the core infrastructure LF security badge
thing (colindixon,
20:07:48)
- OPNFV docs overview from ShuhamRathi (colindixon, 20:08:36)
- https://opnfv.readthedocs.io/en/latest/
first migration is done (colindixon,
20:09:24)
- there's a non-blocking bug where RTD shows a
build failure when the build is actually updating (colindixon,
20:09:47)
- http://www.sphinx-doc.org/en/stable/markup/inline.html#ref-role
how to handle hyperlinks (colindixon,
20:18:19)
- http://docs.opendaylight.org/en/latest/documentation.html#referencing-sections
the ODL-specific stuff (colindixon,
20:19:05)
- ACTION: zxiiro and
colindixon to look into breaking the build when we have broken :ref:
links (colindixon,
20:21:02)
- https://git.opendaylight.org/gerrit/#/c/49783/
documentation on how to create submodules (colindixon,
20:25:28)
- zxiiro says that we now build right the batch
on merge jobs by doing curl -X POST --data
"version_slug=$RTD_BUILD_VERSION"
https://readthedocs.org/build/opendaylight (colindixon,
20:28:54)
- in reality because master => latest and
stable/boron to stable-boron, I think we just build them all on
every merge (colindixon,
20:29:13)
- see other commentary from zxiiro in the full
logs (colindixon,
20:38:18)
- ACTION: colindixon to
migrate the common docs tasks off the wiki to documentation
https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks
(colindixon,
20:43:06)
- http://wiki.c2.com/?LazinessImpatienceHubris
(colindixon,
20:43:50)
Meeting ended at 20:44:57 UTC
(full logs).
Action items
- colindixon to help lisa caywood hunt people down and get the openstack docs updated
- CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have
- colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features
- colindixon to add a section to the release notes script to at least put in a TBD for security advisories
- colindixon to get notes on how to run the release notes generator and automate it
- zxiiro and colindixon to look into breaking the build when we have broken :ref: links
- colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks
Action items, by person
- colindixon
- colindixon to help lisa caywood hunt people down and get the openstack docs updated
- CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have
- colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features
- colindixon to add a section to the release notes script to at least put in a TBD for security advisories
- colindixon to get notes on how to run the release notes generator and automate it
- zxiiro and colindixon to look into breaking the build when we have broken :ref: links
- colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks
- zxiiro
- zxiiro and colindixon to look into breaking the build when we have broken :ref: links
People present (lines said)
- colindixon (28)
- zxiiro (18)
- odl_meetbot (4)
Generated by MeetBot 0.1.4.