#opendaylight-genius: genius
Meeting started by vorburger at 14:05:37 UTC
(full logs).
Meeting summary
- rollcall (vorburger, 14:05:49)
  - vorburger (vorburger,
    14:05:52)
- Andre Fredette (afredette,
    14:06:27)
- faseelak (vorburger,
    14:06:38)
- faseelak (faseelak,
    14:06:43)
 
 
- pending Reviews (vorburger, 14:06:47)
  - due to broken overall build, we're not merging
    anything today (vorburger,
    14:07:04)
 
 
- bug scrub (vorburger, 14:07:18)
  - https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&list_id=77005&product=genius
    (vorburger,
    14:07:27)
- we have 20 open bugs right now (last week we
    had 30 something) (vorburger,
    14:08:14)
- https://bugs.opendaylight.org/show_bug.cgi?id=7451
    (faseelak,
    14:11:56)
- shague (shague,
    14:13:13)
- ACTION: vorburger to
    raise helpdesk to get "ODL SR Target Milestone" everywhere, as e.g.
    https://bugs.opendaylight.org/show_bug.cgi?id=8224 does not have
    it (vorburger,
    14:13:46)
- ACTION: vorburger to
    also raise that we want 2 fields, one for Target/Fixed In and Found
    In (vorburger,
    14:14:17)
- there is a Version field where you can add the
    version. It is a manual process for committers to add the version
    choices (shague,
    14:15:48)
- all open bugs have assigned owners working on
    them (vorburger,
    14:16:20)
 
 
- JUnits status (vorburger, 14:16:41)
  - faseelak working on interface manager test
    coverage, uses vorburger component test infrastructure
    infrastructure (vorburger,
    14:17:36)
- ACTION: faseelak to
    check if https://git.opendaylight.org/gerrit/#/c/54811/ fixes the
    problem discussed on email (vorburger,
    14:18:11)
- https://git.opendaylight.org/gerrit/#/c/54811/
    (vorburger,
    14:18:13)
- faseelak 80% on lockmanager (vorburger,
    14:18:41)
- overall genius is still at only 40% as of
    today (vorburger,
    14:19:00)
- https://sonar.opendaylight.org/
    (faseelak,
    14:19:50)
- fcapsmanager has no tests, but may be removed,
    so we don't want to work on this (vorburger,
    14:20:05)
- resourcemanager is the one most needed tests
    and coverage (vorburger,
    14:20:28)
- ACTION: vorburger to
    put in basic test skeleton into resourcemanager (vorburger,
    14:20:42)
- ACTION: faseelak (or
    David?) to then extend resourcemanager with tests (vorburger,
    14:21:01)
 
 
- Carbon Workflow (vorburger, 14:21:24)
  - see shague's email (vorburger,
    14:22:56)
- vorburger questions why a branch was cut if we
    back patch cherry-pick everything from master to
    stable/carbon (vorburger,
    14:27:09)
- vorburger is warming up to the idea to,
    eventually, let projects release when they see fit, and have
    decoupled releases (vorburger,
    14:27:39)
 
 
- broken build (vorburger, 14:29:30)
  - faseelak raises that build has broken for too
    long (vorburger,
    14:29:45)
- eman is broken (vorburger,
    14:29:55)
- https://git.opendaylight.org/gerrit/#/c/54860/
    (vorburger,
    14:31:09)
- ACTION: vorburger
    afredette will jump on email thread to TSC started by
    faseelak (vorburger,
    14:32:33)
- https://git.opendaylight.org/gerrit/#/c/54425/7
    (shague,
    14:34:20)
- https://logs.opendaylight.org/releng/jenkins092/genius-verify-nitrogen-mvn33-openjdk8/27/console.log.gz
    (shague,
    14:34:43)
- https://logs.opendaylight.org/releng/jenkins092/genius-verify-nitrogen-mvn33-openjdk8/27/archives/interfacemanager/interfacemanager-impl/target/surefire-reports/org.opendaylight.genius.interfacemanager.test.InterfaceManagerConfigurationTest-output.txt.gz
    (vorburger,
    14:38:52)
- https://git.opendaylight.org/gerrit/#/c/54890/
    (shague,
    14:39:29)
- https://git.opendaylight.org/gerrit/#/q/topic:FlowEntity-immutable
    (vorburger,
    14:41:43)
- ACTION: shague to
    merge both the genius and netvirt together next week, once current
    build instability is over and more pressing bug fixes have been
    merged (vorburger,
    14:42:54)
 
Meeting ended at 14:43:26 UTC
(full logs).
Action items
  - vorburger to raise helpdesk to get "ODL SR Target Milestone" everywhere, as e.g. https://bugs.opendaylight.org/show_bug.cgi?id=8224 does not have it
- vorburger to also raise that we want 2 fields, one for Target/Fixed In and Found In
- faseelak to check if https://git.opendaylight.org/gerrit/#/c/54811/ fixes the problem discussed on email
- vorburger to put in basic test skeleton into resourcemanager
- faseelak (or David?) to then extend resourcemanager with tests
- vorburger afredette will jump on email thread to TSC started by faseelak
- shague to merge both the genius and netvirt together next week, once current build instability is over and more pressing bug fixes have been merged
Action items, by person
  -  afredette 
    - vorburger afredette will jump on email thread to TSC started by faseelak
 
-  faseelak 
    - faseelak to check if https://git.opendaylight.org/gerrit/#/c/54811/ fixes the problem discussed on email
- faseelak (or David?) to then extend resourcemanager with tests
- vorburger afredette will jump on email thread to TSC started by faseelak
 
-  shague 
    - shague to merge both the genius and netvirt together next week, once current build instability is over and more pressing bug fixes have been merged
 
-  vorburger 
    - vorburger to raise helpdesk to get "ODL SR Target Milestone" everywhere, as e.g. https://bugs.opendaylight.org/show_bug.cgi?id=8224 does not have it
- vorburger to also raise that we want 2 fields, one for Target/Fixed In and Found In
- vorburger to put in basic test skeleton into resourcemanager
- vorburger afredette will jump on email thread to TSC started by faseelak
 
People present (lines said)
  - vorburger (36)
- shague (5)
- faseelak (3)
- odl_meetbot (3)
- afredette (1)
Generated by MeetBot 0.1.4.