#opendaylight-genius: genius

Meeting started by vorburger at 14:13:16 UTC (full logs).

Meeting summary

  1. info in please (vorburger, 14:13:27)
    1. faseelak (faseelak, 14:13:40)
    2. vorburger (vorburger, 14:13:42)
    3. skitt (skitt, 14:13:45)
    4. edavsua (edavsua, 14:13:48)

  2. Gerrit Reviews (vorburger, 14:14:00)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (faseelak, 14:14:36)
    2. ACTION: Peri to review https://git.opendaylight.org/gerrit/#/c/55860/ (vorburger, 14:15:06)
    3. ACTION: faseelak will review https://git.opendaylight.org/gerrit/#/c/56760/ (vorburger, 14:15:28)
    4. https://git.opendaylight.org/gerrit/#/c/56570/ is ready for merge to stable/carbon, once it re-opens (vorburger, 14:15:59)
    5. ACTION: vorburger to re-review https://git.opendaylight.org/gerrit/#/c/53544/ (vorburger, 14:16:18)
    6. https://git.opendaylight.org/gerrit/#/c/56031/ to be considered in 2 weeks after DDF (master) (vorburger, 14:19:49)
    7. ACTION: edavsua wil review https://git.opendaylight.org/gerrit/#/c/56031/ (vorburger, 14:20:03)
    8. ACTION: faseelak vorburger will write a spec documenting proposal in https://git.opendaylight.org/gerrit/#/c/56031/ (vorburger, 14:22:09)

  3. Test Code Coverage (vorburger, 14:25:03)
    1. according to faseelak it's now at 42% up from 30% (vorburger, 14:25:32)
    2. biggest gaps are in mdsalutil, alivenessmonitor and fcaps-application (vorburger, 14:25:56)
    3. https://sonar.opendaylight.org/ (faseelak, 14:26:45)
    4. mdsalutil has a lot of @Deprecated. If we just cleaned up and got rid of all of that, the coverage would already look better (vorburger, 14:29:40)
    5. ACTION: vivek to table work at DDF for nitrogen to get rid of all @Deprecated code in genius mdsalutil (vorburger, 14:31:37)
    6. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open,25 (vorburger, 14:34:14)

  4. Reviewing very old stuck Gerrits, abandon? (vorburger, 14:34:41)
    1. https://git.opendaylight.org/gerrit/#/c/52334/ (vorburger, 14:35:57)
    2. that's waiting for openflow plugin merge https://git.opendaylight.org/gerrit/#/c/51498/ (vorburger, 14:36:39)
    3. ACTION: Hema_ will ping people having very old pending changes stuck with Merge Conflict (vorburger, 14:38:08)
    4. ACTION: Michael to rebase / review / merge https://git.opendaylight.org/gerrit/#/c/50192/ (vorburger, 14:38:27)


Meeting ended at 14:40:36 UTC (full logs).

Action items

  1. Peri to review https://git.opendaylight.org/gerrit/#/c/55860/
  2. faseelak will review https://git.opendaylight.org/gerrit/#/c/56760/
  3. vorburger to re-review https://git.opendaylight.org/gerrit/#/c/53544/
  4. edavsua wil review https://git.opendaylight.org/gerrit/#/c/56031/
  5. faseelak vorburger will write a spec documenting proposal in https://git.opendaylight.org/gerrit/#/c/56031/
  6. vivek to table work at DDF for nitrogen to get rid of all @Deprecated code in genius mdsalutil
  7. Hema_ will ping people having very old pending changes stuck with Merge Conflict
  8. Michael to rebase / review / merge https://git.opendaylight.org/gerrit/#/c/50192/


Action items, by person

  1. edavsua
    1. edavsua wil review https://git.opendaylight.org/gerrit/#/c/56031/
  2. faseelak
    1. faseelak will review https://git.opendaylight.org/gerrit/#/c/56760/
    2. faseelak vorburger will write a spec documenting proposal in https://git.opendaylight.org/gerrit/#/c/56031/
  3. vorburger
    1. vorburger to re-review https://git.opendaylight.org/gerrit/#/c/53544/
    2. faseelak vorburger will write a spec documenting proposal in https://git.opendaylight.org/gerrit/#/c/56031/
  4. UNASSIGNED
    1. Peri to review https://git.opendaylight.org/gerrit/#/c/55860/
    2. vivek to table work at DDF for nitrogen to get rid of all @Deprecated code in genius mdsalutil
    3. Hema_ will ping people having very old pending changes stuck with Merge Conflict
    4. Michael to rebase / review / merge https://git.opendaylight.org/gerrit/#/c/50192/


People present (lines said)

  1. vorburger (24)
  2. odl_meetbot (4)
  3. faseelak (3)
  4. skitt (1)
  5. edavsua (1)


Generated by MeetBot 0.1.4.