#opendaylight-genius: Genius Weekly

Meeting started by edavsua at 14:06:49 UTC (full logs).

Meeting summary

    1. edavsua (edavsua, 14:07:07)
    2. viveks (viveks, 14:07:11)
    3. Andre Fredette (afredette, 14:07:13)
    4. vorburger (vorburger, 14:07:15)

  1. idmanager improvement (Sai) (vorburger, 14:08:13)
    1. Shai is proposing to use the Id Manager to lease IPs in a DHCP use case (edavsua, 14:12:57)
    2. We'd need to add expiration times for the ids provided by the IdManager (edavsua, 14:13:39)
    3. this modification would be for Nitrogen release (edavsua, 14:14:10)

  2. Abstract DCN cleanup (vorburger, 14:15:37)
    1. SFC is not using Genius' DCN (edavsua, 14:18:47)

  3. Boron SR3 blocker bugs (edavsua, 14:20:14)
    1. https://git.opendaylight.org/gerrit/#/c/53472/ - this is the bug to include in the boron sr3 list (shague, 14:23:25)
    2. https://git.opendaylight.org/gerrit/#/c/53463/ already in list (shague, 14:23:55)
    3. https://git.opendaylight.org/gerrit/#/c/53686/ already in list (shague, 14:24:10)

  4. Unit Test Code Coverage (vorburger, 14:25:08)
    1. we need to analyze what code is not used anymore (edavsua, 14:26:43)
    2. alivenessmonitor and fcapsmanager may be removed (vorburger, 14:26:46)
    3. faseelak (faseelak, 14:26:52)
    4. resourcemanager may also be removed (because everyone is directly using the idmanager) (vorburger, 14:27:37)
    5. Brady Johnson (IRC only) (ebrjohn, 14:34:54)
    6. https://bluejeans.com/440027857/ (edavsua, 14:35:31)
    7. ACTION: vorburger to share TestIMdsalApiManager discussion on private email thread with genius-dev public list (vorburger, 14:39:45)

  5. Multiple VxLAN uplinks pending review (vorburger, 14:39:53)
    1. https://git.opendaylight.org/gerrit/#/c/52871/11 (faseelak, 14:41:23)
    2. ACTION: vorburger to review https://git.opendaylight.org/gerrit/#/c/52871/ if any concerns re. circular dependency (vorburger, 14:43:16)

  6. FlowEntity immutability (vorburger, 14:45:02)
    1. https://lists.opendaylight.org/pipermail/genius-dev/2017-March/001075.html (vorburger, 14:45:11)
    2. ACTION: vorburger will create a proposal for that (edavsua, 14:48:54)

  7. Review of pending Gerrit ready for merge (vorburger, 14:49:27)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:49:34)
    2. ACTION: vorburger to re-review https://git.opendaylight.org/gerrit/#/c/50371/ re. ITM test (vorburger, 14:53:21)


Meeting ended at 15:17:34 UTC (full logs).

Action items

  1. vorburger to share TestIMdsalApiManager discussion on private email thread with genius-dev public list
  2. vorburger to review https://git.opendaylight.org/gerrit/#/c/52871/ if any concerns re. circular dependency
  3. vorburger will create a proposal for that
  4. vorburger to re-review https://git.opendaylight.org/gerrit/#/c/50371/ re. ITM test


Action items, by person

  1. vorburger
    1. vorburger to share TestIMdsalApiManager discussion on private email thread with genius-dev public list
    2. vorburger to review https://git.opendaylight.org/gerrit/#/c/52871/ if any concerns re. circular dependency
    3. vorburger will create a proposal for that
    4. vorburger to re-review https://git.opendaylight.org/gerrit/#/c/50371/ re. ITM test


People present (lines said)

  1. vorburger (22)
  2. edavsua (18)
  3. ebrjohn (7)
  4. odl_meetbot (7)
  5. shague (3)
  6. faseelak (2)
  7. viveks (1)
  8. afredette (1)


Generated by MeetBot 0.1.4.