#opendaylight-genius: genius weekly

Meeting started by vorburger at 14:02:06 UTC (full logs).

Meeting summary

  1. Please #info in (vorburger, 14:02:28)
    1. Vishal (vthapar, 14:03:22)
    2. edavsua (edavsua, 14:04:16)
    3. vorburger (vorburger, 14:05:03)

  2. Agenda Bashing (vorburger, 14:05:09)
    1. https://trello.com/c/nSAVIWNl/27-meeting-agenda-2017-07-13 (vorburger, 14:05:16)
    2. viveks (viveks, 14:05:48)

  3. https://git.opendaylight.org/gerrit/#/c/59177/ (vorburger, 14:06:51)
    1. we do not need the JC for now, we can see if it is needed in future (viveks, 14:11:32)

  4. https://git.opendaylight.org/gerrit/#/c/54426/ (vorburger, 14:16:21)
    1. rebase and use test-genius-all (viveks, 14:17:00)
    2. ACTION: vorburger will do "test-genius-netvirt", vthapar can help look if CSIT fails (vorburger, 14:17:13)

  5. how to get traction on moving all @Deprecated genius.DJC to infrautils.JC ? (viveks, 14:18:17)
  6. how to get traction on moving all @Deprecated genius.DJC to infrautils.JC ? (vorburger, 14:18:19)
    1. start migration with Genius modules (viveks, 14:21:31)
    2. ACTION: vorburger to implement one instance to provide a sample (viveks, 14:23:15)
    3. vorburger to try out interfacemanager (vorburger, 14:23:52)

  7. Open Gerrits (vorburger, 14:24:18)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:24:22)
    2. Change 56031 - Michal to split it in utility and the usage part (viveks, 14:28:54)
    3. ACTION: vorburger split https://git.opendaylight.org/gerrit/#/c/56031/ (vorburger, 14:29:24)
    4. https://git.opendaylight.org/gerrit/#/c/57791/ Blueprint spec for Genius Interface model extensions to hold port-binding information (vorburger, 14:30:14)
    5. Change 57791 - leave it for now, or we can create a private branch for vpp integration? (viveks, 14:32:58)
    6. https://git.opendaylight.org/gerrit/#/c/53632/ (shague, 14:33:22)
    7. https://git.opendaylight.org/gerrit/50259 netvirt vpp patch (shague, 14:34:02)
    8. use augmentations on ietf-interfaces datamodel in Netvirt (viveks, 14:35:33)
    9. Change 59283 - review needed (viveks, 14:36:50)
    10. on the 59283 also include the netvirt counters work (shague, 14:37:47)
    11. Change 60237 - Needs Code-Review (viveks, 14:38:39)
    12. Change 60231 - Faseela to add component tests (viveks, 14:41:35)
    13. Change 60219 - Sam to review and merge (viveks, 14:44:59)
    14. Change 60067 - waiting for merge in stable/carbon (viveks, 14:49:03)
    15. https://git.opendaylight.org/gerrit/60268 (vthapar, 14:49:45)
    16. Change 60268 - change log line to 'debug', from 'info' (viveks, 14:58:48)


Meeting ended at 15:00:44 UTC (full logs).

Action items

  1. vorburger will do "test-genius-netvirt", vthapar can help look if CSIT fails
  2. vorburger to implement one instance to provide a sample
  3. vorburger split https://git.opendaylight.org/gerrit/#/c/56031/


Action items, by person

  1. vorburger
    1. vorburger will do "test-genius-netvirt", vthapar can help look if CSIT fails
    2. vorburger to implement one instance to provide a sample
    3. vorburger split https://git.opendaylight.org/gerrit/#/c/56031/
  2. vthapar
    1. vorburger will do "test-genius-netvirt", vthapar can help look if CSIT fails


People present (lines said)

  1. viveks (17)
  2. vorburger (15)
  3. odl_meetbot (4)
  4. vthapar (3)
  5. shague (3)
  6. edavsua (1)


Generated by MeetBot 0.1.4.