#opendaylight-genius: genius weekly

Meeting started by vorburger at 14:03:24 UTC (full logs).

Meeting summary

  1. info in (vorburger, 14:03:34)
    1. Vishal (vthapar, 14:03:45)
    2. skitt (skitt, 14:03:46)
    3. faseelak_ (faseelak_, 14:04:05)
    4. viveks (viveks, 14:04:12)
    5. https://lists.opendaylight.org/pipermail/genius-dev/2017-August/001797.html (vorburger, 14:04:37)
    6. netvirt already uses "Rebase if Necessary" (vorburger, 14:05:41)
    7. infrautils used to start with "Fast Forward only", but then changed it to "Rebase if Necessary" (vorburger, 14:06:55)
    8. edavsua (edavsua, 14:09:38)
    9. VOTE: Voted on "Shall the genius project change its Gerrit Submit Strategy from Merge if neccessary to Rebase if neccessary?" Results are (vorburger, 14:09:50)
    10. ACTION: vorburger will raise LF ticket for Gerrit submit change (vorburger, 14:11:14)

  2. idmanager Daexim integration OK? (vorburger, 14:11:22)
    1. https://git.opendaylight.org/gerrit/#/c/61769/ (vorburger, 14:11:26)
    2. https://git.opendaylight.org/gerrit/#/c/61769/4/idmanager/idmanager-impl/src/main/java/org/opendaylight/genius/idmanager/IdManager.java (vorburger, 14:11:44)
    3. ACTION: Faseela to prompt Muthu to review it as well (vorburger, 14:13:51)
    4. nobody seem to have any objections (vorburger, 14:14:02)

  3. https://git.opendaylight.org/gerrit/#/c/60265/ (vorburger, 14:14:28)
    1. https://git.opendaylight.org/gerrit/#/c/60265/ was the only use of this method in netvirt, which has been changed (vorburger, 14:15:58)
    2. ACTION: Faseela to +2 and merge when build passed (vorburger, 14:17:44)

  4. Next steps re. deprecating AsyncDataTreeChangeListener? (vorburger, 14:18:29)
    1. https://git.opendaylight.org/gerrit/#/c/59177/ (vorburger, 14:18:40)
    2. there was the idea to add clustered version as well, but that could come into a follow up change also (vorburger, 14:20:31)
    3. ACTION: vorburger to re-review it and +1 as David has taken his feedback into account (vorburger, 14:21:28)
    4. ACTION: Vishal to re-review and +2 and merge it if no other objections (vorburger, 14:22:31)
    5. ACTION: Vishal to see with David if he or him will do the follow-up to add the async part (vorburger, 14:25:41)

  5. FYI mdsal ordering problem (vorburger, 14:26:10)
    1. https://git.opendaylight.org/gerrit/#/c/60313/ (vorburger, 14:26:22)
    2. ACTION: vorburger cherry pick to Nitrogen (vorburger, 14:28:25)
    3. This (c/60313) is the patch to look at how to work around case of weird arbitrary looking comparison failures between actual YANG DataObject read from DS and expected objects from Xtend (vorburger, 14:30:53)

  6. review changes (vorburger, 14:31:12)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:31:19)
    2. FYI https://wiki.opendaylight.org/view/BestPractices/Coding_Guidelines#Utility_classes_with_only_static_methods (vorburger, 14:41:14)


Meeting ended at 14:55:11 UTC (full logs).

Action items

  1. vorburger will raise LF ticket for Gerrit submit change
  2. Faseela to prompt Muthu to review it as well
  3. Faseela to +2 and merge when build passed
  4. vorburger to re-review it and +1 as David has taken his feedback into account
  5. Vishal to re-review and +2 and merge it if no other objections
  6. Vishal to see with David if he or him will do the follow-up to add the async part
  7. vorburger cherry pick to Nitrogen


Action items, by person

  1. vorburger
    1. vorburger will raise LF ticket for Gerrit submit change
    2. vorburger to re-review it and +1 as David has taken his feedback into account
    3. vorburger cherry pick to Nitrogen
  2. UNASSIGNED
    1. Faseela to prompt Muthu to review it as well
    2. Faseela to +2 and merge when build passed
    3. Vishal to re-review and +2 and merge it if no other objections
    4. Vishal to see with David if he or him will do the follow-up to add the async part


People present (lines said)

  1. vorburger (32)
  2. odl_meetbot (6)
  3. edavsua (6)
  4. viveks (3)
  5. vthapar (2)
  6. skitt (2)
  7. faseelak_ (2)


Generated by MeetBot 0.1.4.