#opendaylight-genius: genius-weekly

Meeting started by vorburger at 14:05:23 UTC (full logs).

Meeting summary

  1. info in? (vorburger, 14:05:30)
    1. Vishal (vthapar, 14:05:31)
    2. edavsua (edavsua, 14:05:44)
    3. viveks (viveks, 14:06:13)
    4. faseelak (faseelak, 14:06:39)

  2. Agenda (vorburger, 14:06:58)
    1. https://trello.com/c/AFS8LqP6/35-meeting-agenda-2017-09-21 (vorburger, 14:07:00)

  3. Deprecation/Removal of any unused projects? (vorburger, 14:07:13)
    1. viveks explains that arputil used to be used only by alivenessmonitor, but shague_ clarified on list it's now used by netvirt, so can't remove (vorburger, 14:08:18)
    2. shague (shague_, 14:08:53)
    3. fcapsmanager, fcapsapplication, alivenessmonitor, resourcemanager are all not actively used currently (vorburger, 14:09:11)
    4. there is no "burning problem" to remove them, it's more just a general dont-keep-unused-code (vorburger, 14:09:51)
    5. fcapsmanager / fcapsapplication may be remove once statusdiag by faseelak in infrautils works (vorburger, 14:12:20)

  4. https://git.opendaylight.org/gerrit/#/q/topic:genius.DJC-to-infra.JC finally hopefully ready (vorburger, 14:12:44)
    1. ACTION: vorburger will request CSIT on genius and netvirt once https://git.opendaylight.org/gerrit/#/c/60303/ (vorburger, 14:16:09)

  5. Better share the load of reviewing "trivial" clean up changes (vorburger, 14:16:27)
    1. edavsua says that due to the rule to get x2 +1 to merge, it's sometimes difficult to get for simpler clean up changes (vorburger, 14:17:57)
    2. ACTION: viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua (vorburger, 14:20:21)
    3. ACTION: ALL use "Mechanical:" commit message prefix for changes which are clean up type changes done automatically by IDE like tools (vorburger, 14:22:34)
    4. ACTION: skitt edavsua vorburger ALL to include Hema as Reviewer on more changes (vorburger, 14:23:20)

  6. ready changes (vorburger, 14:26:15)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:26:22)
    2. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0+branch:master (vorburger, 14:26:42)
    3. ACTION: faseelak https://git.opendaylight.org/gerrit/#/c/61931/ (vorburger, 14:28:03)
    4. ACTION: viveks faseelak https://git.opendaylight.org/gerrit/#/c/63121/ (vorburger, 14:29:01)
    5. ACTION: vthapar https://git.opendaylight.org/gerrit/#/c/59177/ +1 and merge (vorburger, 14:30:37)
    6. https://git.opendaylight.org/gerrit/#/c/63381/ (vorburger, 14:31:06)
    7. https://git.opendaylight.org/gerrit/#/c/63372/5 (vorburger, 14:32:43)
    8. https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper (vorburger, 14:32:56)
    9. ACTION: vorburger skitt to further discuss https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper (vorburger, 14:34:42)
    10. https://git.opendaylight.org/gerrit/#/c/63120/ (vorburger, 14:35:50)
    11. ACTION: faseelak edavsua review https://git.opendaylight.org/gerrit/#/c/63120/ (vorburger, 14:37:44)
    12. https://git.opendaylight.org/gerrit/#/c/53998/ (vorburger, 14:38:01)
    13. ACTION: vorburger add vthapar to upcoming change generalizing the idea from https://git.opendaylight.org/gerrit/#/c/53998/ (vorburger, 14:42:57)

  7. Sonar Coverage (vorburger, 14:50:10)
    1. ACTION: vorburger maybe together with skitt to look at re-enabling InterfaceManagerConfigurationTest (vorburger, 14:51:03)
    2. ACTION: ALL look for projects that can be removed, because that will help to drive coverage up ;-) (vorburger, 14:51:35)

  8. Cookies (vorburger, 14:51:42)
    1. No cookies today, only samosas (vorburger, 14:51:52)


Meeting ended at 14:51:54 UTC (full logs).

Action items

  1. vorburger will request CSIT on genius and netvirt once https://git.opendaylight.org/gerrit/#/c/60303/
  2. viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua
  3. ALL use "Mechanical:" commit message prefix for changes which are clean up type changes done automatically by IDE like tools
  4. skitt edavsua vorburger ALL to include Hema as Reviewer on more changes
  5. faseelak https://git.opendaylight.org/gerrit/#/c/61931/
  6. viveks faseelak https://git.opendaylight.org/gerrit/#/c/63121/
  7. vthapar https://git.opendaylight.org/gerrit/#/c/59177/ +1 and merge
  8. vorburger skitt to further discuss https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper
  9. faseelak edavsua review https://git.opendaylight.org/gerrit/#/c/63120/
  10. vorburger add vthapar to upcoming change generalizing the idea from https://git.opendaylight.org/gerrit/#/c/53998/
  11. vorburger maybe together with skitt to look at re-enabling InterfaceManagerConfigurationTest
  12. ALL look for projects that can be removed, because that will help to drive coverage up ;-)


Action items, by person

  1. edavsua
    1. viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua
    2. skitt edavsua vorburger ALL to include Hema as Reviewer on more changes
    3. faseelak edavsua review https://git.opendaylight.org/gerrit/#/c/63120/
  2. faseelak
    1. faseelak https://git.opendaylight.org/gerrit/#/c/61931/
    2. viveks faseelak https://git.opendaylight.org/gerrit/#/c/63121/
    3. faseelak edavsua review https://git.opendaylight.org/gerrit/#/c/63120/
  3. viveks
    1. viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua
    2. viveks faseelak https://git.opendaylight.org/gerrit/#/c/63121/
  4. vorburger
    1. vorburger will request CSIT on genius and netvirt once https://git.opendaylight.org/gerrit/#/c/60303/
    2. skitt edavsua vorburger ALL to include Hema as Reviewer on more changes
    3. vorburger skitt to further discuss https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper
    4. vorburger add vthapar to upcoming change generalizing the idea from https://git.opendaylight.org/gerrit/#/c/53998/
    5. vorburger maybe together with skitt to look at re-enabling InterfaceManagerConfigurationTest
  5. vthapar
    1. viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua
    2. vthapar https://git.opendaylight.org/gerrit/#/c/59177/ +1 and merge
    3. vorburger add vthapar to upcoming change generalizing the idea from https://git.opendaylight.org/gerrit/#/c/53998/
  6. UNASSIGNED
    1. ALL use "Mechanical:" commit message prefix for changes which are clean up type changes done automatically by IDE like tools
    2. ALL look for projects that can be removed, because that will help to drive coverage up ;-)


People present (lines said)

  1. vorburger (39)
  2. odl_meetbot (6)
  3. vthapar (1)
  4. faseelak (1)
  5. viveks (1)
  6. edavsua (1)
  7. shague_ (1)


Generated by MeetBot 0.1.4.