#opendaylight-genius: genius-weekly

Meeting started by vorburger at 14:07:27 UTC (full logs).

Meeting summary

  1. /info in (vorburger, 14:07:32)
    1. edavsua (edavsua, 14:07:36)
    2. viveks (viveks, 14:07:42)
    3. faseelak (faseelak, 14:09:03)

  2. Transactions framework (edavsua, 14:11:11)
  3. topic Transaction Utility (vorburger, 14:13:34)
    1. https://git.opendaylight.org/gerrit/#/c/63372/ (vorburger, 14:13:35)
    2. https://git.opendaylight.org/gerrit/#/c/63372/8/itm/itm-impl/src/main/java/org/opendaylight/genius/itm/confighelpers/ItmTunnelAggregationHelper.java (vorburger, 14:14:00)
    3. https://git.opendaylight.org/gerrit/#/c/63372/8/mdsalutil/mdsalutil-api/src/main/java/org/opendaylight/genius/infra/ManagedNewTransactionRunnerImpl.java (vorburger, 14:16:12)
    4. viveks raises idea to launch concerted effort to migrate genius to this (vorburger, 14:20:48)
    5. session at the DDF next week for more discussion about this, and future plans (incl https://git.opendaylight.org/gerrit/#/c/63471/) (vorburger, 14:22:00)
    6. this utility prevents transaction leaks by automatically submit(), cancel() and close() Txs (vorburger, 14:22:42)

  4. FutureRpcResults (vorburger, 14:23:12)
    1. https://git.opendaylight.org/gerrit/#/c/63413/ (vorburger, 14:23:25)
    2. https://git.opendaylight.org/gerrit/#/c/63413/9/interfacemanager/interfacemanager-impl/src/main/java/org/opendaylight/genius/interfacemanager/rpcservice/InterfaceManagerRpcService.java (vorburger, 14:24:06)
    3. viveks proposes to have a slide about this in the genius oxygen plan side deck (vorburger, 14:30:07)

  5. DataBrokerFailures (vorburger, 14:30:49)
    1. https://git.opendaylight.org/gerrit/#/c/63120/ (vorburger, 14:31:29)
    2. https://git.opendaylight.org/gerrit/#/c/63121/5 (vorburger, 14:31:51)
    3. https://git.opendaylight.org/gerrit/#/c/63121/5/lockmanager/lockmanager-impl/src/test/java/org/opendaylight/genius/lockmanager/tests/LockManagerTest.java (vorburger, 14:32:11)

  6. Pending changes ready for merge (vorburger, 14:35:06)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:35:15)
    2. https://git.opendaylight.org/gerrit/#/c/63323/ (vorburger, 14:35:23)
    3. Hema asks us to wait on this (vorburger, 14:35:40)
    4. https://git.opendaylight.org/gerrit/#/c/63787/ (vorburger, 14:35:59)
    5. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (viveks, 14:37:46)
    6. ACTION: viveks to ask Vishal & Muthu to review https://git.opendaylight.org/gerrit/#/c/63787/ (vorburger, 14:40:24)
    7. https://git.opendaylight.org/gerrit/#/c/63505/ (vorburger, 14:41:43)
    8. ACTION: Hema to review https://git.opendaylight.org/gerrit/#/c/63505/ (vorburger, 14:41:57)
    9. ACTION: faseelak to review https://git.opendaylight.org/gerrit/#/c/63505/ (vorburger, 14:42:59)
    10. https://git.opendaylight.org/gerrit/#/c/63950/ (vorburger, 14:43:11)
    11. ACTION: Hema to review and just merge https://git.opendaylight.org/gerrit/#/c/63950/ (vorburger, 14:43:21)
    12. https://git.opendaylight.org/gerrit/#/c/63481/ (vorburger, 14:43:59)
    13. this one is in carbon, and only in carbon, why? (vorburger, 14:44:10)
    14. ACTION: viveks to follow-up on https://git.opendaylight.org/gerrit/#/c/63481/ with reporter (incl. why on carbon only, not nitrogen and master) (vorburger, 14:47:13)

  7. David new listener Executor (vorburger, 14:51:22)
    1. https://git.opendaylight.org/gerrit/#/c/63799/ (vorburger, 14:57:18)

  8. Documentation for genius (vorburger, 15:01:39)
    1. ACTION: EVERYONE let's revive the genius developer guide documentation! (vorburger, 15:02:50)

  9. genius master branch state (vorburger, 15:11:14)
    1. earlier today we broke master, it's fixed now, you need to rebase if you have strange build compliation failures (vorburger, 15:11:45)


Meeting ended at 15:11:48 UTC (full logs).

Action items

  1. viveks to ask Vishal & Muthu to review https://git.opendaylight.org/gerrit/#/c/63787/
  2. Hema to review https://git.opendaylight.org/gerrit/#/c/63505/
  3. faseelak to review https://git.opendaylight.org/gerrit/#/c/63505/
  4. Hema to review and just merge https://git.opendaylight.org/gerrit/#/c/63950/
  5. viveks to follow-up on https://git.opendaylight.org/gerrit/#/c/63481/ with reporter (incl. why on carbon only, not nitrogen and master)
  6. EVERYONE let's revive the genius developer guide documentation!


Action items, by person

  1. faseelak
    1. faseelak to review https://git.opendaylight.org/gerrit/#/c/63505/
  2. viveks
    1. viveks to ask Vishal & Muthu to review https://git.opendaylight.org/gerrit/#/c/63787/
    2. viveks to follow-up on https://git.opendaylight.org/gerrit/#/c/63481/ with reporter (incl. why on carbon only, not nitrogen and master)
  3. UNASSIGNED
    1. Hema to review https://git.opendaylight.org/gerrit/#/c/63505/
    2. Hema to review and just merge https://git.opendaylight.org/gerrit/#/c/63950/
    3. EVERYONE let's revive the genius developer guide documentation!


People present (lines said)

  1. vorburger (41)
  2. odl_meetbot (5)
  3. edavsua (5)
  4. faseelak (2)
  5. viveks (2)
  6. skitt (0)


Generated by MeetBot 0.1.4.