#opendaylight-genius: genius-weekly

Meeting started by vorburger at 14:03:05 UTC (full logs).

Meeting summary

  1. Please #info in ... (vorburger, 14:03:17)
    1. vorburger (vorburger, 14:03:24)
    2. faseelak (faseelak, 14:03:29)
    3. shague (shague, 14:03:53)

  2. agenda bashing (vorburger, 14:04:47)
    1. https://trello.com/c/dQKgWchC/40-meeting-agenda-2017-11-02 (vorburger, 14:04:49)
    2. CSIT before merge (vorburger, 14:04:58)
    3. bug scrub (vorburger, 14:05:03)
    4. Gerrit scrub (vorburger, 14:05:14)
    5. Vishal (vthapar, 14:05:18)

  3. CSiT failures following merge of Tom's recent change (vorburger, 14:07:46)
    1. ACTION: faseelak is looking through CSIT log to try understand failure (vorburger, 14:08:04)
    2. https://git.opendaylight.org/gerrit/#/c/64544/ (vorburger, 14:08:34)
    3. https://git.opendaylight.org/gerrit/#/c/65016/ (vorburger, 14:08:48)
    4. https://git.opendaylight.org/gerrit/#/c/64544/ patch causing CSIT problems (shague, 14:16:27)
    5. https://git.opendaylight.org/gerrit/#/c/65016/ revert patch looks to fix csit tests (shague, 14:16:48)
    6. https://jenkins.opendaylight.org/releng/view/netvirt/job/netvirt-csit-1node-openstack-ocata-gate-stateful-oxygen/226/ csit showing revert passing (shague, 14:17:12)
    7. tom finds line 77 was accidentally removed (shague, 14:18:12)
    8. tpantelis just saw the problem, live while in the meeting (vorburger, 14:18:14)
    9. ACTION: Tom Pantelis will raise a new Gerrit ASAP, we won't merge the revert (vorburger, 14:18:53)
    10. Tom thanks Faseela for having pointed him in the right direction to see what was wrong in the clean up patch that broke CSIT (vorburger, 14:19:18)

  4. What patches shall we run CSIT on? (vorburger, 14:19:36)
    1. Clean-up patches to be split as dependant reviews and CSIT to be run on final patch (faseelak, 14:23:08)

  5. Listener patches (vorburger, 14:23:31)
    1. Hema had some questions, David couldn't make it, but Tom is with us for the first time (welcome!!), and was involved in the new listeners (vorburger, 14:24:05)

  6. Gerrit Reviews (vorburger, 14:36:12)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:36:22)
    2. https://git.opendaylight.org/gerrit/#/c/63323/ (vorburger, 14:36:54)
    3. ACTION: Hema will rebase https://git.opendaylight.org/gerrit/#/c/63324/ and we'll merge it and the c/63323/ for stable/nitrogen together (vorburger, 14:39:04)
    4. https://git.opendaylight.org/gerrit/#/c/64623/ (vorburger, 14:39:57)
    5. ACTION: Hema is -1 this one based on the previous discussion with Tom and will follow-up with David and Tom (vorburger, 14:40:48)
    6. https://git.opendaylight.org/gerrit/#/c/64625/ (vorburger, 14:41:10)
    7. ACTION: Hema will do that -1 this one based on the previous discussion with Tom and will follow-up with David and Tom (vorburger, 14:42:06)
    8. https://git.opendaylight.org/gerrit/#/c/65008/ (vorburger, 14:42:50)
    9. ACTION: faseelak will run genius CSIT and merge it when that passes (vorburger, 14:45:12)
    10. https://git.opendaylight.org/gerrit/#/c/64844/ (vorburger, 14:45:32)
    11. ACTION: vorburger will self merge https://git.opendaylight.org/gerrit/#/c/64844/ once Tom's patch has gone in (vorburger, 14:46:39)
    12. fix for CSIT failure https://git.opendaylight.org/gerrit/#/c/65049/1 (faseelak, 14:46:57)
    13. https://git.opendaylight.org/gerrit/#/c/64762/ (vorburger, 14:47:06)
    14. ACTION: Hema will do also -1 this 3rd one based on the previous discussion with Tom and will follow-up with David and Tom (vorburger, 14:47:23)

  7. JIRA bug scrubbing (vorburger, 14:47:47)
    1. https://jira.opendaylight.org/issues/?filter=10136 (vorburger, 14:47:59)
    2. https://jira.opendaylight.org/browse/GENIUS-56 (vorburger, 14:48:48)
    3. lets review the JIRAs int he other order... ;-) (vorburger, 14:49:51)
    4. https://jira.opendaylight.org/browse/GENIUS-77 (vorburger, 14:49:53)
    5. awaiting mor information, logs from original issue were wiped out (vthapar, 14:51:36)
    6. ACTION: vthapar to follow up on this (vthapar, 14:51:46)
    7. https://jira.opendaylight.org/browse/GENIUS-85 (vorburger, 14:52:13)
    8. Faseela says there was a gerrit for this already? (vorburger, 14:53:39)
    9. ACTION: vthapar will update bug with latest status and next step (vorburger, 14:53:51)
    10. (vorburger, 14:54:21)
    11. https://jira.opendaylight.org/browse/GENIUS-32 (vorburger, 14:54:26)
    12. ACTION: faseela to update (vorburger, 14:57:58)
    13. https://jira.opendaylight.org/browse/GENIUS-86 (vorburger, 14:58:19)
    14. ACTION: faseelak will get in touch with Kency to get this one moving (vorburger, 14:58:48)
    15. https://jira.opendaylight.org/browse/GENIUS-94 (vorburger, 14:58:59)
    16. closed (vorburger, 14:59:02)
    17. https://jira.opendaylight.org/browse/GENIUS-90 (vorburger, 14:59:36)
    18. ACTION: vthapar will eventually look at this we said last week (vorburger, 14:59:50)
    19. ACTION: edwin will provide input on failures seen in the related patch (vorburger, 15:00:35)


Meeting ended at 15:01:22 UTC (full logs).

Action items

  1. faseelak is looking through CSIT log to try understand failure
  2. Tom Pantelis will raise a new Gerrit ASAP, we won't merge the revert
  3. Hema will rebase https://git.opendaylight.org/gerrit/#/c/63324/ and we'll merge it and the c/63323/ for stable/nitrogen together
  4. Hema is -1 this one based on the previous discussion with Tom and will follow-up with David and Tom
  5. Hema will do that -1 this one based on the previous discussion with Tom and will follow-up with David and Tom
  6. faseelak will run genius CSIT and merge it when that passes
  7. vorburger will self merge https://git.opendaylight.org/gerrit/#/c/64844/ once Tom's patch has gone in
  8. Hema will do also -1 this 3rd one based on the previous discussion with Tom and will follow-up with David and Tom
  9. vthapar to follow up on this
  10. vthapar will update bug with latest status and next step
  11. faseela to update
  12. faseelak will get in touch with Kency to get this one moving
  13. vthapar will eventually look at this we said last week
  14. edwin will provide input on failures seen in the related patch


Action items, by person

  1. faseelak
    1. faseelak is looking through CSIT log to try understand failure
    2. faseelak will run genius CSIT and merge it when that passes
    3. faseelak will get in touch with Kency to get this one moving
  2. vorburger
    1. vorburger will self merge https://git.opendaylight.org/gerrit/#/c/64844/ once Tom's patch has gone in
  3. vthapar
    1. vthapar to follow up on this
    2. vthapar will update bug with latest status and next step
    3. vthapar will eventually look at this we said last week
  4. UNASSIGNED
    1. Tom Pantelis will raise a new Gerrit ASAP, we won't merge the revert
    2. Hema will rebase https://git.opendaylight.org/gerrit/#/c/63324/ and we'll merge it and the c/63323/ for stable/nitrogen together
    3. Hema is -1 this one based on the previous discussion with Tom and will follow-up with David and Tom
    4. Hema will do that -1 this one based on the previous discussion with Tom and will follow-up with David and Tom
    5. Hema will do also -1 this 3rd one based on the previous discussion with Tom and will follow-up with David and Tom
    6. faseela to update
    7. edwin will provide input on failures seen in the related patch


People present (lines said)

  1. vorburger (57)
  2. odl_meetbot (8)
  3. shague (5)
  4. vthapar (3)
  5. faseelak (3)
  6. skitt (1)
  7. Vishal (0)


Generated by MeetBot 0.1.4.