#opendaylight-genius: genius-weekly

Meeting started by vorburger at 15:07:32 UTC (full logs).

Meeting summary

  1. Please #Info in everyone present (vorburger, 15:07:53)
    1. viveks (viveks, 15:08:24)
    2. vorburger (vorburger, 15:10:03)
    3. shague (shague, 15:10:07)
    4. edavsua (edavsua, 15:10:08)
    5. skitt (skitt, 15:10:08)
    6. faseelak (faseelak, 15:10:15)

  2. Agenda Bashing (vorburger, 15:10:47)
    1. OOM issues: GENIUS-96 & GENIUS-96 (vorburger, 15:11:11)
    2. New Projects having overlap with GENIUS: GNT & Telemetry (vorburger, 15:11:21)
    3. bug scrub : https://jira.opendaylight.org/projects/GENIUS/issues/GENIUS-92?filter=allopenissues (vorburger, 15:11:47)
    4. ready changes: https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:11:56)
    5. How to proceed with the migration of listeners? (vorburger, 15:12:03)
    6. https://review.openstack.org/518540 - networking-odl patch to help with OOM issue (shague, 15:13:26)

  3. OOM issues (vorburger, 15:13:30)
    1. michael had fixed some of the OOM issues in openflowplugin (faseelak, 15:14:51)

  4. New Projects having overlap with GENIUS: GNT & Telemetry (vorburger, 15:17:07)
    1. viveks to send an email indicating the same (faseelak, 15:21:25)
    2. discussion on where codehale matrix wrapper whould be placed (faseelak, 15:27:06)
    3. vorburger says it should be in infrautils as JC is going to be the first user for the same (faseelak, 15:27:40)

  5. CSIT for diagstatus (faseelak, 15:29:33)
    1. discussion on how to test utilities provided by infrautils (faseelak, 15:29:51)

  6. how to proceed with migration of listeners (faseelak, 15:30:42)
  7. FutureRpcResults (vorburger, 15:43:24)
    1. discussion on whether we should throw exceptions to make rpc fail (faseelak, 15:49:49)
    2. vorburger suggests to change the rpc results for genuine expected cases (faseelak, 15:58:37)

  8. Gerrit Reviews (vorburger, 16:04:33)
    1. https://git.opendaylight.org/gerrit/#/c/65299/ (vorburger, 16:04:36)
    2. ACTION: viveks review https://git.opendaylight.org/gerrit/#/c/65299/ (vorburger, 16:04:45)


Meeting ended at 16:06:14 UTC (full logs).

Action items

  1. viveks review https://git.opendaylight.org/gerrit/#/c/65299/


Action items, by person

  1. viveks
    1. viveks review https://git.opendaylight.org/gerrit/#/c/65299/


People present (lines said)

  1. vorburger (18)
  2. faseelak (11)
  3. odl_meetbot (5)
  4. shague (2)
  5. skitt (1)
  6. edavsua (1)
  7. viveks (1)


Generated by MeetBot 0.1.4.