#opendaylight-genius: genius-weekly

Meeting started by vorburger at 15:06:02 UTC (full logs).

Meeting summary

  1. Everyone please #info in.. (vorburger, 15:06:15)
    1. skitt (skitt, 15:06:20)
    2. vorburger (vorburger, 15:06:20)
    3. edavsua (edavsua, 15:07:25)
    4. faseelak (faseelak, 15:07:43)
    5. ACTION: skitt will bring virtual food and drink to the next weekly meeting ;-) (vorburger, 15:10:13)
    6. faseelak had run netvirt csit on genius stable/nitrogen patches till yesterday (faseelak, 15:10:23)
    7. https://docs.google.com/spreadsheets/d/1sxjIx5DIvaR4Lix4o8kNTWvIQX_0KqD61UNhy3qB1R0/edit#gid=461297039 (shague, 15:10:48)
    8. ACTION: faseelak to check the csit failure in netvirt to figure out which module is failing (faseelak, 15:11:19)

  2. Broken CSIT (vorburger, 15:13:15)
    1. ACTION: vorburger to check openflowplugin patches to analyse whether they are causing csti failures (faseelak, 15:13:16)

  3. Agenda bashing (vorburger, 15:13:43)
    1. https://trello.com/c/4z0r4TU8/44-meeting-agenda-2017-11-30 (vorburger, 15:13:50)

  4. David: Listener scale test results? (vorburger, 15:14:39)
    1. ACTION: Hema will finish the review on listeners (edavsua, 15:18:32)
    2. ACTION: Vivek and Edwin will comment on the scale tests by email (edavsua, 15:19:23)

  5. DJC removal (vorburger, 15:19:46)
    1. https://git.opendaylight.org/gerrit/#/c/66064/ just got merged (vorburger, 15:20:06)
    2. ACTION: vorburger to update email thread and Weather item Wiki page (vorburger, 15:20:20)

  6. Upgrade Race Condition (vorburger, 15:20:42)
    1. https://git.opendaylight.org/gerrit/#/c/66050/ (vorburger, 15:20:48)
    2. ACTION: faseelak to review it (vorburger, 15:21:13)

  7. SingleTransactionDataBroker with RetryingManagedNewTransactionRunner (vorburger, 15:21:49)
    1. https://git.opendaylight.org/gerrit/#/c/65812/ (vorburger, 15:21:58)
    2. viveks (viveks, 15:23:58)
    3. just go merged (vorburger, 15:29:19)
    4. keep an eye on CSIT to see if more starts failing (vorburger, 15:29:30)
    5. ACTION: vorburger rebase https://git.opendaylight.org/gerrit/#/c/66072/ and run CSIT there (vorburger, 15:30:23)

  8. InterfaceManagerService API without RpcResult (vorburger, 15:30:48)
    1. https://git.opendaylight.org/gerrit/#/c/65004/ (vorburger, 15:30:57)
    2. ACTION: edavsua to review https://git.opendaylight.org/gerrit/#/c/65004/ and merge it if is OK (vorburger, 15:31:52)

  9. Id manager: use transaction manager (vorburger, 15:32:09)
    1. https://git.opendaylight.org/gerrit/#/c/64726/ (vorburger, 15:32:15)
    2. ACTION: faseelak to review https://git.opendaylight.org/gerrit/#/c/64726/ and merge if she's OK with it (vorburger, 15:33:07)

  10. Resource batcher clean-up, phase 1 (vorburger, 15:33:47)
    1. https://git.opendaylight.org/gerrit/#/c/65675/ (vorburger, 15:33:52)
    2. ACTION: skitt to look at why its causing CSIT failures (vorburger, 15:34:03)

  11. Review other pending Gerrits (vorburger, 15:34:32)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:34:35)
    2. https://git.opendaylight.org/gerrit/#/c/64620/ (vorburger, 15:35:24)
    3. viveks says scale testing was succesful (vorburger, 15:35:48)
    4. ACTION: viveks to merge https://git.opendaylight.org/gerrit/#/c/64620/ (vorburger, 15:36:10)
    5. https://git.opendaylight.org/gerrit/#/c/64762/ (vorburger, 15:36:26)
    6. https://git.opendaylight.org/gerrit/#/c/58233/ (vorburger, 15:36:50)
    7. ACTION: faseelak to self -1 the WIP https://git.opendaylight.org/gerrit/#/c/58233/ (vorburger, 15:37:46)
    8. https://git.opendaylight.org/gerrit/#/c/65923/ (vorburger, 15:38:09)
    9. ACTION: vorburger to review and merge https://git.opendaylight.org/gerrit/#/c/65923/ (vorburger, 15:38:33)
    10. https://git.opendaylight.org/gerrit/#/c/66096/ (vorburger, 15:39:23)
    11. ACTION: faseelak to peer review and merge https://git.opendaylight.org/gerrit/#/c/66096/ (vorburger, 15:40:07)
    12. https://git.opendaylight.org/gerrit/#/c/66097/ (vorburger, 15:40:14)
    13. ACTION: edavsua to review and merge https://git.opendaylight.org/gerrit/#/c/66097/ (vorburger, 15:41:03)
    14. ACTION: faseelak to review and merge https://git.opendaylight.org/gerrit/#/c/66097/ (vorburger, 15:41:08)
    15. ACTION: Hema to review and merge https://git.opendaylight.org/gerrit/#/c/66097/ (vorburger, 15:41:51)

  12. Question about MNTR and retries (vorburger, 15:42:57)
    1. https://git.opendaylight.org/gerrit/#/c/66097/2/itm/itm-impl/src/main/java/org/opendaylight/genius/itm/confighelpers/ItmInternalTunnelAddWorker.java (vorburger, 15:43:00)
    2. interface ManagedNewTransactionRunner has 2 different implementations: ManagedNewTransactionRunnerImpl VS RetryingManagedNewTransactionRunner (vorburger, 15:45:05)

  13. OptimisticLockFailedException (vorburger, 15:46:38)
    1. https://git.opendaylight.org/gerrit/#/c/65726/3 (faseelak, 15:46:40)
    2. https://jira.opendaylight.org/browse/NETVIRT-1023 (vorburger, 15:46:52)
    3. dimple pointed out that the above patch is causing the bug NETVIRT-1023 (faseelak, 15:49:36)


Meeting ended at 15:49:50 UTC (full logs).

Action items

  1. skitt will bring virtual food and drink to the next weekly meeting ;-)
  2. faseelak to check the csit failure in netvirt to figure out which module is failing
  3. vorburger to check openflowplugin patches to analyse whether they are causing csti failures
  4. Hema will finish the review on listeners
  5. Vivek and Edwin will comment on the scale tests by email
  6. vorburger to update email thread and Weather item Wiki page
  7. faseelak to review it
  8. vorburger rebase https://git.opendaylight.org/gerrit/#/c/66072/ and run CSIT there
  9. edavsua to review https://git.opendaylight.org/gerrit/#/c/65004/ and merge it if is OK
  10. faseelak to review https://git.opendaylight.org/gerrit/#/c/64726/ and merge if she's OK with it
  11. skitt to look at why its causing CSIT failures
  12. viveks to merge https://git.opendaylight.org/gerrit/#/c/64620/
  13. faseelak to self -1 the WIP https://git.opendaylight.org/gerrit/#/c/58233/
  14. vorburger to review and merge https://git.opendaylight.org/gerrit/#/c/65923/
  15. faseelak to peer review and merge https://git.opendaylight.org/gerrit/#/c/66096/
  16. edavsua to review and merge https://git.opendaylight.org/gerrit/#/c/66097/
  17. faseelak to review and merge https://git.opendaylight.org/gerrit/#/c/66097/
  18. Hema to review and merge https://git.opendaylight.org/gerrit/#/c/66097/


Action items, by person

  1. edavsua
    1. edavsua to review https://git.opendaylight.org/gerrit/#/c/65004/ and merge it if is OK
    2. edavsua to review and merge https://git.opendaylight.org/gerrit/#/c/66097/
  2. faseelak
    1. faseelak to check the csit failure in netvirt to figure out which module is failing
    2. faseelak to review it
    3. faseelak to review https://git.opendaylight.org/gerrit/#/c/64726/ and merge if she's OK with it
    4. faseelak to self -1 the WIP https://git.opendaylight.org/gerrit/#/c/58233/
    5. faseelak to peer review and merge https://git.opendaylight.org/gerrit/#/c/66096/
    6. faseelak to review and merge https://git.opendaylight.org/gerrit/#/c/66097/
  3. skitt
    1. skitt will bring virtual food and drink to the next weekly meeting ;-)
    2. skitt to look at why its causing CSIT failures
  4. viveks
    1. viveks to merge https://git.opendaylight.org/gerrit/#/c/64620/
  5. vorburger
    1. vorburger to check openflowplugin patches to analyse whether they are causing csti failures
    2. vorburger to update email thread and Weather item Wiki page
    3. vorburger rebase https://git.opendaylight.org/gerrit/#/c/66072/ and run CSIT there
    4. vorburger to review and merge https://git.opendaylight.org/gerrit/#/c/65923/
  6. UNASSIGNED
    1. Hema will finish the review on listeners
    2. Vivek and Edwin will comment on the scale tests by email
    3. Hema to review and merge https://git.opendaylight.org/gerrit/#/c/66097/


People present (lines said)

  1. vorburger (55)
  2. faseelak (10)
  3. odl_meetbot (7)
  4. skitt (5)
  5. edavsua (3)
  6. shague (1)
  7. viveks (1)


Generated by MeetBot 0.1.4.