#opendaylight-genius: Genius Weekly 2017-08-03

Meeting started by vthapar at 14:00:46 UTC (full logs).

Meeting summary

  1. rollcall and agenda bashing (vthapar, 14:01:37)
    1. Vishal (vthapar, 14:02:42)
    2. https://trello.com/c/MJiDOxBz/30-meeting-agenda-2017-08-03 Agenda for today (vthapar, 14:04:49)
    3. edavsua (edavsua, 14:05:32)
    4. faseelak (faseelak, 14:06:22)

  2. Service Recovery Spec (vthapar, 14:07:28)
    1. https://git.opendaylight.org/gerrit/58693 (vthapar, 14:07:38)
    2. review commens from faseelak and shague addressed (vthapar, 14:08:40)
    3. would like this to get merge so code can start coming in (vthapar, 14:08:53)

  3. Status Reporting in interfacemanager and ITM (vthapar, 14:09:56)
    1. way status is reported post blueprint migration is not consistent (vthapar, 14:10:21)
    2. earlier single provider was managing all listeners so could report overall status (vthapar, 14:10:45)
    3. with BP each listener is independent so provider doesn't know if it actually came up or not (vthapar, 14:11:16)
    4. so providers can wrongly post status as Operational to SnD even though listeners are still in progress (vthapar, 14:11:47)

  4. patches (vthapar, 14:12:43)
    1. https://git.opendaylight.org/gerrit/59177 Listener framework (vthapar, 14:13:20)
    2. some util classes in mdsal are using old controller version of cluster apis, should move to new MDSAL versions (vthapar, 14:15:36)
    3. ACTION: edavsua will work on cleanup (vthapar, 14:15:57)
    4. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 patches ready for review (vthapar, 14:16:43)
    5. https://git.opendaylight.org/gerrit/#/c/54426/ (vthapar, 14:18:51)
    6. https://git.opendaylight.org/gerrit/#/q/status:open+project:genius+branch:master+topic:cleanup (vthapar, 14:21:32)
    7. cleanup patches to be reviewed and merged, small changes (vthapar, 14:21:48)
    8. https://git.opendaylight.org/gerrit/#/c/60131/ (vthapar, 14:22:15)
    9. https://git.opendaylight.org/gerrit/#/c/51445/ Basic service binding framework (vthapar, 14:25:59)
    10. ACTION: faseelak to set topic branch correctly for service binding framework patches (vthapar, 14:27:31)

  5. announcements (vthapar, 14:27:37)
    1. next week is our code freeze (vthapar, 14:27:53)

  6. cookies (vthapar, 14:28:01)


Meeting ended at 14:28:08 UTC (full logs).

Action items

  1. edavsua will work on cleanup
  2. faseelak to set topic branch correctly for service binding framework patches


Action items, by person

  1. edavsua
    1. edavsua will work on cleanup
  2. faseelak
    1. faseelak to set topic branch correctly for service binding framework patches


People present (lines said)

  1. vthapar (32)
  2. odl_meetbot (5)
  3. faseelak (1)
  4. edavsua (1)


Generated by MeetBot 0.1.4.