#opendaylight-genius: genius-weekly

Meeting started by vorburger at 15:04:15 UTC (full logs).

Meeting summary

  1. Everyone please #info in.... (vorburger, 15:04:30)
    1. vpickard (vpickard, 15:04:31)
    2. viveks (viveks, 15:04:33)
    3. vorburger (vorburger, 15:04:34)

  2. Agenda Bashing (vorburger, 15:04:45)
    1. vpickard wants to discuss genius auto tunnels (vorburger, 15:05:03)
    2. vorburger is interested in feedback about remaining issues following the "big bump", if there are any? (vorburger, 15:05:40)
    3. Gerrit reviews & are we still holding back for aynthing or can keep going now? (vorburger, 15:06:29)

  3. genius auto tunnels (vorburger, 15:12:08)
    1. ACTION: vpickard to send email to genius-dev regarding bug where br-int added without dpid, update code does not handle case where br-int update comes in where dpid is added. Found this in d/s testing in OOO based deploy (vpickard, 15:12:30)

  4. The Big Bump (vorburger, 15:12:52)
    1. no one aware of any remaining issues, for genius (vorburger, 15:13:19)
    2. TSC call this evening will discuss impact on release timeline (vorburger, 15:14:02)

  5. Gerrit reviews (vorburger, 15:14:16)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:14:54)
    2. ACTION: viveks will ask Vishal & Hema to please review x5 patches from David re. migrating listeners to new framework (vorburger, 15:16:49)
    3. https://git.opendaylight.org/gerrit/#/c/66488/ (viveks, 15:18:54)
    4. https://git.opendaylight.org/gerrit/#/c/66490/ (viveks, 15:19:24)
    5. viveks and vpickard discussed and agreed to get these into stable/carbon AFTER we've them in master (still be reviewed) (vorburger, 15:21:37)
    6. https://git.opendaylight.org/gerrit/#/c/65290/ (viveks, 15:22:40)
    7. https://git.opendaylight.org/gerrit/#/c/65290/ (vorburger, 15:22:49)
    8. this is an old Gerrit from vorburger with a proposed enhancement to LockManager, for which CSIT passed, back in November... (vorburger, 15:23:49)
    9. ACTION: viveks will ask Faseela to review https://git.opendaylight.org/gerrit/#/c/65290/ (vorburger, 15:24:24)
    10. https://git.opendaylight.org/gerrit/#/c/67231/ is a WIP, viveks will -1 it until it's good to go in (vorburger, 15:25:01)
    11. https://git.opendaylight.org/gerrit/#/c/67159/ (viveks, 15:25:27)
    12. https://git.opendaylight.org/gerrit/#/c/67159/ (vorburger, 15:26:45)
    13. ACTION: tpantelis to re-review and +1 https://git.opendaylight.org/gerrit/#/c/67159/ if OK for him (vorburger, 15:27:14)
    14. ACTION: vorburger to review https://git.opendaylight.org/gerrit/#/c/67159/ and merge if OK (vorburger, 15:27:51)
    15. ACTION: viveks to check with Tarun why Tom's feedback about removing initial delay why not taken into account? (vorburger, 15:30:40)
    16. ACTION: vorburger to try out https://git.opendaylight.org/gerrit/#/c/67290/ (vorburger, 15:31:59)
    17. ACTION: Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/66502/ (vorburger, 15:32:18)
    18. ACTION: Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/67058/ (vorburger, 15:33:01)
    19. merged https://git.opendaylight.org/gerrit/#/c/66849/ adding portuuid to be retrieved as part of port statistics (vorburger, 15:34:01)
    20. ACTION: vorburger to review https://git.opendaylight.org/gerrit/#/c/67415/ and comment that it should use his new RPC erorr handling util (vorburger, 15:35:34)


Meeting ended at 15:36:23 UTC (full logs).

Action items

  1. vpickard to send email to genius-dev regarding bug where br-int added without dpid, update code does not handle case where br-int update comes in where dpid is added. Found this in d/s testing in OOO based deploy
  2. viveks will ask Vishal & Hema to please review x5 patches from David re. migrating listeners to new framework
  3. viveks will ask Faseela to review https://git.opendaylight.org/gerrit/#/c/65290/
  4. tpantelis to re-review and +1 https://git.opendaylight.org/gerrit/#/c/67159/ if OK for him
  5. vorburger to review https://git.opendaylight.org/gerrit/#/c/67159/ and merge if OK
  6. viveks to check with Tarun why Tom's feedback about removing initial delay why not taken into account?
  7. vorburger to try out https://git.opendaylight.org/gerrit/#/c/67290/
  8. Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/66502/
  9. Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/67058/
  10. vorburger to review https://git.opendaylight.org/gerrit/#/c/67415/ and comment that it should use his new RPC erorr handling util


Action items, by person

  1. viveks
    1. viveks will ask Vishal & Hema to please review x5 patches from David re. migrating listeners to new framework
    2. viveks will ask Faseela to review https://git.opendaylight.org/gerrit/#/c/65290/
    3. viveks to check with Tarun why Tom's feedback about removing initial delay why not taken into account?
  2. vorburger
    1. vorburger to review https://git.opendaylight.org/gerrit/#/c/67159/ and merge if OK
    2. vorburger to try out https://git.opendaylight.org/gerrit/#/c/67290/
    3. vorburger to review https://git.opendaylight.org/gerrit/#/c/67415/ and comment that it should use his new RPC erorr handling util
  3. vpickard
    1. vpickard to send email to genius-dev regarding bug where br-int added without dpid, update code does not handle case where br-int update comes in where dpid is added. Found this in d/s testing in OOO based deploy
  4. UNASSIGNED
    1. tpantelis to re-review and +1 https://git.opendaylight.org/gerrit/#/c/67159/ if OK for him
    2. Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/66502/
    3. Faseela to review and if OK merge https://git.opendaylight.org/gerrit/#/c/67058/


People present (lines said)

  1. vorburger (31)
  2. viveks (5)
  3. odl_meetbot (4)
  4. vpickard (2)


Generated by MeetBot 0.1.4.