#opendaylight-genius: genius-weekly

Meeting started by vorburger at 15:09:56 UTC (full logs).

Meeting summary

  1. Roll Call, everyone #info in please (vorburger, 15:10:07)
    1. faseelak (faseelak, 15:10:13)
    2. vorburger (vorburger, 15:10:15)
    3. Hema (Hema, 15:10:16)
    4. vpickard (vpickard, 15:10:25)
    5. shague (shague, 15:10:35)
    6. vthapar (vthapar, 15:10:39)

  2. Agenda today? (vorburger, 15:11:35)
    1. Release Blockers status (vorburger, 15:11:41)
    2. https://jira.opendaylight.org/issues/?filter=10206 (shague, 15:11:53)
    3. ConcurrentHashMap, Genius' use of infrautils.caches (vorburger, 15:11:58)
    4. Gerrit reviews (vorburger, 15:12:04)

  3. Release Blockers status (vorburger, 15:12:22)
    1. https://jira.opendaylight.org/issues/?filter=10206 (vorburger, 15:12:43)
    2. GENSIUS-116 fix is ready, need to merge and cherry pick to oxygen (vthapar, 15:13:06)
    3. https://jira.opendaylight.org/browse/GENIUS-116 (vorburger, 15:13:09)
    4. https://jira.opendaylight.org/browse/GENIUS-116 (vthapar, 15:13:27)
    5. https://git.opendaylight.org/gerrit/#/c/68794/ ready for merge to stable/oxygen (vorburger, 15:14:02)
    6. vorburger has added comment "[~klou] https://git.opendaylight.org/gerrit/#/c/68794/ is cherry-picked and +2 ready for merge to Oxygen..." (vorburger, 15:14:50)
    7. ACTION: shague will reach out to Kit Lou to get that merged (vorburger, 15:15:02)
    8. https://jira.opendaylight.org/browse/GENIUS-115 (vorburger, 15:15:17)
    9. https://git.opendaylight.org/gerrit/#/c/68797/ (vorburger, 15:17:54)
    10. ACTION: Hema will email Josh to confirm that patch is the one to go in (vorburger, 15:18:07)
    11. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=592032762 oxygen tracking sheet (shague, 15:21:34)
    12. add blockers bugs to the sheet and update the status. klou will approve the gerrits for merge and then the releng team will merge (shague, 15:22:34)

  4. Concurrent delete and write (vorburger, 15:28:20)
    1. long discussion re. transactional questions (vorburger, 15:28:44)

  5. Tom's HWTEP cache (vorburger, 15:29:17)
    1. https://git.opendaylight.org/gerrit/#/c/66789/ (vorburger, 15:29:50)
    2. ACTION: tpantelis to rebase https://git.opendaylight.org/gerrit/#/c/66789/ (vorburger, 15:33:27)
    3. ACTION: vorburger to re-review and hopefully merge https://git.opendaylight.org/gerrit/#/c/66789/ (vorburger, 15:33:37)

  6. Edwin's immutables for performance enhancements (vorburger, 15:36:26)
    1. https://git.opendaylight.org/gerrit/#/c/68524/ (vorburger, 15:36:32)
    2. http://immutables.github.io (vorburger, 15:36:51)
    3. ACTION: vorburger to pull that change and try to help Edwin (vorburger, 15:37:50)

  7. Gerrit reviews (vorburger, 15:38:08)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:38:14)
    2. https://git.opendaylight.org/gerrit/#/c/68170/ (vorburger, 15:38:51)
    3. faseela suspects this rename of RPC would break netvirt (vorburger, 15:39:56)
    4. ACTION: Hema to review and +1 or -1 https://git.opendaylight.org/gerrit/#/c/68170/ (vorburger, 15:40:14)

  8. Victor's 3 auto TZ related changes for carbon (vorburger, 15:41:41)
    1. ACTION: faseela will reach out to vpickard to sync with Vivek if this is OK for carbon (vorburger, 15:42:11)
    2. https://git.opendaylight.org/gerrit/#/c/68947/ (vorburger, 15:43:17)
    3. https://git.opendaylight.org/gerrit/#/c/68952/ (vorburger, 15:43:22)

  9. ConcurrentHashMap, Genius' use of infrautils.caches (vorburger, 15:44:48)
    1. Vishal is asking what the recommendation re. static ConcurrentHashMap is now (vorburger, 15:45:08)
    2. vorburger is clarifying that we don't want "static" fields anywhere for anything, not just ConcurrentHashMap (vorburger, 15:45:30)
    3. you can use the infrautils.caches instead of ConcurrentHashMap if you want monitoring and evicition, ottherwise a (non-static) ConcurrentHashMap is fine (vorburger, 15:45:58)
    4. ACTION: vishal interested in contributing a fix in infrautils to remove the current default hard-coded cache size, and instead introduce a mandatory cache size set by code (may be in 2 stages); vorburger is all for that (vorburger, 15:46:51)


Meeting ended at 15:46:55 UTC (full logs).

Action items

  1. shague will reach out to Kit Lou to get that merged
  2. Hema will email Josh to confirm that patch is the one to go in
  3. tpantelis to rebase https://git.opendaylight.org/gerrit/#/c/66789/
  4. vorburger to re-review and hopefully merge https://git.opendaylight.org/gerrit/#/c/66789/
  5. vorburger to pull that change and try to help Edwin
  6. Hema to review and +1 or -1 https://git.opendaylight.org/gerrit/#/c/68170/
  7. faseela will reach out to vpickard to sync with Vivek if this is OK for carbon
  8. vishal interested in contributing a fix in infrautils to remove the current default hard-coded cache size, and instead introduce a mandatory cache size set by code (may be in 2 stages); vorburger is all for that


Action items, by person

  1. Hema
    1. Hema will email Josh to confirm that patch is the one to go in
    2. Hema to review and +1 or -1 https://git.opendaylight.org/gerrit/#/c/68170/
  2. shague
    1. shague will reach out to Kit Lou to get that merged
  3. vorburger
    1. vorburger to re-review and hopefully merge https://git.opendaylight.org/gerrit/#/c/66789/
    2. vorburger to pull that change and try to help Edwin
    3. vishal interested in contributing a fix in infrautils to remove the current default hard-coded cache size, and instead introduce a mandatory cache size set by code (may be in 2 stages); vorburger is all for that
  4. vpickard
    1. faseela will reach out to vpickard to sync with Vivek if this is OK for carbon


People present (lines said)

  1. vorburger (44)
  2. shague (4)
  3. odl_meetbot (4)
  4. vthapar (3)
  5. vpickard (1)
  6. Hema (1)
  7. faseelak (1)


Generated by MeetBot 0.1.4.