#opendaylight-genius: genius-weekly

Meeting started by vorburger at 14:01:32 UTC (full logs).

Meeting summary

    1. Hema (HemaG, 14:02:28)
    2. Vishal (vthapar, 14:02:32)

  1. Josh's Add dp-id to ARP notifications (vorburger, 14:07:49)
    1. https://git.opendaylight.org/gerrit/#/c/75248/ (vorburger, 14:07:54)
    2. ACTION: HemaG if this change c/75248 is OK for you, will you +1 it (vorburger, 14:08:48)

  2. GENIUS-207 UpgradeUtils OptimisticLockFailedException c/75535 (vorburger, 14:10:29)
    1. https://git.opendaylight.org/gerrit/#/c/75535/ (vorburger, 14:11:08)
    2. ACTION: vorburger to update (HemaG, 14:14:23)
    3. ACTION: vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it (vorburger, 14:14:31)

  3. ManagedNewTransactionRunner improvements from Stephen (vorburger, 14:14:50)
    1. https://git.opendaylight.org/gerrit/#/c/75348/ (vorburger, 14:15:00)
    2. https://git.opendaylight.org/gerrit/#/c/75543/ (vorburger, 14:15:05)
    3. skitt gives an overview and explanation of these enhancements (vorburger, 14:16:56)
    4. ACTION: HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish (vorburger, 14:31:01)
    5. where to capture the kind of best practices that came up in this discussion? MD SAL developer guide in docs/ (vorburger, 14:34:15)
    6. ACTION: vorburger to try to make a contribution to "MD SAL Developer guide" (if that even exists..) re. TomP's feedback about clustered listeners, and create at a least new Wiki if hard to contribute to docs (vorburger, 14:36:31)

  4. HemaG asking for thoughts on observation in CSIT re. DataObjectCache (vorburger, 14:37:32)
    1. DTCL fired before Cache? (vorburger, 14:37:55)
    2. ACTION: HemaG to post to genius-dev with more details about these listeners (vorburger, 14:40:11)

  5. Pending Gerrit reviews (vorburger, 14:44:34)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:44:38)
    2. https://git.opendaylight.org/gerrit/#/c/74909/ (vorburger, 14:44:52)
    3. ACTION: HemaG to either run CSIT and merge or merge right away (vorburger, 14:45:46)
    4. https://git.opendaylight.org/gerrit/#/c/75272/ (vorburger, 14:46:06)
    5. HemaG is actively working on this, it's WIP. Discussion if -1 prevents CSIT, but should not. (vorburger, 14:47:23)
    6. https://git.opendaylight.org/gerrit/#/c/74842/ (vorburger, 14:47:34)
    7. ACTION: HemaG to add more reviewers before merging it (vorburger, 14:48:44)
    8. https://git.opendaylight.org/gerrit/#/c/74843/ (vorburger, 14:48:58)
    9. ACTION: HemaG to see if that was just a temporary test that needs to be -1 or merged (vorburger, 14:50:00)

  6. Very old Gerrits (vorburger, 14:50:33)
    1. #link https://wiki.opendaylight.org/view/Genius:Main (vorburger, 14:50:36)
    2. https://git.opendaylight.org/gerrit/#/dashboard/?title=Genius+abandonment+review&Send+email+warning+due+to+3+weeks+inaction=project:genius+status:open+age:21d+-age:31d&Close+due+to+4+weeks+inaction=project:genius+status:open+age:31d (vorburger, 14:50:41)
    3. ACTION: vorburger to send an email to genius-dev (vorburger, 14:52:19)


Meeting ended at 14:52:49 UTC (full logs).

Action items

  1. HemaG if this change c/75248 is OK for you, will you +1 it
  2. vorburger to update
  3. vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it
  4. HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish
  5. vorburger to try to make a contribution to "MD SAL Developer guide" (if that even exists..) re. TomP's feedback about clustered listeners, and create at a least new Wiki if hard to contribute to docs
  6. HemaG to post to genius-dev with more details about these listeners
  7. HemaG to either run CSIT and merge or merge right away
  8. HemaG to add more reviewers before merging it
  9. HemaG to see if that was just a temporary test that needs to be -1 or merged
  10. vorburger to send an email to genius-dev


Action items, by person

  1. HemaG
    1. HemaG if this change c/75248 is OK for you, will you +1 it
    2. vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it
    3. HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish
    4. HemaG to post to genius-dev with more details about these listeners
    5. HemaG to either run CSIT and merge or merge right away
    6. HemaG to add more reviewers before merging it
    7. HemaG to see if that was just a temporary test that needs to be -1 or merged
  2. skitt
    1. HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish
  3. vorburger
    1. vorburger to update
    2. vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it
    3. HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish
    4. vorburger to try to make a contribution to "MD SAL Developer guide" (if that even exists..) re. TomP's feedback about clustered listeners, and create at a least new Wiki if hard to contribute to docs
    5. vorburger to send an email to genius-dev
  4. vthapar
    1. vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it
    2. HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish


People present (lines said)

  1. vorburger (36)
  2. HemaG (7)
  3. odl_meetbot (3)
  4. vthapar (3)
  5. skitt (1)


Generated by MeetBot 0.1.4.