#opendaylight-genius: genius-weekly

Meeting started by vorburger at 14:05:57 UTC (full logs).

Meeting summary

  1. Info in (vorburger, 14:06:06)
    1. low attendance today, Hema sent her apologies by email, vthapar sick (vorburger, 14:06:26)
    2. Karthika (vorburger, 14:07:07)
    3. Nidhi (vorburger, 14:07:13)
    4. shague (shague, 14:07:43)

  2. Pending Gerrits review (vorburger, 14:07:48)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:07:57)
    2. https://git.opendaylight.org/gerrit/#/c/72462/ (vorburger, 14:08:35)
    3. ACTION: Hema see, or check with Faseela if needed, re the -2 on https://git.opendaylight.org/gerrit/#/c/72063/ which still has a test failure (vorburger, 14:10:21)
    4. Hi Nishchya, before we consider merging this to Oxygen, could you get https://git.opendaylight.org/gerrit/#/c/72462/ on master to pass (it still has a test failure) and get Faseela to remove her -2 there? Then we can look at this for Oxygen. It will also need a cherry-pick to Fluorine. (vorburger, 14:11:32)
    5. https://git.opendaylight.org/gerrit/#/c/76727/ (vorburger, 14:11:43)
    6. this is fluorine back patch of something which shague has merged into master 3 days ago (vorburger, 14:12:23)
    7. ACTION: shague will handle this one (vorburger, 14:12:49)
    8. https://git.opendaylight.org/gerrit/#/c/76729/ (vorburger, 14:12:57)
    9. this goes together with the previous one, shague will merge when ready with netvirt (vorburger, 14:13:41)

  3. OpenDaylight-SIMPLE (vorburger, 14:14:19)
    1. https://github.com/vorburger/opendaylight-simple (vorburger, 14:14:38)
    2. vorburger is about to have restconf working (hopefully), FYI skitt (vorburger, 14:19:34)
    3. shague and vorburger discuss next steps, and agree we'll need to go: ovsdb -> openflowplugin -> genius -> netvirt (vorburger, 14:20:01)
    4. https://github.com/vorburger/opendaylight-simple/issues/33 (vorburger, 14:23:07)
    5. https://github.com/vorburger/opendaylight-simple/issues/46 (vorburger, 14:25:23)
    6. https://github.com/vorburger/opendaylight-simple/issues/47 (vorburger, 14:29:28)
    7. vthapar points out that we would do: ovsdb -> neutron -> openflowplugin -> genius -> netvirt (vorburger, 14:36:26)
    8. discussion about how vthapar shague and others could help skitt and vorburger more actively on opendaylight-simple (vorburger, 14:38:34)
    9. https://wiki.opendaylight.org/view/BestPractices/DI_Guidelines (vorburger, 14:38:56)
    10. blueprint-maven-plugin (vorburger, 14:39:15)
    11. has this already been done for osdb? no see this linkK (vorburger, 14:40:58)
    12. https://github.com/opendaylight/ovsdb/search?q=%40Singleton&unscoped_q=%40Singleton (vorburger, 14:41:02)
    13. please use topic "simple-dist" for any work related to this (vorburger, 14:42:03)

  4. odltools (vorburger, 14:45:36)
    1. vthapar and shague discussing improvements (vorburger, 14:45:45)


Meeting ended at 14:50:53 UTC (full logs).

Action items

  1. Hema see, or check with Faseela if needed, re the -2 on https://git.opendaylight.org/gerrit/#/c/72063/ which still has a test failure
  2. shague will handle this one


Action items, by person

  1. shague
    1. shague will handle this one


People present (lines said)

  1. vorburger (34)
  2. odl_meetbot (3)
  3. shague (1)
  4. skitt (1)
  5. vthapar (1)


Generated by MeetBot 0.1.4.