#opendaylight-genius: Genius Weekly 12/13/18

Meeting started by faseelak at 15:00:47 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (faseelak, 15:01:16)
    1. vorburger (vorburger, 15:01:24)
    2. https://jira.opendaylight.org/browse/GENIUS-256 (faseelak, 15:01:28)
    3. Vishal (vthapar, 15:01:33)

  2. networkutils module (faseelak, 15:03:05)
    1. vni utils need to be moved to a common place (faseelak, 15:05:44)
    2. currently it is tied to NAT module, hence moving to genius in networkutils module (faseelak, 15:06:16)
    3. vthapar says it is better to make it genric than tying it to vni (faseelak, 15:06:31)
    4. https://git.opendaylight.org/gerrit/#/c/78319/ (faseelak, 15:06:42)

  3. ITM AutoTunnels suite (faseelak, 15:06:54)
    1. https://git.opendaylight.org/gerrit/#/c/77783/ (faseelak, 15:07:04)
    2. vthapar asks whether we can disable BFD by default (faseelak, 15:08:33)
    3. Hema updates apps are not even reacting to BFD status, so it makes sense to disable this by default (faseelak, 15:08:58)
    4. vthapar says odltools has check to see if all tunnels are UP, and looks like sometimes it fails as tunnels are taking too long to come up (faseelak, 15:09:28)
    5. faseelak asks whether we need a weather item for this (faseelak, 15:10:15)
    6. vthapar says we can disable this in netvirt CSIT, so that sfc is not impacted (faseelak, 15:11:15)

  4. ITM JIRAs : GENIUS-245 (faseelak, 15:12:23)
    1. ACTION: faseelak to reachout to Brady to see if sfc will be impacted if we change the default for tunnel monitoring (faseelak, 15:14:11)
    2. Karthika has sent an email sometimes VMs are getting IPs which are not falling in /24 causing ITM test cases to fai (faseelak, 15:14:51)
    3. vthapar says genius CSIT needs to be enhanced to accomodate such changes by moving /8 prefix (faseelak, 15:15:18)
    4. ACTION: Karthika to do the required changes in genius CSIT (faseelak, 15:15:33)

  5. stale cache entries in IFM (faseelak, 15:15:51)
    1. proper synchronization is not there in the way the concurrenthashmaps in interfacemanager/itm are populated (faseelak, 15:18:13)
    2. https://git.opendaylight.org/gerrit/#/c/78750/ (faseelak, 15:18:25)

  6. remove resourcemanager from odl-genius feature (faseelak, 15:19:51)
    1. https://git.opendaylight.org/gerrit/#/c/78746/ (faseelak, 15:20:04)

  7. Gerrit reviews (vorburger, 15:23:25)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:23:26)
    2. https://git.opendaylight.org/gerrit/#/c/78014/ (vorburger, 15:24:11)
    3. ACTION: Hema to review the above patch (faseelak, 15:24:28)
    4. https://git.opendaylight.org/gerrit/#/c/78056/ (faseelak, 15:25:01)
    5. Ankit has a +1 and would be good to merge (faseelak, 15:25:17)
    6. ACTION: vorburger to react to https://git.opendaylight.org/gerrit/#/c/78055/ (vorburger, 15:26:26)
    7. https://git.opendaylight.org/gerrit/#/c/78649/ yangtools bump patch on fluorine (faseelak, 15:28:21)
    8. https://git.opendaylight.org/gerrit/#/c/78371/ Drop null to Empty (faseelak, 15:29:20)
    9. ACTION: vorburger to review the above patch (faseelak, 15:30:16)
    10. build failures on other changes on the yangtools bump patch on fluorine, so we'll wait re. https://git.opendaylight.org/gerrit/#/c/78649 (vorburger, 15:30:49)
    11. https://git.opendaylight.org/gerrit/#/c/78749/ (faseelak, 15:31:00)
    12. follow-up patch for Michael's TestMdsalapiManager patch, michael to review it (faseelak, 15:31:20)


Meeting ended at 15:33:08 UTC (full logs).

Action items

  1. faseelak to reachout to Brady to see if sfc will be impacted if we change the default for tunnel monitoring
  2. Karthika to do the required changes in genius CSIT
  3. Hema to review the above patch
  4. vorburger to react to https://git.opendaylight.org/gerrit/#/c/78055/
  5. vorburger to review the above patch


Action items, by person

  1. faseelak
    1. faseelak to reachout to Brady to see if sfc will be impacted if we change the default for tunnel monitoring
  2. vorburger
    1. vorburger to react to https://git.opendaylight.org/gerrit/#/c/78055/
    2. vorburger to review the above patch
  3. UNASSIGNED
    1. Karthika to do the required changes in genius CSIT
    2. Hema to review the above patch


People present (lines said)

  1. faseelak (36)
  2. vorburger (7)
  3. odl_meetbot (4)
  4. vthapar (1)


Generated by MeetBot 0.1.4.