#opendaylight-genius: GeniusWeekly-08/02/2018

Meeting started by faseelak at 14:03:18 UTC (full logs).

Meeting summary

  1. Move ManagedTransactionRunner to MDSAL (faseelak, 14:04:02)
    1. Stephen working with tom to get this into MDSAL for Neon (faseelak, 14:04:42)
    2. vorburger says there will be some changes to the API once it is migrated to MDSAL (faseelak, 14:05:11)
    3. assumption that MDSAL committers wont have major objection to take it to MDSAL (faseelak, 14:05:39)

  2. Make Genius CSIT fail on new exceptions introduced (faseelak, 14:06:23)
    1. https://jira.opendaylight.org/browse/GENIUS-200 (vorburger, 14:06:42)
    2. faseelak asks vthapar on how netvirt CSIT does the exception scanning in karaf log (faseelak, 14:06:59)
    3. shague says he did that for netvirt CSIT, and it is quite easy to do (faseelak, 14:07:12)
    4. vthapar says he can see how to get it done for genius CSIT (faseelak, 14:07:25)

  3. Convert all of genius to managed transactions (faseelak, 14:09:20)
    1. https://jira.opendaylight.org/browse/GENIUS-176 (faseelak, 14:09:32)
    2. most of the modules are already converted (faseelak, 14:11:41)
    3. edwin had question on the mdsalutil api changes when GENIUS-176 is incorporated (faseelak, 14:12:03)
    4. faseelak comments it is better to do it on Neon, as this introduces API changes (faseelak, 14:13:02)
    5. vorburger says let us keep working, and then cherry-pick if needed later to Fluorine (faseelak, 14:13:56)
    6. https://lists.opendaylight.org/pipermail/genius-dev/2018-August/003220.html (vorburger, 14:14:07)

  4. BugScrub (faseelak, 14:17:06)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10406 (faseelak, 14:17:47)
    2. shague asks whether there is an easy tool to debug the ping failures in netvirt csit (faseelak, 14:21:12)
    3. vthapar says this needs to be integrated to odltools, and josh is working on some tool like this (faseelak, 14:21:32)
    4. faseelak says she can work on adding a wiki explaining the l2 pipeline (faseelak, 14:27:57)

  5. Open Gerrits (vorburger, 14:32:36)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:32:38)
    2. https://git.opendaylight.org/gerrit/#/c/72712/ not going to be merged yet as that a Neon topic; faseelak will -1 it (vorburger, 14:33:11)
    3. https://git.opendaylight.org/gerrit/#/c/69190/ CSIT is still failing... (vorburger, 14:34:08)
    4. ACTION: Hema to chase why this is still failing CSIT (vorburger, 14:34:27)
    5. https://git.opendaylight.org/gerrit/#/c/74760/ for https://jira.opendaylight.org/browse/GENIUS-195 (vorburger, 14:35:09)
    6. https://git.opendaylight.org/gerrit/#/c/74602/ (vorburger, 14:38:18)

  6. JIRA Management (vorburger, 14:41:05)
    1. ACTION: vorburger create new Oxygen-SR4 target version, and move 3 unresolved issue on SR3 which missed the boat to SR4 (or close): GENIUS-179, GENIUS-167, GENIUS-161 (vorburger, 14:41:59)


Meeting ended at 14:42:49 UTC (full logs).

Action items

  1. Hema to chase why this is still failing CSIT
  2. vorburger create new Oxygen-SR4 target version, and move 3 unresolved issue on SR3 which missed the boat to SR4 (or close): GENIUS-179, GENIUS-167, GENIUS-161


Action items, by person

  1. vorburger
    1. vorburger create new Oxygen-SR4 target version, and move 3 unresolved issue on SR3 which missed the boat to SR4 (or close): GENIUS-179, GENIUS-167, GENIUS-161


People present (lines said)

  1. faseelak (22)
  2. vorburger (12)
  3. odl_meetbot (4)
  4. odp-gerritbot (3)
  5. vthapar (0)


Generated by MeetBot 0.1.4.