#opendaylight-genius: Weekly_Meeting_04_12

Meeting started by faseelak at 14:05:27 UTC (full logs).

Meeting summary

    1. Hema (Hema, 14:05:50)
    2. vorburger (vorburger, 14:06:01)

  1. fluorine topics (faseelak, 14:07:38)
    1. any new features should have a spec uploaded before may 8th (faseelak, 14:07:51)
    2. https://wiki.opendaylight.org/view/Genius:Main (vorburger, 14:08:34)
    3. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 14:08:43)

  2. pending code reviews (faseelak, 14:08:43)
    1. Tarun's patches for auto-tunnels merged (faseelak, 14:10:35)
    2. Michael's patch to remove it-parent (faseelak, 14:11:26)

  3. SFT timeouts (faseelak, 14:11:57)
    1. vorburger says it is a global issue, not specific to genius (faseelak, 14:12:16)
    2. https://jira.opendaylight.org/browse/ODLPARENT-148 (vorburger, 14:12:24)
    3. might be an issue due to the inter project dependencies defined as bundles and not using features (faseelak, 14:12:56)
    4. stable/oxygen builds are broken (faseelak, 14:15:50)
    5. faseela asked whether this change in odlparent requires a version bump up (faseelak, 14:16:54)

  4. genius-tools migration (faseelak, 14:17:22)
    1. faseelak has migrated sfc, genius and netvirt to the new tools (faseelak, 14:17:51)
    2. planning to remove the older base classes (faseelak, 14:18:03)

  5. itm-scalability patches (faseelak, 14:18:56)
    1. Hema indicated that they are working on pending patches, addressing review comments (faseelak, 14:19:20)

  6. usage of ManagedTransactionRunnerImpl (faseelak, 14:20:02)
    1. vorburger said it would be great if more people can pitch in for the migration, so that we can get rid of the transaction leaks (faseelak, 14:20:31)
    2. skitt working on a utility to throw checktyle errors, for the usage of dataBroker.newReadWriteTransaction() (faseelak, 14:21:16)
    3. skitt, it would be great, if you could send out an email to genius-dev about the new transaction-parent stuff (faseelak, 14:22:37)

  7. internship topic proposals (faseelak, 14:24:37)
    1. if you have topic proposals, please submit them (faseelak, 14:25:05)
    2. https://git.opendaylight.org/gerrit/#/c/70457/ (vorburger, 14:25:45)
    3. ACTION: vorburger to discuss with skitt to consolidate quality-parent and transaction-parent (faseelak, 14:28:17)


Meeting ended at 14:28:44 UTC (full logs).

Action items

  1. vorburger to discuss with skitt to consolidate quality-parent and transaction-parent


Action items, by person

  1. skitt
    1. vorburger to discuss with skitt to consolidate quality-parent and transaction-parent
  2. vorburger
    1. vorburger to discuss with skitt to consolidate quality-parent and transaction-parent


People present (lines said)

  1. faseelak (24)
  2. vorburger (7)
  3. odl_meetbot (3)
  4. skitt (1)
  5. Hema (1)


Generated by MeetBot 0.1.4.