#opendaylight-group-policy: datastore

Meeting started by regXboi at 14:01:53 UTC (full logs).

Meeting summary

    1. regXoi (regXboi, 14:02:19)
    2. regXboi (regXboi, 14:02:31)
    3. via Ghangout: alagalah, regxboi, readams, rexpugh-HP (alagalah, 14:03:00)
    4. via Ghangout: raghu67 (alagalah, 14:03:14)

  1. Keith/Rob to MD-SAL team: Can MD-SAL able to handle indexing/queries that we need for the Contract/Policy repository? (this is a followon from the ARCH team meeting 5/2) (alagalah, 14:05:06)
    1. regXboi doubts it can (opinion) (alagalah, 14:05:23)
    2. ... as it stands today but regXboi (IBM), but the OpenDaylight Organisation (via the intern program) has someone assigned for querying/indexing whom regXboi will mentor (alagalah, 14:06:38)
    3. regXboi mentioned JQuery (alagalah, 14:06:48)
    4. There were concerns expressed in the ARCH meeting last week that a) this is too complex for an intern b) JQuery maybe the wrong solution for this (alagalah, 14:07:25)
    5. regXboi can see how a) above maybe valid, b) again regXboi acks this may be possible but doesn't want to create something new and is asking for alternatives to JQuery (alagalah, 14:09:00)
    6. dvorkinista points out that we first have to drive this from our particular requirements, and we have only a handful of use cases for this topic and JQuery is more general purpose (alagalah, 14:09:40)
    7. readams feels we may have to write a lightweight indexing query functionality. (alagalah, 14:09:57)
    8. regXboi points out that this will have to be done via the MD-SAL team (alagalah, 14:10:08)
    9. raghu67 points out that this will have to be within the MD-SAL (query of index) rather than outside... dvorkinista says thats why readams said we need "hooks" to the MD-SAL, implying we agree that this should be in MD-SAL and we should consume that service. (alagalah, 14:10:55)
    10. regXboi +1E6 to Mike (alagalah, 14:11:13)
    11. jmedved just joined channel (alagalah, 14:11:27)
    12. regXboi says that we will have everything from a tenant to an EPG (alagalah, 14:13:28)
    13. dvorkinista says we should have some sophisticated tree traversal capability. (alagalah, 14:13:44)
    14. regXboi: EPG is where the rubber meets the road (alagalah, 14:14:02)
    15. raghu67: says there are 3 forms of queries.. (missed the 3) (alagalah, 14:14:17)
    16. class, subtree and relationships (I think) (regXboi, 14:14:53)
    17. dvorkinista REST doesn't have concept of RPC, it works on data, and works on Trees, and we need to be able to query on class, we need to be able to query on sub-tree, but also need to be able to traverse relationships (gets tricky here) (alagalah, 14:14:55)
    18. dvorkinista when you get a subtree, you should have children and others... current implementation espec. with RESTCONF the things we can do is slightly limited (alagalah, 14:15:51)
    19. dvorkinista believes that RESTCONF isn't the best way of implementing REST, and if we use RPCs we aren't really REST (alagalah, 14:16:11)
    20. regXboi asks jmedved if he received email from Phil Robb, re: ODL intern for JQuery project (noted above), and discussion to this point has been if JQuery is too General Purpose, and now regXboi has noodled, thinks dvorkinista may be right (alagalah, 14:17:11)
    21. jmedved points out that JQuery is quite different from what GBP needs (via dvorkinista) especially as we look at subscription (and continually pushing data) (alagalah, 14:17:54)
    22. regXboi: Not only will GBP need "hooks" (ala readams comment) but Service chaining project may need it too (alagalah, 14:18:48)
    23. jmedved: annotate the models with some form of yang extension (GBP model) to facilitate MD-SAL hooks (alagalah, 14:19:26)
    24. raghu67 Index hooks or RPC hooks? (alagalah, 14:19:37)
    25. raghu67 Clarifies... MD-SAL index maybe too generic, hence GBP may build our own. Hence perhaps hooks so MD-SAL can build the specialised indexes (alagalah, 14:20:36)
    26. jmedved says datastore will have to build indexes and MD-SAL will have to pass it through to the datastore. Hence need hooks into MD-SAL. (alagalah, 14:21:29)
    27. alagalah asks if those hooks are purely RPC. jmedved says no, the MD-SAL won't have any use for the indice (hence no RPCs ??) but would have to pass it thru (alagalah, 14:22:04)
    28. raghu67 doesn't thinks thats what regXboi dvorkinista has in mind (alagalah, 14:22:17)
    29. dvorkinista: push mechanism is based on this.... (alagalah, 14:22:28)
    30. jmedved two mechanisms need to be built out but dvorkinista gives example that first query has to be supported (ie there isn't an existing subscription/push mechanism initialised) (alagalah, 14:23:18)
    31. jmedved discussed the subscription/push of subtree on data change (in line with our desire to be data driven) but dvorkinista says that the semantics are the same (alagalah, 14:23:58)
    32. jmedved Is delineating between the creation/support of indices in the "MD-SAL" datastore, and database triggers for subscription (push-on-change) (alagalah, 14:25:09)
    33. regXboi who receives the trigger? dvorkinista says we need to push the change, but the issue is what happens if I didn't get the prior change. regXboi Asks if you push the change, on top of a missed change, it gets ugly. dvorkinista says one solution is policy repo has a "queue" like thing and we don't remove from queue until acknowledged (purely synchronous) (alagalah, 14:27:01)
    34. regXboi uses "version" to imply "hey I'm missing a couple of updates" (we want to avoid versioning) ... dvorkinista says its more of an accumulator. (alagalah, 14:27:35)
    35. dvorkinista wants to keep this as simple as simple as simple as possible (but no simpler) :-P (alagalah, 14:28:07)
    36. Renderer needs to notify when it got the data, if he has #17, and buffer is at #23, then you need another update. regXboi says that once it hits renderer it is it's responsibility. (alagalah, 14:29:55)
    37. ACTION: alagalah to ensure that these minutes are linked to Renderer sub-group page and ARCH page and in ARCH agenda (alagalah, 14:30:40)
    38. jmedved wants to whiteboard use cases (alagalah, 14:30:53)
    39. ACTION: alagalah to add whiteboard usecases to ARCH agenda (alagalah, 14:33:20)
    40. 1PM thursday is the status call. Right? (raghu67, 14:34:00)


Meeting ended at 14:35:12 UTC (full logs).

Action items

  1. alagalah to ensure that these minutes are linked to Renderer sub-group page and ARCH page and in ARCH agenda
  2. alagalah to add whiteboard usecases to ARCH agenda


Action items, by person

  1. alagalah
    1. alagalah to ensure that these minutes are linked to Renderer sub-group page and ARCH page and in ARCH agenda
    2. alagalah to add whiteboard usecases to ARCH agenda


People present (lines said)

  1. alagalah (45)
  2. regXboi (5)
  3. odl_meetbot (4)
  4. raghu67 (1)


Generated by MeetBot 0.1.4.