#opendaylight-group-policy: DataStore 4/28

Meeting started by regXboi at 14:01:44 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:DATASTORE (alagalah, 14:02:24)

  1. agenda bashing (regXboi, 14:04:01)
  2. who is contributing and what time can be devoted? (regXboi, 14:04:50)
    1. alagalah sent this to the mailing list (regXboi, 14:05:10)
    2. only regXboi and s3wong have replied so far (regXboi, 14:05:22)
    3. discussion of where performance considerations should be tracked - here or in MD-SAL (regXboi, 14:07:52)
    4. ACTION: regXboi to update wiki page with the scope of datastore (regXboi, 14:10:53)
    5. alagalah: Charter of this group is to determine requirements of GBP datastore and it's mapping to MD-SAL and any changes we may need to MD-SAL ala APIs. This meeting will roll into Arch and DATASTORE will actually, once we get to code, we will probably have only 3 groups (EP-mapper/policy, OperationalState, Renderers) (alagalah, 14:10:59)
    6. ACTION: (not direct for this) jmedved to start actual model discussion (regXboi, 14:15:27)
    7. ACTION: jmedved to produce a YANG model from GBP UML 0.97 with Tony (Pantheon?) and email to the list in next two days. (alagalah, 14:15:39)
    8. currently jmedved uses cbench to hit the datastore currently (regXboi, 14:15:43)
    9. http://www.joedog.org/siege-home/ (regXboi, 14:16:38)
    10. https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.e7ngfp46nqhv5oltibelval6o8 (alagalah, 14:17:46)
    11. Rob Adams asks if we are putting the "cart before the horse" talking about MD-SAL performance metrics (alagalah, 14:18:55)
    12. Before we have an actual implementation to measure (alagalah, 14:19:03)
    13. regXboi claims what we are doing is setting the methodology so it is common when comparing implementations (regXboi, 14:19:25)
    14. regXboi points out that he wants to settle on a methodology so we can use the same methodology to benchmark existing, and then measure our implementations against it and identify improvements etc (alagalah, 14:19:40)
    15. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore (alagalah, 14:20:47)
    16. according to jmedved that is the latest documented, but it still needs to be updated with latest infromation (regXboi, 14:21:20)
    17. new in-memory data store is going to an external customer so we'll have field trial data to work with (regXboi, 14:22:27)
    18. jmedved is interest in comparing performance of current tree with mlemay's KV implementation of the in-memory datastore (regXboi, 14:23:13)
    19. (edit) s/interest/interested/ in last info (regXboi, 14:23:34)
    20. alagalah want to clarify the separation of md-sal and in-memory datastore and is asking if readams is comfortable with the implementation implications of that (regXboi, 14:24:28)
    21. readams is still working it (regXboi, 14:24:38)
    22. a bit of a discussion of APIC vs ODL sharding (regXboi, 14:34:11)
    23. alagalah asks jmedved about a) does sharding fall under GBP or MD-SAL. jmedved says MD-SAL. b) Does MD-SAL have a Release Plan that I can sync the GBP release plan with so that when a portion of GBP needs to leverage sharding (and the leader + 2x follower concept from APIC for a shard) that MD-SAL has a prototype ready to go. jmedved points out that MD-SAL is not an official project but a sub-pa (alagalah, 14:42:08)
    24. ACTION: alagalah once he publishes the first cut of the GBP Helium Release Plan will also have a document that gives context to the relationships between subgroups, and other projects, to justify why certain steps are at certain gates in the critical path (alagalah, 14:42:55)
    25. alagalah asks jmedved about a) does sharding fall under GBP or MD-SAL. jmedved says MD-SAL. b) Does MD-SAL have a Release Plan that I can sync the GBP release plan with so that when a portion of GBP needs to leverage sharding (and the leader + 2x follower concept from APIC for a shard) that MD-SAL has a prototype ready to go. jmedved points out that MD-SAL is not an official project but a sub-pa (alagalah, 14:43:59)
    26. rt of the Controller project, and these discussions are still underway. (regXboi, 14:44:28)
    27. (that finished the previous info) (regXboi, 14:44:34)


Meeting ended at 14:49:41 UTC (full logs).

Action items

  1. regXboi to update wiki page with the scope of datastore
  2. (not direct for this) jmedved to start actual model discussion
  3. jmedved to produce a YANG model from GBP UML 0.97 with Tony (Pantheon?) and email to the list in next two days.
  4. alagalah once he publishes the first cut of the GBP Helium Release Plan will also have a document that gives context to the relationships between subgroups, and other projects, to justify why certain steps are at certain gates in the critical path


Action items, by person

  1. alagalah
    1. alagalah once he publishes the first cut of the GBP Helium Release Plan will also have a document that gives context to the relationships between subgroups, and other projects, to justify why certain steps are at certain gates in the critical path
  2. regXboi
    1. regXboi to update wiki page with the scope of datastore
  3. UNASSIGNED
    1. (not direct for this) jmedved to start actual model discussion
    2. jmedved to produce a YANG model from GBP UML 0.97 with Tony (Pantheon?) and email to the list in next two days.


People present (lines said)

  1. regXboi (25)
  2. alagalah (24)
  3. odl_meetbot (4)
  4. s3wong (4)


Generated by MeetBot 0.1.4.