#opendaylight-group-policy: GBP ARCH May9

Meeting started by alagalah at 18:22:16 UTC (full logs).

Meeting summary

  1. Mickey to discuss subscription from whiteboard (alagalah, 18:22:37)
    1. phone 1-866-432-9903 (dconde, 18:23:04)
    2. access code 204 699 499 (dconde, 18:23:15)
    3. recording webex (alagalah, 18:24:28)
    4. dvorkini_ drawing on whiteboard re: EP attach/mutation (alagalah, 18:24:57)
    5. Can attach conditions to EPGs as well as EPs, and EPG can be scoped to enforcement domain (alagalah, 18:25:30)
    6. Can extend this concept to the tenant (alagalah, 18:25:43)
    7. EPG has conditions and can also belong to an "enforcement domain" which is a renderer or set of renderers who share the domain-ness (alagalah, 18:26:31)
    8. Can rely on EP attachment and there's context of which EPG is belongs to and domain it belongs to and resolution of EPG and things on EPG depends on and what things it depends on, and we resolve those things (alagalah, 18:27:06)
    9. Tenant is generalised concept of EPG scope (alagalah, 18:27:44)
    10. Mickey asks if Enforcement domain comes from EPG and tenant, but dvorkini_ says not necessarily, can be other things (alagalah, 18:28:13)
    11. So Enforcement Domain can be fully reactive or it can be pre-populated (alagalah, 18:28:33)
    12. pre-population: we know which policies are in scope, from EPG/tenant, and can apply the same logic to the EPs and anything that is in scope for your EnfDom you bring in scope (alagalah, 18:29:10)
    13. Need to consume different models, because say we are in an OF controller ... and alagalah lost the train of thought (see recording) (alagalah, 18:29:45)
    14. raghu67_ asks if a new EPG gets created, how is the scope created. dvorkini_ so either an EP attaches (and rules are applied based on EP) or someone writes the rules for the EPG (alagalah, 18:30:41)
    15. dvorkini_ says we can a load of contracts that aren't instantiated as they only come into scope at various times of day (ie nightly batch jobs etc) (alagalah, 18:31:29)
    16. dvorkini_ says that once we get into OpFlex etc, then we need to be reactive, as others are adding things dynamically to the system. (alagalah, 18:32:50)
    17. Up to the renderer what gets resolved or either you can resolve things that are "within your circle" (alagalah, 18:33:26)
    18. ie one mode, is you retrieve the group and all its surrounding contracts, and once EPs appear, you already know, and once its peer EP comes online you retrieve its' information (alagalah, 18:34:04)
    19. mickey says this is where all the questions come about (alagalah, 18:34:34)
    20. Question was do I grab anything proactively (ie if I have consumer, do I try and proactively get provider information ahead of time) (alagalah, 18:34:58)
    21. dvorkini_ shows EP->EPG-> contract (single side, say provider), and we have another side that consumes it (and shows selectors within EPG) and shows retrieval of everything from Provider side through to Consumer selector *(which has the consumer requirements) so we can make the match (accord) (alagalah, 18:36:02)
    22. point is that there are multiple modes (alagalah, 18:36:09)
    23. dvorkini_ points out that if we don't know something, we can still reactively retrieve information. (alagalah, 18:36:45)
    24. reactivity vs proactivity again resolves to the renderer, as for instance, OpFlex renderer being reactive may not be as expensive as say an OF renderer (alagalah, 18:37:21)
    25. dvorkini_ says for ACI, the way we are thinking of this is to subscribe to tenants and policies (alagalah, 18:37:49)
    26. readams points out that at the initial scales reactive will be fine, but if we want to scale to "ridiculous levels" we may need to look at alternate sharding etc... (alagalah, 18:38:33)
    27. some comment about who's who in the zoo ie does Jan's MD-SAL team have to own this and dvorkini_ points out that they shouldn't care (alagalah, 18:38:55)
    28. net of the last 5min. Renderer commons, gets EP, contracts etc, does some work, once we get closer to clauses/subjects/rules, we are using the specific implementation renderer (this is active rendering), passive rendering is where we are pretty much just passing stuff through (think APIC subtended to ODL, and some slight munging of policy semantics might be necessary but its ostensibly passthru) (alagalah, 18:46:43)
    29. alagalah will augment these minutes with mickey's notes (alagalah, 18:54:51)
    30. Dave Lenrow brings up that we need to model and be cogniscent of the Renderer performance, and readams points out that this is a complex situation, espec. when we have an outage, recovery, and a flood of messaging (alagalah, 19:00:31)
    31. mickey: Jan maybe interested in how we subscribe to selection relators, but rob points out that we need to actually have the yang model get into the datastore, but its a bit premature (alagalah, 19:04:04)
    32. We need a better phone/microphone for the conference room where you host. I'll contribute. It's brutal trying to follow the audio in the room (lenrow, 19:04:33)
    33. need to define exactly what we need to subscribe to. (alagalah, 19:04:54)
    34. ACTION: Mickey/Rob by May23 to build up a list of specific parts of the UML model that the MD-SAL has to support subscription services for (alagalah, 19:06:31)


Meeting ended at 19:06:37 UTC (full logs).

Action items

  1. Mickey/Rob by May23 to build up a list of specific parts of the UML model that the MD-SAL has to support subscription services for


People present (lines said)

  1. alagalah (39)
  2. regXboi (4)
  3. odl_meetbot (4)
  4. dconde (3)
  5. cloudtoad (2)
  6. lenrow (1)


Generated by MeetBot 0.1.4.