#opendaylight-group-policy: gbp model

Meeting started by regXboi at 17:04:39 UTC (full logs).

Meeting summary

  1. agenda bashing (regXboi, 17:05:09)
    1. do we *HAVE* an agenda? (regXboi, 17:05:16)
    2. regXboi translates "risk" as "DOA" (regXboi, 17:08:28)
    3. but that is regXboi not speaking as a TSC member but as a committer (regXboi, 17:08:54)
    4. regXboi states concern as a committer on the risk of not meeting helium (dconde, 17:09:03)
    5. there was some dicussion between Noir0 and the edwarnicke but we have not had a chance to check w/ them (dconde, 17:10:11)
    6. regXboi asks mickey_spiegel whether we are doing ARCH (dconde, 17:11:06)
    7. I am not aware of ARCH topics. (dconde, 17:11:17)
    8. propose to cancel. (dconde, 17:11:24)
    9. readams just joined hangout (dconde, 17:11:52)
    10. readams just arrived (regXboi, 17:11:53)
    11. readams says real work needs to be done but have not had chance to do it. (dconde, 17:12:31)
    12. maybe on topic of model -- key areas to be taken care of, are : (dconde, 17:12:45)
    13. 1) l2/l3 context and data plane modeling aspects. Not hard, but needs to be done. to associate L2/L3 context with EPG (dconde, 17:13:10)
    14. 2) additions to represent intra EPG policies as a peer contract notion. and define semantics. this is tricky for several reasons. Contract notions have directoinality which is noe defined. (dconde, 17:13:43)
    15. INTRA policies need to define multi-cast and broadcast. I.e not src/dest (dconde, 17:14:04)
    16. we can get big switches that has no broadcast allowed except certain types of traffic. like what ACI does. and let ARP are handled by special proxies. (dconde, 17:14:39)
    17. https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.6msm68t31c5fdn152g721o09ks (tbachman, 17:15:01)
    18. so… some effort needs to go into modeling how the location - identifier mapping (dconde, 17:15:11)
    19. in context field --we have the mapping for the renderer (dconde, 17:15:24)
    20. we thought that was a separate repo that was renderer specific, but current thought was to put into the EP registry. (dconde, 17:15:50)
    21. last area: (dconde, 17:15:54)
    22. status and exception repo. (dconde, 17:16:05)
    23. status repo needs design. (dconde, 17:16:10)
    24. we can derive some prior work -- such as in ACI (dconde, 17:16:29)
    25. readams needs to define model as he writes the renderer. (dconde, 17:16:47)
    26. if anyone wants to define those, it's welcome! (dconde, 17:16:57)
    27. the exception repo is straightfoward. need some error context and results need to be stored. (blocked? What's the constrints were relaxed, error type (fatal, non fatal) (dconde, 17:18:00)
    28. perhaps an orchestraton system can fix it. (TCAM space ran out?). Orch system can fix by moving. VMs but that's a FUTURE thing. (dconde, 17:18:44)
    29. it is more than Error log, but it has a active events, not an log of past errors. (dconde, 17:19:24)
    30. big distinction compared to syslog semantics. (dconde, 17:19:34)
    31. regXboi now wants to talk about.... (dconde, 17:19:40)
    32. context of dataplane (dconde, 17:19:49)

  2. context (dconde, 17:20:12)
    1. we think we get concepts of contexts…but there is the In-between (dconde, 17:20:30)
    2. specifically tunnels. (dconde, 17:20:47)
    3. readams says tunnels msy not come in. w.r.t. policies can state what can communicate. it's a diff between broadcast domain vs. subnet. (dconde, 17:21:33)
    4. details of the underlying network may require tunneling, but we do not define a policy on how that is done. (dconde, 17:21:54)
    5. regXboi sees a use-case. (dconde, 17:22:21)
    6. only thing that identifies an EPG is a tunnel ID (dconde, 17:22:30)
    7. readams says -- imagine in context of a bigswitch fabric, or ACI. a link comes into the leaf node (dconde, 17:23:10)
    8. underneath is some OTHer network you don't control. It has a tag (dconde, 17:23:32)
    9. regXboi adding to epg based on policy of CIDR block and address (dconde, 17:24:17)
    10. based on VXLAN tag for traffic that traverses the mesh (dconde, 17:24:40)
    11. then we need to learn it and associate with EPG (dconde, 17:25:09)
    12. regXboi disagress since… L3 context needs to have things that the outer header of a tunnel MIGHT have. (dconde, 17:26:22)
    13. associates a port to an EPG may be true…. (dconde, 17:27:12)
    14. readams you can MAP a port -- VLAN 5 means Web EPG, VLANX 6 == DB EPG. (dconde, 17:27:48)
    15. regXboi agrrees on that. (dconde, 17:27:55)
    16. any mapping semantics is possible. (dconde, 17:28:05)
    17. that can be done via learning. (dconde, 17:28:23)
    18. simplest renderer if orchestration system managed all VMs but in raality, we need learning capability for most products (dconde, 17:29:00)
    19. AGREED: port into EPG by regXboi (dconde, 17:29:24)
    20. but regXboi wonders how it's supposed to work. (dconde, 17:29:37)
    21. it is similar to what lenrow asked in ML (dconde, 17:29:47)
    22. readams says mickey_spiegel comment is mostly true. but you can potentially route between devices within same EPG or L2 context. (dconde, 17:31:20)
    23. it's an issue of sharing name space. (dconde, 17:31:32)
    24. if you have a private connectivity group you need something that ties ito to the 5 tuples you see on the wire. (dconde, 17:32:24)
    25. it's a name space issue. (dconde, 17:32:57)
    26. but readams needs to work it out, perhaps talks with others on how it can be implemented (dconde, 17:33:18)
    27. lenrow wants to call it a virtual network context. (dconde, 17:33:30)
    28. maybe….but L2 != L3 context (dconde, 17:33:41)
    29. regXboi is happy - he is on PTO last half of next week. (dconde, 17:36:44)
    30. any topics of ARCH call? (dconde, 17:36:58)
    31. but now… anyone thing we do? (dconde, 17:37:07)
    32. readams work needs to happen in ARCh but hard to do in a call, it needs to be written. (dconde, 17:37:29)
    33. uchau asks did the renderer meetings get restarted (regXboi, 17:38:58)
    34. lenrow asks if renderer design is put down on paper (regXboi, 17:39:50)
    35. readams replies to something that comes out to the scribe as "not yet" (regXboi, 17:40:15)
    36. lenrow asks about a capability infrastructure (regXboi, 17:40:33)
    37. renderers can complain by raising exception (dconde, 17:40:39)
    38. that is in the design on Wiki (dconde, 17:40:51)
    39. lenrow asks where the code? (regXboi, 17:40:52)
    40. filling in details of design needs to be done, but there is an architecture diagram on wiki. but we need to fill in details. (dconde, 17:41:36)
    41. https://wiki.opendaylight.org/view/Group_Policy:Architecture Architecture wiki page (tbachman, 17:41:57)
    42. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model Policy architecture page (tbachman, 17:42:13)
    43. concept of subject features - set of actions and classifiers supported will go a long way to address this (dconde, 17:42:28)
    44. yang models and code for the policy and endpoint registry are in ODL git (tbachman, 17:43:12)
    45. important to desribe wht is capable so we can expose in UI (tbachman, 17:44:11)
    46. go to wiki and please check the arch link in dev doc. (dconde, 17:44:37)
    47. lenrow will go look at it offline (dconde, 17:45:06)
    48. we should just get online at top of hours to air concerns in arch meeting (dconde, 17:47:13)


Meeting ended at 17:47:43 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dconde (75)
  2. regXboi (26)
  3. tbachman (8)
  4. odl_meetbot (8)
  5. s3wong (7)
  6. mickey_spiegel (7)
  7. lenrow (2)


Generated by MeetBot 0.1.4.