#opendaylight-group-policy: gbp_model

Meeting started by tbachman at 17:04:57 UTC (full logs).

Meeting summary

  1. opening the floor for model topics (tbachman, 17:06:39)
    1. readams asks if anyone has anything they’d want to bring up (tbachman, 17:07:00)
    2. lenrow has something he may bring up in the architecture meeting, but nothing for now (tbachman, 17:07:33)
    3. the question he has is how would you use GBP in a wireless/mobility scenario, where EPs migrate from AP to AP (roaming problem) (tbachman, 17:07:59)
    4. readams says that policy is independent of the location, so this should work — but falls to the renderer (tbachman, 17:08:22)
    5. we’ll cover this more in the architecture meeting (tbachman, 17:08:59)
    6. mickey_spiegel brings up the question of what’s mandatory and optional in yang model - not clear in yang model, but is clearer in the model that dvorkin showed (tbachman, 17:09:23)
    7. readams says he’s looking into it — for the most part, mostly none of it is mandatory (tbachman, 17:09:43)
    8. readams says that there are a few places here and there where he may be missing a mandatory=true (tbachman, 17:10:20)
    9. readams reccomends more eyes on the model (tbachman, 17:10:50)
    10. mickey_spiegel also brings up defaults — especially L2/L3 context, where we need to choose some defaults (tbachman, 17:11:19)
    11. mickey_spiegel just wants to make sure we have a deterministic behavior (tbachman, 17:12:16)
    12. readams notes that you can have environments that have no L2 at all, so saying in the model that you have a default L2 context might not be what we want (tbachman, 17:12:39)
    13. readams says it probably makes sense to have a default L2 context within any given L3 context — but that may not be well definied, b/c you need a subnet mapped to it. (tbachman, 17:13:20)
    14. mickey_spiegel says that some of this may be render-dependent (tbachman, 17:13:58)
    15. readams says that it would be helpful if someone could take a look at the defaults in the model, that would be helpful. (tbachman, 17:15:57)
    16. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model <= policy arch (tbachman, 17:17:09)
    17. https://wiki.opendaylight.org/view/Group_Policy:Architecture <= overall arch (tbachman, 17:17:37)
    18. https://wiki.opendaylight.org/view/Group_Policy:Architecture/OpFlex_Renderer <= arch for opflex (tbachman, 17:17:58)
    19. https://wiki.opendaylight.org/view/Group_Policy:Architecture/OpenFlow_Renderer <= arch for openflow (tbachman, 17:18:13)
    20. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Renderer_Common <= arch for renderer common (tbachman, 17:18:33)
    21. alagalah asks for people to contribute to agenda items for meetings (tbachman, 17:22:20)
    22. and meetings will be consolidated, and more generalized (i.e. not a separate renderers, arch, model, etc.) (tbachman, 17:23:01)
    23. ACTION: alagalah will send out email proposing this to the list (tbachman, 17:23:24)
    24. alagalah would like to start driving things via trello (tbachman, 17:23:43)
    25. alagalah would like to kick off every meeting with a trello update (tbachman, 17:23:52)
    26. https://trello.com/b/edPC5PAe/odl-gbp-helium <= link to trello board (tbachman, 17:24:08)
    27. contact alagalah if you aren’t subscribed to the board. You need to be subscribed in order to add yourself to cards, etc. (tbachman, 17:24:32)


Meeting ended at 17:26:38 UTC (full logs).

Action items

  1. alagalah will send out email proposing this to the list


People present (lines said)

  1. tbachman (30)
  2. odl_meetbot (3)
  3. readams (2)
  4. dconde (2)


Generated by MeetBot 0.1.4.