#opendaylight-group-policy: gbp-status

Meeting started by dconde at 19:59:59 UTC (full logs).

Meeting summary

    1. for hangout is https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o (dconde, 20:04:19)
    2. here (mickey_spiegel, 20:06:12)
    3. here (dvorkinista, 20:06:18)
    4. dconde here (dconde, 20:07:21)
    5. here (s3wong, 20:07:24)

  1. start of meeting (dconde, 20:07:52)
    1. agenda item (dconde, 20:07:59)
    2. we see the list of people who will be committed (dconde, 20:08:30)
    3. anyone else should speak up. (dconde, 20:08:37)
    4. AGREED: that the list if what we have for now. (dconde, 20:08:52)
    5. liemmn is 20%, right? but may ramp in future? (dconde, 20:09:27)
    6. liemmn said starting at less than 20 but may ramp to 40% (dconde, 20:09:50)
    7. uchau may ramp up in similar way (dconde, 20:10:03)
    8. Hemanth adds 20% to himself and another TBD from oneConvergence. (dconde, 20:10:34)
    9. A4, a4 in spreadsheet is a reference to tasks in the spreadsheet. (dconde, 20:10:53)
    10. concept of dummy renderer. (dconde, 20:11:11)
    11. we see a diagram on the hangout. (dconde, 20:11:19)
    12. this idagram is going to change since renderers have two components. we have common store for the 4 boxes. repo, ep reg, enforcement repo, op states. (dconde, 20:12:14)
    13. benefits in parallel development by creating a dummy renderer that statically responds (like a stub?) same for SB renderer (dconde, 20:12:45)
    14. it's a stub with a statically defined field. (dconde, 20:13:12)
    15. if I know the subject,etc. we can stuff the subject into the stub (dconde, 20:13:34)
    16. we need to work with the scorer for the scalar generation algorithm. Someone in APIC team has done that. So alagalah will contact them for background. (dconde, 20:14:14)
    17. same for thresholding and acknowledgement (dconde, 20:14:28)
    18. the boxes have very little intelligence in them. (dconde, 20:14:39)
    19. the renderer has all the intelligence in them. (dconde, 20:14:49)

  2. parallel implementation (dconde, 20:15:15)
    1. the DSE talk to the Endpoint registry / mapper (dconde, 20:17:29)
    2. DSE / Governance / Congress /etc. needs to fit in. (dconde, 20:17:45)
    3. DSE stands for data services engine (dconde, 20:18:00)
    4. Plexxi guys contributed that to the Congress project. (dconde, 20:18:10)
    5. DSE pulls out network metadata from other sources (dconde, 20:18:36)
    6. there is a placeholer in the release plan. (dconde, 20:19:36)
    7. we start with OpenFlow and OpFlex moved into incubation this morning (dconde, 20:19:51)
    8. so that's a real project. (dconde, 20:20:03)
    9. we want to implement REnderer common and migrate OF Strawman (dconde, 20:20:58)
    10. we will talk about that in the ARCH meeting tomorrow. (dconde, 20:22:11)
    11. we think subscription and rendering is intertwined. (dconde, 20:22:27)
    12. everyting in column A should be a sheet. (dconde, 20:22:38)
    13. interdependencies are critical. (dconde, 20:22:53)

  3. release plan schedule (dconde, 20:23:13)
    1. we are looking at gates. (dconde, 20:23:24)
    2. M1 to M3 is easy (dconde, 20:23:30)
    3. M4 and 5 are harder (dconde, 20:23:34)
    4. all things are gated on beginning of a week except we have a conflict with Labor day for code freeze (dconde, 20:24:41)
    5. probability for working on labor day is low (dconde, 20:25:24)
    6. dvorkinista reviewing release plan. (dconde, 20:25:36)
    7. this is aggressive. (dconde, 20:25:49)
    8. if people at 20% then if you are not familiar with ODL it's hard. (dconde, 20:26:08)
    9. we can do stuff like pair work, etc to ramp it up. alagalah says we need to experience first hand if this is sane. (dconde, 20:26:50)
    10. if the goal is to render everything forever, it's hopeless. (dconde, 20:27:23)
    11. we need to understand the subset. (dconde, 20:27:30)
    12. dlenrow is talking about stretch goals, etc. a few subjects to render (dconde, 20:27:58)
    13. dvorkinista says if we do it well, it's better than something fast that does not work. (dconde, 20:28:26)
    14. mickey_spiegal says that contracts and such need to be put in early. (dconde, 20:29:07)
    15. dvorkinista says it needs to be fast too. (dconde, 20:29:27)
    16. alagalah says a subset is doable. (dconde, 20:29:48)
    17. dvorkinista (dconde, 20:30:18)
    18. most affects are on service chaining, but dvorkinista says we can hold off on that but it needs to be done well, and we can wait for that. (dconde, 20:30:43)
    19. we need to be very careful and not over commit. (dconde, 20:31:12)

  4. service chaining (dconde, 20:31:25)
    1. looking at diagram (dconde, 20:31:50)
    2. the diagram will be mailed out. (dconde, 20:32:06)
    3. dvorkinista we need to make sure it is extensible. (dconde, 20:32:15)
    4. OK to skip functions to edit without rewrite. (dconde, 20:32:23)
    5. dvorkiinsta not worried about policy. EPR needs to be fast. Renderer is where all crazy behaviour is. (dconde, 20:32:57)
    6. it seems to make sense for parallel development. (dconde, 20:33:18)
    7. alagalah says we need to worry about extensibility in renderer. (dconde, 20:33:37)
    8. we need to describe a policy that governs that. (dconde, 20:33:58)
    9. all of these things can be subclassed, says dvorkinista (dconde, 20:35:10)
    10. OF stuff is down below, says mickey_spiegel (dconde, 20:35:20)
    11. this is in the OF render, not part of the common renderer. (dconde, 20:36:15)
    12. dvorkiista says it's another layer of abstraction. OpenFlow based, affinity, etc. (dconde, 20:37:00)

  5. renderer (dconde, 20:37:34)
    1. we are redrawing diagram. (dconde, 20:37:47)
    2. adding OF renderer below Flow based renderer (dconde, 20:38:01)
    3. idea to make the dummy object is statically defined and we invoke this into flows. (dconde, 20:38:54)
    4. flow based rendering is not stateless. (dconde, 20:39:22)
    5. render common is constantly rendering. Are we worried about passing vs. storing. (dconde, 20:39:58)
    6. we talked about schedule. (dconde, 20:41:29)

  6. recap (dconde, 20:41:35)
    1. is this a sane plan? (dconde, 20:41:42)
    2. keep everything equal. and statically define it. (dconde, 20:43:16)
    3. readams asks.does the dummy version need to be created first? (dconde, 20:43:47)
    4. readams says we cannot make progress until model is defined. (dconde, 20:44:26)
    5. readams what is A5 for renderer? (dconde, 20:45:22)
    6. alagalah asks which parts do you want to contrib to? (dconde, 20:46:09)

  7. call fo volunteers (dconde, 20:46:21)
  8. call for volunteers (dconde, 20:46:31)
  9. we have a proposal now. (dconde, 20:47:34)
    1. liemnm how do we do tests? (dconde, 20:47:52)
    2. we do have dependencies -- says lenrow (dconde, 20:48:40)
    3. alagalah UI extensions are unknown. (dconde, 20:48:50)
    4. we need to look at QOS, openflow 1.3 metering impl, etc. (dconde, 20:50:05)
    5. this may limit what labels we can use. (dconde, 20:50:11)
    6. ACTION: alagalah to follow on edwarnicke ODL plans (dconde, 20:50:31)
    7. test dev platform == mininet. but ideally we need real set-up. (dconde, 20:52:51)
    8. tbachman to document the ovsdb / openstack / ovs dev environment (dconde, 20:53:20)
    9. also for openflow on mininet. (dconde, 20:53:28)
    10. for OpFlex, it's nascent, so we need to figure out. probably mininet too,b ut it may be ovs switches directly on Linux. Who knows. (dconde, 20:53:58)
    11. spredsheet was emailed out. (dconde, 20:54:44)
    12. sharing is failing. (dconde, 20:55:10)
    13. sharing of gDocs done. (dconde, 20:56:13)

  10. anything else? (dconde, 20:56:53)
    1. monday COB has the final commitment. (dconde, 20:57:22)
    2. if you cannot get on ghangout then go to IRC and say you cannot get on, and then we can fire off a WebEx. (dconde, 20:59:07)
    3. of use YouTube live to stream video. (dconde, 20:59:40)


Meeting ended at 20:59:53 UTC (full logs).

Action items

  1. alagalah to follow on edwarnicke ODL plans


Action items, by person

  1. alagalah
    1. alagalah to follow on edwarnicke ODL plans


People present (lines said)

  1. dconde (122)
  2. dlenrow (4)
  3. dvorkinista (4)
  4. odl_meetbot (4)
  5. jmedved (2)
  6. tbachman (2)
  7. mickey_spiegel (1)
  8. s3wong (1)
  9. alagalah (0)


Generated by MeetBot 0.1.4.