#opendaylight-group-policy: gbp_status

Meeting started by tbachman at 19:59:44 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 19:59:57)
    1. Agenda https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 20:03:52)

  2. RC1, Karaf and package update - Bachman (alagalah, 20:04:07)
    1. Group Based Policy is in the RC1 release artifact (tbachman, 20:04:32)
    2. There was one issue that was project-wide, involving restconf (tbachman, 20:04:47)
    3. but there’s a workaround (tbachman, 20:05:22)
    4. TSC voted today to cut final release artifacts on Monday 9/22 (tbachman, 20:05:43)
    5. The TSC will give a go/no-go to the release on the following Thursday’s TSC call (tbachman, 20:06:46)
    6. There will be release review meetings on Wednesday and Thursday, during the current bug-scrub meetings, for 2 hrs (tbachman, 20:07:14)
    7. Each project will have ~10 minutes for their release review, and will be allocated a time slot by Phil Robb and George Zhao (tbachman, 20:07:58)
    8. The autorelease setup that Ed Warnicke created will handle converting from the SNAPSHOT releases to production, so no action is needed on our part for that (tbachman, 20:08:32)

  3. Release Review preso next week (alagalah, 20:09:07)
    1. Items to be covered: (alagalah, 20:09:13)
    2. Features , Non-Code Aspects (user docs, examples, tutorials, articles), Architectural Issues, Security Issues, Quality Assurance (test coverage, etc), End-of-life (API/Features EOLed in Release), Bugzilla (summary of bug situation), Standards (summary of standard compliance) ,Schedule (initial schedule and changes over the release cycle) (alagalah, 20:11:05)
    3. ACTION: Keith (alagalah) to cover these items in a quick (must be <10min) preso (alagalah, 20:11:25)

  4. POC now open for business - Burns/Bachman (alagalah, 20:11:41)
    1. https://wiki.opendaylight.org/view/Group_Policy:Building_and_Running (alagalah, 20:12:20)
    2. The POC is now working, thanks to bug fixing over the weekend that alagalah did with Ed Warnicke, Tony Tkacik, and Michal Rehak (tbachman, 20:13:23)
    3. there was a change to the controller in terms of referencing the right Instance IDs in the Flow Capaable Node (tbachman, 20:14:40)
    4. there was also a change to yangtools to address a recent change to the codecs that was made (tbachman, 20:15:05)
    5. there were also two changes made to the GBP code to address another change to yangtools to address codecs (return null pointers instead of empty lists) (tbachman, 20:15:59)

  5. Docs - Mickey (alagalah, 20:16:55)
    1. mickey not available today, thomas? (alagalah, 20:17:07)
    2. mickey_spiegel is about 1/3 through converting readams’ text (tbachman, 20:17:44)
    3. https://wiki.opendaylight.org/view/Group_Policy:Architecture and sub-files (alagalah, 20:17:58)
    4. The documentation is not part of autorelease, so if it’s cut on Monday, it will be done so manually (tbachman, 20:29:28)
    5. the goal should be to have docs ready for Monday, with speculation that there may be some iterations (tbachman, 20:29:45)

  6. other items (tbachman, 20:30:38)
    1. Noiro is no longer at Sunnyvale, moving to B15, Cisco Campus (alagalah, 20:30:47)
    2. tbachman urges folks to download the RC2 (final) release artifacts and run the demo — the more platforms we get testing on the better (tbachman, 20:31:22)


Meeting ended at 20:32:08 UTC (full logs).

Action items

  1. Keith (alagalah) to cover these items in a quick (must be <10min) preso


Action items, by person

  1. alagalah
    1. Keith (alagalah) to cover these items in a quick (must be <10min) preso


People present (lines said)

  1. tbachman (36)
  2. alagalah (36)
  3. edwarnicke (11)
  4. mickey_spiegel (6)
  5. odl_meetbot (5)


Generated by MeetBot 0.1.4.