#opendaylight-group-policy: gbp_status_arch

Meeting started by tbachman at 18:00:18 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 18:01:46)
    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting Agenda for today’s Status/Arch meeting (tbachman, 18:03:00)

  2. Review of cleaned up Trello (tbachman, 18:03:13)
    1. alagalah condensed the number of cards by making checklists (tbachman, 18:05:49)
    2. The “Super-cala-fragalistic important” category contains items that were deferred from the Helium release (tbachman, 18:06:31)
    3. Team members are encouraged to pick cards from this Trello category first (tbachman, 18:07:16)
    4. https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Lithium Trello board for GBP (tbachman, 18:07:48)

  3. Lithium Release plan (tbachman, 18:08:36)
    1. shares a template for the Li Release Plan (link below) (alagalah, 18:09:45)
    2. https://docs.google.com/a/noironetworks.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit#gid=0 (alagalah, 18:09:52)
    3. ACTION: tbachman to link to GBP wiki and email -dev list (alagalah, 18:10:06)
    4. alagalah notes that Offset0 and Offset2 are the easiest to grok.. ie Offset0: others depend on you, you don't depend on other Offset2: you depend on others, no one depends on 2. Offset1 is a little more hazy (as in I haven't heard a definitive defn) (alagalah, 18:13:28)

  4. WIP (tbachman, 18:18:26)
    1. alagalah working on design for the PolicyException Handler (tbachman, 18:19:12)
    2. Similar to the FCAPs model for alarming (tbachman, 18:19:21)
    3. This represents an alarm that can change over time (tbachman, 18:19:39)
    4. Alarm Severity Assignment Profile model (ASAP), which is an operational policy (tbachman, 18:20:33)
    5. The severity of the inability to get that policy can be augmented by the operational policy (tbachman, 18:21:30)
    6. alagalah invites those with Telcordia/FCAPs experience to help out (tbachman, 18:23:13)
    7. dbainbri asks how to refer to individual cards on the Trello board (tbachman, 18:24:25)
    8. alagalah says that each card has a name (e.g. card 37) and a link (tbachman, 18:24:39)
    9. https://trello.com/c/hjSnav8q - Exception handling trello card (alagalah, 18:25:45)
    10. https://trello.com/c/V8RqRzlC - Exception handling coding trello card (alagalah, 18:26:03)
    11. https://tools.ietf.org/html/draft-smith-opflex-00 Original OpFlex RFC (tbachman, 18:29:07)

  5. POSTMAN files on wiki (tbachman, 18:29:25)
    1. ACTION: alagalah to push POSTMAN files to the wiki (tbachman, 18:29:48)
    2. POSTMAN files can be used to exercise REST APIs with GBP (tbachman, 18:30:04)

  6. Update on OpenStack Paris (tbachman, 18:30:41)
    1. https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/group-based-policy-extension-for-networking Group Based Policy Extension for Networking video at OpenStack Paris summit (tbachman, 18:30:53)
    2. https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/opendaylight-and-openstack-developer-panel OpenStack and OpenDaylight developer panel video at OpenStack Paris summit (tbachman, 18:30:54)
    3. https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/sponsor-demo-theater-one-convergence-policy-driven-network-service-delivery One Convergence: Policy Driven Network Service Delivery video at OpenStack Paris summit (tbachman, 18:30:55)
    4. https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/neutron-roundtable-overlay-or-full-sdn Neutron Round Table: Overlay or Full SDN? video at OpenStack Paris summit (tbachman, 18:30:56)
    5. (tbachman, 18:30:57)
    6. : https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/sponsor-demo-theater-opendaylight-opendaylight-and-the-rise-of-open-source-sdn OpenDaylight and the Rise of OpenSource SDN video at OpenStack Paris summit (tbachman, 18:33:08)

  7. HOW TOs (alagalah, 18:33:48)
    1. alagalah asks what we’re missing in order to make the project more consumable and easier to use? (tbachman, 18:34:16)
    2. alagalah notes we have wiki pages describing the arch and the POC (tbachman, 18:34:39)
    3. alagalah says we’re missing a component map, along the lines of other projects (e.g. MD-SAL) (tbachman, 18:35:16)
    4. https://wiki.opendaylight.org/view/Group_Policy:Architecture GBP Arch wiki page (tbachman, 18:35:26)
    5. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model GBP Policy Model wiki page (tbachman, 18:35:44)
    6. https://wiki.opendaylight.org/view/Group_Policy:Architecture/OVS_Overlay GBP OVS Overlay wiki page (tbachman, 18:36:07)
    7. mickey_spiegel says the main thing that’s missing is more examples and use cases of policies and how you would use the model to do different things (tbachman, 18:36:51)
    8. alagalah says that was one of the goals of the latest iteration of the POC (i.e. dockerization), but notes that we could do morehere (tbachman, 18:37:17)
    9. alagalah asks what use cases mickey_spiegel would like to see (tbachman, 18:38:16)
    10. mickey_spiegel says he created a list before the Helium release, and will provide that (tbachman, 18:38:29)
    11. tbachman says there are use cases that Sanjay provided (tbachman, 18:39:19)
    12. mickey_spiegel says that those were a bit more complex, and that simpler use cases would probably be more useful (tbachman, 18:39:35)
    13. alagalah says the current POC is only a “two-tier”, so maybe a 3-tier might be helpful (tbachman, 18:40:18)
    14. https://wiki.opendaylight.org/images/8/83/Policy_Usecases.pptx Use cases created by Sanjay (tbachman, 18:40:29)
    15. dbainbri says component maps, API doc, tutorials are all very useful (tbachman, 18:41:53)
    16. ACTION: alagalah to document the FLOW of information through GBP and the OFOverlayRenderer in a diagram to help augment or show at a high-level the information that is represented in the Architecture wiki information (alagalah, 18:44:50)
    17. ACTION: alagalah also how it interacts with all of ODL ie openflowplugin or indeed how to get it from a RESTcall etc (alagalah, 18:45:29)
    18. ACTION: alagalah to make a User level walk thru (5min preso type level) (alagalah, 18:46:06)
    19. Andrew has some ideas for the GUI/UI (tbachman, 18:48:28)
    20. initial thought for policies and contracts is sort of a google maps concept (tbachman, 18:48:43)
    21. you could zoom in to endpoints, zoom out to policies between data centers, etc. (tbachman, 18:49:21)
    22. The other dimension to the UI is specifying policies/contracts (tbachman, 18:49:41)


Meeting ended at 18:54:33 UTC (full logs).

Action items

  1. tbachman to link to GBP wiki and email -dev list
  2. alagalah to push POSTMAN files to the wiki
  3. alagalah to document the FLOW of information through GBP and the OFOverlayRenderer in a diagram to help augment or show at a high-level the information that is represented in the Architecture wiki information
  4. alagalah also how it interacts with all of ODL ie openflowplugin or indeed how to get it from a RESTcall etc
  5. alagalah to make a User level walk thru (5min preso type level)


Action items, by person

  1. alagalah
    1. alagalah to push POSTMAN files to the wiki
    2. alagalah to document the FLOW of information through GBP and the OFOverlayRenderer in a diagram to help augment or show at a high-level the information that is represented in the Architecture wiki information
    3. alagalah also how it interacts with all of ODL ie openflowplugin or indeed how to get it from a RESTcall etc
    4. alagalah to make a User level walk thru (5min preso type level)
  2. tbachman
    1. tbachman to link to GBP wiki and email -dev list


People present (lines said)

  1. tbachman (55)
  2. alagalah (10)
  3. odl_meetbot (7)


Generated by MeetBot 0.1.4.