#opendaylight-group-policy: gbp_status_arch

Meeting started by tbachman at 18:00:51 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 18:00:56)
    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting Agenda for today’s meeting (tbachman, 18:01:07)
    2. https://cisco.webex.com/cisco/j.php?MTID=m783db2a03dec4c9aab0e22e43db642d6 (tbachman, 18:02:53)

  2. OpenStack Integration (tbachman, 18:03:43)
    1. https://review.openstack.org/#/c/134285/1/specs/juno/gbp-odl-policy-driver.rst,unified openstack blueprint for group based policy integration with opendaylight (tbachman, 18:05:58)
    2. s3wong says the groupbasedpolicy for openstack will be released as a separte bundle for Juno (december time frame) (tbachman, 18:09:38)
    3. default driver maps policy constructs to neutron constructs (tbachman, 18:09:49)
    4. There are also 2 vendor drivers: OneConvergence and APIC (tbachman, 18:10:03)
    5. There currently isn’t a driver for opendaylight (tbachman, 18:10:11)
    6. s3wong will be writing this driver (tbachman, 18:10:18)
    7. The driver will do a one-to-one mapping of OpenStack GBP constructs to ODL GBP constructs (tbachman, 18:10:48)
    8. There will be an extension driver created as well (tbachman, 18:11:17)
    9. s3wong says a gap analysis is needed (tbachman, 18:11:50)
    10. openstack has support for redirect to a service (tbachman, 18:11:58)
    11. GBP has such support, but there’s no such concept as services in ODL (tbachman, 18:12:19)
    12. the assignment of resources to things like a load balancer is done by openstack groupbasedpolicy, but such constructs may not exist in ODL (tbachman, 18:14:04)
    13. YaPeng Wu from Hauwei plus 2-5 others may be joining the effort (tbachman, 18:14:34)
    14. YaPeng is also interested in writing the OVSDB renderer (tbachman, 18:14:49)
    15. There is an effort to create a policy program in openstack, so GBP and Congress may become part of that (tbachman, 18:16:41)
    16. The repo currently doesn’t have any CI, but as part of the effort, CI needs to be stood up in GBP repo to vote on patches (tbachman, 18:17:39)
    17. Vendor CI will probably be done as part of Juno (tbachman, 18:18:27)
    18. The feature-freeze for Juno is in 2 weeks, and ODL driver probably won’t make it (tbachman, 18:18:49)
    19. This may not be bad, as the Lithium cycle aligns well with the Kilo release (tbachman, 18:19:06)

  3. HOW-TOs (tbachman, 18:20:08)
    1. https://docs.google.com/a/noironetworks.com/document/d/1bZAwLk1EffE3ZU3QfzROZQ5kDdm6yScBcZADIFKFDbo/edit Original Use Cases document on GBP wiki (tbachman, 18:21:16)
    2. alagalah welcomes anyone to add to this (tbachman, 18:21:40)
    3. By separating infrastructure and policy, it makes it easier to stand up different infrastructures using the same policy (tbachman, 18:22:30)
    4. alagalah would like to set up a 3-tier web app (tbachman, 18:23:04)
    5. Daniel asks to see something that’s not a pure consumer/producer relationshipo (tbachman, 18:24:08)
    6. alagalah says that for peer-to-peer, the model does support intra-group policy, but this is currently stubbed in the code (tbachman, 18:24:51)
    7. alagalah asks what sorts of things Daniel would like to see (tbachman, 18:25:12)
    8. Daniel says it’s mostly for access (e.g. ICMP) (tbachman, 18:25:28)
    9. alagalah says that currently the default behavior within an EPG is to allow connectivity (tbachman, 18:25:54)
    10. ACTION: to look into this further and get back to Daniel (tbachman, 18:26:10)
    11. Daniel says from an orchestration perspective, he doesn’t want to have to track which group is a provider and which is a consumer of a contract (tbachman, 18:30:59)
    12. alagalah says that we need to work out how we’re going to work the producer/consumer for the UI as well (tbachman, 18:31:26)

  4. Trello Board (tbachman, 18:35:08)
    1. alagalah working on opstate and exception repository design (tbachman, 18:36:14)
    2. alagalah wants to have fault rules (e.g. threshold crossing), and can assign severity to a fault and have it placed in the data store (tbachman, 18:37:24)
    3. the heuristics need to be configurable by the operator (tbachman, 18:37:59)
    4. these would be operational policies (tbachman, 18:38:04)
    5. alagalah says that there’s also a question of how to apply governance to all of this, but that’s further down the road (tbachman, 18:39:08)
    6. https://tools.ietf.org/html/draft-smith-opflex-01 Latest OpFlex RFC (tbachman, 18:40:20)
    7. tbachman working on updating the OpFlex renderer based on these RFC updates (tbachman, 18:42:01)
    8. alagalah going to work on the 3-tier web app demo as well (tbachman, 18:42:13)
    9. https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Trello board for GBP (tbachman, 18:42:31)

  5. Lithium Release Plan (tbachman, 18:42:38)
    1. https://docs.google.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit?usp=sharing Template for project tracking (tbachman, 18:55:14)


Meeting ended at 18:57:58 UTC (full logs).

Action items

  1. to look into this further and get back to Daniel


People present (lines said)

  1. tbachman (60)
  2. rgowrishankar (10)
  3. s3wong (7)
  4. odl_meetbot (5)
  5. alagalah (0)


Generated by MeetBot 0.1.4.