#opendaylight-group-policy: group-based-policy 14-05-15 STATUS

Meeting started by alagalah at 20:11:39 UTC (full logs).

Meeting summary

  1. Agenda review (alagalah, 20:11:54)
  2. Agenda: https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 20:12:39)
    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 20:12:48)
    2. regXboi here (regXboi, 20:13:31)
    3. tbachman here (tbachman, 20:13:37)
    4. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2014-May/000171.html (readams, 20:13:40)
    5. readams mickey_spiegel alagalah here in Sunnyvale (alagalah, 20:13:48)
    6. jmedved here (jmedved, 20:14:25)
    7. what Rob linked is the current Functional Spec (alagalah, 20:14:27)
    8. are we taking comments on the architectural wiki page? (regXboi, 20:14:47)
    9. it's the current status as of yesterday (readams, 20:14:49)
    10. ie, he is tongue in cheek saying "This is the current status" which is fair, but I have one or two more things to cover (alagalah, 20:14:57)
    11. I'm concerned about the first figure (regXboi, 20:15:06)
    12. it's missing something (regXboi, 20:15:13)
    13. https://wiki.opendaylight.org/view/File:Group-based_policy_architecture.png (alagalah, 20:15:36)
    14. regXboi are you thinking back to this: https://wiki.opendaylight.org/view/File:Architecture-tasks.png (alagalah, 20:18:38)
    15. no (regXboi, 20:19:04)
    16. I'm thinking more like list (regXboi, 20:19:15)
    17. aw shoot, the figure I want isn't where I thought it was (regXboi, 20:19:57)
    18. can we hide multiple repos from the API exposed? More complexity that has nothing to do with user domain intent (lenrow, 20:20:25)
    19. regXboi alagalah have read func spec. mickey_spiegel has read outline (alagalah, 20:22:14)
    20. readams notes 10% done (alagalah, 20:22:22)
    21. tbachman has skimmed it (tbachman, 20:22:28)
    22. Suggest that people start to review it and comment on the mailer (alagalah, 20:22:56)
    23. the thing you should read now is the model (readams, 20:22:59)
    24. http://pastebin.com/DrsWSUAn (regXboi, 20:23:05)
    25. Duly noted that regXboi points out that API does not live on restCONF alone, but on every word from the mouth of REST (alagalah, 20:33:30)
    26. alagalah had a bad bible upbrining (alagalah, 20:33:45)

  3. Trello/Plan Of Record (alagalah, 20:34:29)
    1. https://docs.google.com/a/noironetworks.com/spreadsheets/d/1Tp2dblnizQ4xi_4xcQgHP8dRPiqxdgC9pqlRdEuP6_I/edit#gid=0 (alagalah, 20:35:02)
    2. https://trello.com/b/edPC5PAe/odl-gbp-helium (alagalah, 20:35:41)
    3. I'm assuming that those on the PlanOfRecord who are committed to contributing have made their intentions known. (alagalah, 20:36:28)
    4. as we get to complete the Func Spec, my intention is that a lot of these meetings are going to disappear, and meetings will be between contributors on the project. (alagalah, 20:36:59)
    5. any questions? (alagalah, 20:37:09)
    6. as discussed my goal is to prototype some end-to-end use cases using GBP. We will likely commit resources to subprojects as required to accomplish this. still TBD (e.g. model, rendering, etc.) (lenrow, 20:39:09)
    7. As of next week, my intention is to start managing the meetings via Trello (alagalah, 20:39:28)
    8. EPR/PR very close to being done (in terms of Yang). (alagalah, 20:41:48)
    9. ACTION: regXboi to catch up Exception/Enforcement YANG (regXboi, 20:42:52)
    10. ACTION: alagalah to define Renderer commons (alagalah, 20:43:20)
    11. ACTION: tbachman, jmedved, lenrow uchau to work end-to-end use cases (regXboi, 20:45:00)
    12. ACTION: alagalah to start each meeting that has a sub-group that applies with the trello sub-group (alagalah, 20:46:49)

  4. Any other business? (alagalah, 20:47:01)
    1. move to adjourn? (regXboi, 20:47:13)
    2. +1 (alagalah, 20:47:19)
    3. +1 (tbachman, 20:47:24)


Meeting ended at 20:47:37 UTC (full logs).

Action items

  1. regXboi to catch up Exception/Enforcement YANG
  2. alagalah to define Renderer commons
  3. tbachman, jmedved, lenrow uchau to work end-to-end use cases
  4. alagalah to start each meeting that has a sub-group that applies with the trello sub-group


Action items, by person

  1. alagalah
    1. alagalah to define Renderer commons
    2. alagalah to start each meeting that has a sub-group that applies with the trello sub-group
  2. jmedved
    1. tbachman, jmedved, lenrow uchau to work end-to-end use cases
  3. lenrow
    1. tbachman, jmedved, lenrow uchau to work end-to-end use cases
  4. regXboi
    1. regXboi to catch up Exception/Enforcement YANG
  5. tbachman
    1. tbachman, jmedved, lenrow uchau to work end-to-end use cases


People present (lines said)

  1. regXboi (77)
  2. alagalah (68)
  3. tbachman (28)
  4. readams (27)
  5. lenrow (16)
  6. jmedved (14)
  7. odl_meetbot (7)
  8. mickey_spiegel (1)


Generated by MeetBot 0.1.4.