#opendaylight-group-policy: Group Policy Status
Meeting started by readams1 at 19:56:55 UTC
(full logs).
Meeting summary
- 
  - https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o
    (alagalah,
    19:59:27)
- https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o
    (readams1,
    20:02:13)
 
 
- Actions from last week (readams1, 20:05:30)
  - Datastore: they tentatively stated we'd used
    MD-SAL and figure out how to implement sharding (readams1,
    20:06:55)
- Need to benchmark and verify working
    assumptions (readams1,
    20:07:15)
- repository/endpoint: working on defining basic
    outline, need help with MD-SAL best practices (readams1,
    20:07:44)
- Jan will help to build the model (readams1,
    20:09:23)
- ACTION: alagalah
    readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to
    build Yang for Endpoint Reg and a subset of the UML Model with
    potentially a follow up Tue Apr29 with jmedved and Tony (alagalah,
    20:12:16)
- Jan may invite other people to help with
    this. (readams1,
    20:13:00)
- ACTION: Prior
    commitment to have Endpoint Reg strawman for Mon Apr28 may not be
    feasible. (alagalah,
    20:13:15)
- Renderer meetings on hold until
    readams1/alagalah get strawman Renderer. May be predicated on
    YANG/MD-SAL discussions so will have better idea Monday Apr28
    (alagalah,
    20:14:44)
 
 
- Operational state (readams1, 20:15:05)
  - What does "operational state" mean?
    (readams1,
    20:16:10)
- is it about instrumentation?  Or is it about
    making sure that the end-user readily consume group-based
    policy? (readams1,
    20:17:41)
- Or is it operational data such as link-state
    information, etc? (readams1,
    20:18:40)
- Does it have to do with the
    "enforcement/exception database"? (readams1,
    20:19:14)
- People will be want to analyze logs and also
    based on specific policies or objects (readams1,
    20:20:34)
- compliance (readams1,
    20:20:39)
- ACTION: alagalah will
    talk to dvorkinista to clarify (readams1,
    20:22:21)
- divorkinsta says it's about: capture of the
    general state and exceptions associated with it (readams1,
    20:26:08)
- counters, measurements, exceptions, overall
    health, debugging, etc (readams1,
    20:26:49)
- ACTION: dvorkinista
    attends and clarifies OPSTATE. (alagalah,
    20:27:35)
 
 
- Renderer (readams1, 20:28:06)
  - We need to settle on what the downstream
    prototype plugin would work (readams1,
    20:28:39)
- we'll assume for now we'll use OpenFlow
    implementation, but we'll investigate what's the easiest
    (readams1,
    20:29:46)
- Affinity might also provide a reasonable
    renderer (readams1,
    20:30:14)
- Openflow/ovsdb may be the most understandable,
    but we'll have to see (readams1,
    20:31:43)
- ACTION: alagalah will
    look at the different projects to figure out what has the most
    reasonable northbound API (readams1,
    20:32:54)
- Another possibility would be
    netconf/ACL/whatever (readams1,
    20:33:42)
- options are: opendove, ovsdb, netconf,
    openflow (readams1,
    20:34:17)
- openflow/ovsdb are known quantity, not tied to
    a vendor (readams1,
    20:34:52)
- Note that this isn't the only rendered: just
    the first renderer (readams1,
    20:35:13)
 
 
- Helium release plan (readams1, 20:35:21)
  - https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan
    (alagalah,
    20:35:57)
- I don't see the desktop. (dconde,
    20:36:25)
- now I do. (dconde,
    20:36:27)
- Do declare intent to participate in
    simultaneous release, we need to publish our release plan for public
    comment (readams1,
    20:37:59)
- project plan needs to align to the milestone
    dates (readams1,
    20:38:13)
- release plan template is still for
    Hydrogen (dconde,
    20:38:33)
- release plan template needs to be
    updated (readams1,
    20:38:48)
- does it resemble a waterfall project
    plan? (dconde,
    20:39:18)
- regxboi states it is. (dconde,
    20:39:23)
- https://wiki.opendaylight.org/view/Open_DOVE:Release_Plan_2013
    (regXboi,
    20:39:57)
- can change the draft release plan until
    M2 (dlenrow_,
    20:40:21)
- big milestones are M4 and M5 (dconde,
    20:40:38)
- plans are not supposed to change after
    M2. (dconde,
    20:41:19)
- most project didn't really hit milestones for
    Hydrogen (readams1,
    20:41:48)
- there's some tolerance for minor misses
    (readams1,
    20:43:08)
- two weeks left to create a plan. (dconde,
    20:43:22)
- we cannot put features into patches.
    (dconde,
    20:44:16)
- ACTION: alagalah will
    build a sophisticated and complete draft plan (readams1,
    20:44:52)
- release plans are an honor system. (dconde,
    20:44:55)
- agendas = good (readams1,
    20:48:28)
 
Meeting ended at 20:49:42 UTC
(full logs).
Action items
  - alagalah readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to build Yang for Endpoint Reg and a subset of the UML Model with potentially a follow up Tue Apr29 with jmedved and Tony
- Prior commitment to have Endpoint Reg strawman for Mon Apr28 may not be feasible.
- alagalah will talk to dvorkinista to clarify
- dvorkinista attends and clarifies OPSTATE.
- alagalah will look at the different projects to figure out what has the most reasonable northbound API
- alagalah will build a sophisticated and complete draft plan
Action items, by person
  -  alagalah 
    - alagalah readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to build Yang for Endpoint Reg and a subset of the UML Model with potentially a follow up Tue Apr29 with jmedved and Tony
- alagalah will talk to dvorkinista to clarify
- alagalah will look at the different projects to figure out what has the most reasonable northbound API
- alagalah will build a sophisticated and complete draft plan
 
-  jmedved 
    - alagalah readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to build Yang for Endpoint Reg and a subset of the UML Model with potentially a follow up Tue Apr29 with jmedved and Tony
 
-  readams1 
    - alagalah readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to build Yang for Endpoint Reg and a subset of the UML Model with potentially a follow up Tue Apr29 with jmedved and Tony
 
- UNASSIGNED
    - Prior commitment to have Endpoint Reg strawman for Mon Apr28 may not be feasible.
- dvorkinista attends and clarifies OPSTATE.
 
People present (lines said)
  - readams1 (40)
- dconde (10)
- alagalah (8)
- regXboi (5)
- odl_meetbot (4)
- dlenrow_ (4)
- s3wong (2)
- jmedved (1)
Generated by MeetBot 0.1.4.