#opendaylight-group-policy: GroupBasedPolicy Status

Meeting started by alagalah at 20:06:03 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 20:07:15)

  1. First commit/merge - Special thanks to Ryan and Rob! (alagalah, 20:07:37)
    1. Corollary: Suggested commit process. (alagalah, 20:08:22)
    2. to scribes: actions should be stand alone (regXboi, 20:10:07)
    3. actions ought to be standalone (dconde, 20:10:09)
    4. does every commit require multiple code reviews? (dconde, 20:11:54)
    5. one commiter per team. but generally have one other person to review code (dconde, 20:12:38)
    6. if other person is a commiter, you can push it through. (dconde, 20:12:53)
    7. AGREED: Commit process is that each push will only need one committer. It is to their discretion if they seek other committers opinion, and/or another reviewer who may not be a committer... K.I.S.S. (alagalah, 20:15:18)
    8. votes are not cumulative (dconde, 20:15:33)
    9. ACTION: regxboi to figure out how to do the + votes (dconde, 20:16:51)
    10. ACTION: Q was raised "What happens when there is a -2?" Does the merge not happen until it is removed, even if there is a +2? regXboi (alagalah, 20:17:06)
    11. ACTION: to validate (alagalah, 20:17:40)

  2. Who is going to OpenStack summit and what are the implications to team meetings next week? (alagalah, 20:18:16)
    1. at openstack (dconde, 20:18:29)
    2. S3wong is going to OpenStack and so is Dvorkin (dconde, 20:19:31)
    3. so we will have critical mass to keep meeting next week (dconde, 20:19:42)
    4. Meetings to proceed (alagalah, 20:20:09)
    5. regxboi says there is a conflict with the Neutron GBP meeting that conflicts. (dconde, 20:20:12)

  3. regXboi There is a conflict between ODL GBP and Neutron GBP (ie Thur 1pm Pac), resolution discussion (alagalah, 20:20:33)
    1. we want the OTHER meeting to move, but what to do? (dconde, 20:21:26)
    2. shall we use Doodle again to find a free time slot? (dconde, 20:22:02)
    3. how about Monday PM? (dconde, 20:22:27)
    4. let's not use Doodle. We will use IRC instead. (dconde, 20:23:09)
    5. IDEA: alagalah proposes Mon 1p-4p(fin) Pac, Tue 1:30p-4p(fin) Pac, Fri 1p-4p(fin) (alagalah, 20:23:54)
    6. Monday is OK with me 1 pm (dconde, 20:24:36)
    7. 1-2 pm monday 1-2:30 pm tuesday nothing wed (regXboi, 20:25:20)
    8. Monday at 1pm is fine with me (tbachman, 20:25:21)
    9. ACTION: regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:00 Pac recurring (1hr) (alagalah, 20:27:05)
    10. yes, 1:30 is OK (dconde, 20:27:18)
    11. ACTION: 13:00 struck down.... regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:30 Pac recurring (1hr) (alagalah, 20:28:13)
    12. AGREED: new time for meeting (dconde, 20:28:34)
    13. be careful of -2 votes (dconde, 20:28:43)
    14. only way to remove -2 is the original reviewer to change it. (dconde, 20:29:12)
    15. ACTION: re: regXboi action item on gerrit review vote of -2... -2 blocks merge until removed. (alagalah, 20:29:14)

  4. Plan of Record (alagalah, 20:29:51)
    1. https://docs.google.com/a/noironetworks.com/spreadsheets/d/1Tp2dblnizQ4xi_4xcQgHP8dRPiqxdgC9pqlRdEuP6_I/edit#gid=0 (alagalah, 20:30:21)
    2. we agreed to ignore the prior meeting change discussion. (dconde, 20:35:26)
    3. Liem set down to zero for resources due to some conflicts. (dconde, 20:37:08)
    4. regxboi wants to fill in and float in (dconde, 20:37:26)
    5. uyen is working on use cases together with lenrow (dconde, 20:38:33)
    6. uchau working on model (dconde, 20:39:03)
    7. ACTION: plan of record is agreed upon (dconde, 20:40:39)
    8. ACTION: Each developer/contributor to review tabs and self assign themselves to a sub-project that they would like to work on (mickey_spiegel, 20:41:34)
    9. we're at our limit of 10 on hangout (tbachman, 20:42:19)
    10. ACTION: please a question mark on column A if you are not sure which subgroup you can work on, if you do know, please that in column a (dconde, 20:42:25)

  5. Trello accounts (alagalah, 20:43:03)
    1. trello accounts are driven from Google accounts. Trello is a kanban board. it is used to see who is working on what. (dconde, 20:43:34)
    2. we are not using it for full Agile method. (dconde, 20:43:50)
    3. trello for day-to-day (dconde, 20:43:58)
    4. ACTION: will people #info their names and ID into the IRC so we can set up Trello accounts. (dconde, 20:44:19)
    5. this applies to committers. (dconde, 20:44:32)
    6. regXboi@gmail.com (regXboi, 20:45:18)
    7. Jan Medved = jmedved (jmedved, 20:45:21)
    8. regxboi asks is that Google ID? (dconde, 20:45:25)
    9. alagalah says just use your email. cn be gmail or whatever. (dconde, 20:45:41)
    10. oops regxboi@gmail.com (regXboi, 20:45:57)
    11. rex pugh = rex.pugh@hp.com (rexpugh-HP, 20:46:07)
    12. Thomas Bachman tbachman@yahoo.com (tbachman, 20:47:07)
    13. you need to install scrum for trello (dconde, 20:48:15)
    14. please install scrumfortrello.com (alagalah, 20:48:18)
    15. there are chrome/ffox or safari extensions (dconde, 20:48:51)
    16. note, we are not doing formal scrums. We're just using these tools. (dconde, 20:49:28)
    17. alagalah sharing desktop (dconde, 20:51:44)
    18. we are showing the renderer whiteboard diagram. (dconde, 20:52:11)
    19. when regXboi is happy, life is good (tbachman, 20:52:50)

  6. YANG review - Rob Adams (and our first commit) (alagalah, 20:53:02)
    1. a yang model has rough approx of policy model (dconde, 20:53:28)
    2. changed some model elements in clause/object area. (dconde, 20:53:56)
    3. added cross tenant contracts (dconde, 20:54:07)
    4. policy model is separate from end point repo (dconde, 20:54:22)
    5. they generate code. less horrific java code. and got it to a local minima of horribleness (dconde, 20:54:51)
    6. toaster example does not work yet. (dconde, 20:55:15)
    7. in theory, all of this (i.e REST calls) should work, but who knows why it does not work today. (dconde, 20:55:51)
    8. jmedved asks "did you try archetype? (dconde, 20:56:04)
    9. stock ODL is run by readams. and they do not work (dconde, 20:56:16)
    10. there is another example that may be better suited. (dconde, 20:56:36)
    11. some people are supposed to be fixing it. like people from brocade. (dconde, 20:57:30)
    12. jmedved not sure if those changes were merged yet. may be in gerrit (dconde, 20:58:26)
    13. ACTION: readams says that the YANG model is not working, but also the "Toaster" example doesn't work. jmedved says it should work, so asked readams to email alias. jmedved to link archetype as well. Email alias controller-dev@ and discuss@ (alagalah, 20:58:51)
    14. https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:MD-SAL-Simple_Archetype (jmedved, 20:59:05)
    15. jmedved is cpoying to IRC on some other ideas. (dconde, 20:59:09)
    16. it does provide skeletons for provider and consumer. (dconde, 20:59:57)
    17. readams just wants config to work. jmedved says you need a provider. (dconde, 21:00:09)
    18. regxboi leaving. (dconde, 21:00:23)
    19. harman singh is working on that (dconde, 21:00:48)
    20. jmedved thinks harman singh does not come to IRC. (dconde, 21:02:44)
    21. harmasin@cisco.com is a contact for readams to contact for YANG Toaster etc (alagalah, 21:03:15)
    22. jmedved says toaster may be out of his hands, but with archetype can be something he can assist on (dconde, 21:03:35)

  7. JSON generation from Use Case - Keith (due for ARCH/MODEL sub-group) (alagalah, 21:04:52)
    1. whiteboard session for use-cases (dconde, 21:05:15)
    2. looking at screen share now. (dconde, 21:05:24)
    3. dvorkinista laid out a use case and diagram. (dconde, 21:05:44)
    4. he went through qualities, conditions, etc. and a related YANG model (dconde, 21:06:38)
    5. with right tags, etc. (dconde, 21:06:47)
    6. so write up the example in the policy model. it has all the right objects. (dconde, 21:07:12)
    7. ACTION: if you need clarification on the model alagalah described, please spek up. (dconde, 21:08:37)
    8. ACTION: Keith to write up detailed 3-tier example with contracts, break that down through the yang model, create JSON input (mickey_spiegel, 21:08:47)


Meeting ended at 21:10:49 UTC (full logs).

Action items

  1. regxboi to figure out how to do the + votes
  2. Q was raised "What happens when there is a -2?" Does the merge not happen until it is removed, even if there is a +2? regXboi
  3. to validate
  4. regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:00 Pac recurring (1hr)
  5. 13:00 struck down.... regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:30 Pac recurring (1hr)
  6. re: regXboi action item on gerrit review vote of -2... -2 blocks merge until removed.
  7. plan of record is agreed upon
  8. Each developer/contributor to review tabs and self assign themselves to a sub-project that they would like to work on
  9. please a question mark on column A if you are not sure which subgroup you can work on, if you do know, please that in column a
  10. will people #info their names and ID into the IRC so we can set up Trello accounts.
  11. readams says that the YANG model is not working, but also the "Toaster" example doesn't work. jmedved says it should work, so asked readams to email alias. jmedved to link archetype as well. Email alias controller-dev@ and discuss@
  12. if you need clarification on the model alagalah described, please spek up.
  13. Keith to write up detailed 3-tier example with contracts, break that down through the yang model, create JSON input


Action items, by person

  1. alagalah
    1. regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:00 Pac recurring (1hr)
    2. 13:00 struck down.... regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:30 Pac recurring (1hr)
    3. if you need clarification on the model alagalah described, please spek up.
  2. jmedved
    1. readams says that the YANG model is not working, but also the "Toaster" example doesn't work. jmedved says it should work, so asked readams to email alias. jmedved to link archetype as well. Email alias controller-dev@ and discuss@
  3. regXboi
    1. regxboi to figure out how to do the + votes
    2. Q was raised "What happens when there is a -2?" Does the merge not happen until it is removed, even if there is a +2? regXboi
    3. re: regXboi action item on gerrit review vote of -2... -2 blocks merge until removed.
  4. UNASSIGNED
    1. to validate
    2. plan of record is agreed upon
    3. Each developer/contributor to review tabs and self assign themselves to a sub-project that they would like to work on
    4. please a question mark on column A if you are not sure which subgroup you can work on, if you do know, please that in column a
    5. will people #info their names and ID into the IRC so we can set up Trello accounts.
    6. Keith to write up detailed 3-tier example with contracts, break that down through the yang model, create JSON input


People present (lines said)

  1. dconde (68)
  2. alagalah (26)
  3. tbachman (6)
  4. jmedved (4)
  5. regXboi (4)
  6. odl_meetbot (4)
  7. mickey_spiegel (2)
  8. s3wong (2)
  9. rexpugh-HP (1)


Generated by MeetBot 0.1.4.