#opendaylight-group-policy: model subgroup

Meeting started by regXboi at 17:05:23 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:MODEL#Team_Meeting (alagalah_, 17:05:56)

  1. white board diagram of 3-tier to JSON (tbachman, 17:06:22)
    1. alagalah created JSON of 3-tier model (tbachman, 17:07:29)
    2. Regarding action of 3 tier app softcopy and JSON generation find information here: (alagalah, 17:07:48)
    3. ACTION: https://drive.google.com/folderview?id=0BztNICcppsJKY0tMRl8tVlBQN2s&usp=sharing (alagalah, 17:07:53)
    4. work in progressw (alagalah, 17:08:24)

  2. Create power point of 3-tier (tbachman, 17:08:38)
    1. work in progress -- task takes time (tbachman, 17:08:50)
    2. action from last meeting: alagalah to instead of writing whitepaper or annotating the UML to write a PPT with animations that describes the UML model with annotations. (alagalah, 17:08:55)
    3. WIP : blocked on time (alagalah, 17:09:01)
    4. Action: dvorkinista to restruct model in structure, definition use - has not had time. (alagalah, 17:09:24)
    5. no update, Mike at OS summit (alagalah, 17:09:31)
    6. Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc (alagalah, 17:09:44)

  3. Action Items (though look to other topics on resolution -- didn't get topics right at first) (tbachman, 17:10:16)
    1. ACTION: alagalah to schedule meeting with edwarnicke and regxboi (possibly ChrisPrice) to discuss Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc (alagalah, 17:10:35)
    2. Action: alagalah meeting with Uyen, Rex, Dave Lenrow, regXboi to discuss Use-Case -> UML -> JSON "conversion" ... 14:30 Pac Fri May9 (alagalah, 17:11:29)
    3. meetings have been ongoing -- Unified communications use case with proactive flows. Team has been working on mapping use case to the model (tbachman, 17:12:10)
    4. Microsoft Lync uses many ports, so the question has been of how to provide information for classifier so that renderer can install flows between session peers. (tbachman, 17:13:21)
    5. plan is to manage call setup of 200+ per second (tbachman, 17:16:27)
    6. readams says that changing the config dynamically is not the way to do this (tbachman, 17:16:56)
    7. classifier represents dynamic concept, such as lookup in database (i.e. look up of metadata) (tbachman, 17:17:22)
    8. readams recommends move lookup of 5-tuple to different store, which better supports the applications needs (tbachman, 17:21:04)
    9. readams says operational data doesn't belong in the policy, which is a configuration store (tbachman, 17:23:59)
    10. mickey_spiegel notes that we're maybe talking about two APIs here. (tbachman, 17:28:32)
    11. readams asks if there is an orchestration system for the UC&C application to orchestrate this (tbachman, 17:29:10)
    12. uchau says there's an application on the controller (idea is based on ONF use case) (tbachman, 17:29:26)
    13. user app is integrated with UC&C system, network app that is part of the contoller, and is policy based system (tbachman, 17:29:54)
    14. readams says that GBP does not make sense as a generic midlleware layer (tbachman, 17:32:09)
    15. GBP model is different from the way normal network management is done. (tbachman, 17:33:24)
    16. mickey_spiegel notes asks for definition of what uchau means by policy (tbachman, 17:35:00)
    17. losing audio (tbachman, 17:35:31)
    18. regXboi is concerned about narrow definition of what GBP is trying to provide (e.g. SFC) (tbachman, 17:36:49)
    19. if there are orchestration systems NB with a different definition of policy model, he doesn't want us to say "oh we can't talk to you" (tbachman, 17:37:23)
    20. readams notes that if the model is based on fundamentally different principles, this might not make sense. (tbachman, 17:37:50)
    21. regXboi notes that this has to work with other orchestration systems (cough cough *openstack* cough cough) (tbachman, 17:38:49)
    22. readams asserts that in cases where user sees endpoints and communication between these groups of endpoints, then GBP works well (tbachman, 17:40:41)
    23. uchau says that there are users who want to establish link calls (tbachman, 17:43:03)
    24. losing audio (tbachman, 17:43:34)
    25. there are two broad categories of data: operational state data and configuration data (tbachman, 17:53:03)
    26. for example, a new session could be considered operational state data (tbachman, 17:53:17)
    27. the policy needed by a session is considered configuration data (tbachman, 17:53:35)
    28. define a classifier that is "link communication", as "anything that is communication on an active link session" (tbachman, 17:54:05)
    29. semantics around operational and configuration state data are different (tbachman, 17:55:47)
    30. persistence, transactionality, referential integrity (tbachman, 17:55:58)
    31. This affects how we represent this data (tbachman, 17:56:16)
    32. question of can we change actions, classifiers, or tenants in a dynamic fashion? (tbachman, 17:57:14)
    33. it's 11am PST (tbachman, 18:00:17)


Meeting ended at 18:06:15 UTC (full logs).

Action items

  1. https://drive.google.com/folderview?id=0BztNICcppsJKY0tMRl8tVlBQN2s&usp=sharing
  2. alagalah to schedule meeting with edwarnicke and regxboi (possibly ChrisPrice) to discuss Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc


Action items, by person

  1. alagalah
    1. alagalah to schedule meeting with edwarnicke and regxboi (possibly ChrisPrice) to discuss Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc
  2. regXboi
    1. alagalah to schedule meeting with edwarnicke and regxboi (possibly ChrisPrice) to discuss Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc


People present (lines said)

  1. tbachman (46)
  2. regXboi (11)
  3. alagalah (11)
  4. odl_meetbot (8)
  5. uchau (2)
  6. alagalah_ (1)
  7. readams (0)


Generated by MeetBot 0.1.4.