#opendaylight-group-policy: ODL-GBP-MODEL

Meeting started by dconde at 17:08:10 UTC (full logs).

Meeting summary

  1. service_insertion (dconde, 17:08:34)
    1. we need to determine whether GBP does the plumbing for other service insertion projects (dconde, 17:09:29)
    2. readams says a pair of EP talking via a FW -- but we are restricted from dealing with this in a pairwise fashion. (dconde, 17:10:16)
    3. ways to reason about it. (dconde, 17:11:34)
    4. dvorkin says - group provides a contract … (he's drawing on board) then another group consumes a contract. (dconde, 17:11:52)
    5. within this grop, there is a subject to the conversation., let's say it's for HTTP for sake of argument (dconde, 17:12:11)
    6. action is specified to redirect to a service GRAPH (dconde, 17:12:22)
    7. let's actually call it a chain. (dconde, 17:12:31)
    8. there's an entry point an an out. and we stick devicess iside. for service functions. we may have direct return too. (dconde, 17:13:05)
    9. expressed from consumer's POV, we enter the service and we pop-out. It's VERY easy, right? (dconde, 17:13:28)
    10. but now, for the details. (dconde, 17:13:36)
    11. what if we try to do the following: (dconde, 17:13:46)
    12. we have two VIPs in LB (dconde, 17:14:05)
    13. we have two poolls. grp 1 belongs to pool1, grp 2 belongs to pool 2 (dconde, 17:14:37)
    14. it's no longer a chain, it's a GRAPH. (dconde, 17:14:57)
    15. so new semantics. (dconde, 17:15:02)
    16. if we have a WAF betwen pool 2 and grp 2 (dconde, 17:15:41)
    17. if WAF a member of EPG or something else. (dconde, 17:15:51)
    18. as dlenrow said we treat service function as a group (dconde, 17:16:24)
    19. so we are drawing group graph view (dconde, 17:17:11)
    20. do we don't wnt to get stuff confused with application intent. (dconde, 17:17:57)
    21. do we treat them as regular rules to redirect? (dconde, 17:20:22)
    22. probably need to treat tranparent functions differently from non-transparent (dlenrow, 17:21:46)
    23. we want these to be auto provisioned too. (dconde, 17:23:27)
    24. are we a plumber or what? (dconde, 17:23:31)
    25. mickey_spiegel says no everything is transparent. (dconde, 17:34:09)
    26. https://blueprints.launchpad.net/neutron/+spec/adv-services-in-vms (dconde, 17:40:45)
    27. AGREED: we need to bring in others who are more familiar with the services world (Quinn) (dconde, 17:46:38)
    28. we are talking about http://tools.ietf.org/html/draft-quinn-sfc-arch-04 (dconde, 17:48:14)


Meeting ended at 17:53:09 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dconde (35)
  2. mickey_spiegel (4)
  3. odl_meetbot (4)
  4. tbachman (3)
  5. dlenrow (1)
  6. alagalah_ (0)


Generated by MeetBot 0.1.4.