#opendaylight-group-policy: ODL-GBP-REQUIREMENTS

Meeting started by dconde at 20:01:00 UTC (full logs).

Meeting summary

    1. https://meetings.webex.com/collabs/#/meetings/detail?uuid=M4NPPO6UULL1B0DFPK2HQ9VZX8-9VIB&rnd=563175.79385 (lenrow, 20:02:03)

  1. goals (dconde, 20:07:50)
    1. new invitation sent from Mike with WebEx (dconde, 20:10:06)
    2. email came from dvorkinista (dconde, 20:10:19)
    3. want scale and perf requirements (dconde, 20:10:50)
    4. need three requirements that lenrow is showing (dconde, 20:12:12)
    5. 1. how powerful the model is? 2. rate of change and 3. expose declarative intent NBI to expose traffic sterring and redirection (dconde, 20:13:34)
    6. chrispriceab wants to avoid duality. (dconde, 20:15:13)
    7. dvokiinista wants to avoid duplicating what is in affinity group and other projects (dconde, 20:16:24)
    8. dvorkinista it can be rendered to affinity groups is needed (dconde, 20:17:07)
    9. lenrow agrees. given he write original proposal for affinity project (dconde, 20:18:00)
    10. dvorkinista shall we combine with affinity project? (dconde, 20:18:42)
    11. lenrow says affinity does not have activity (dconde, 20:19:40)
    12. chrisprice has concerns the if existing declarative API in ODL is not good enough if GBP there to fix it? (dconde, 20:23:35)
    13. point 4. (dconde, 20:25:12)
    14. dvorkinista wants transportable policy at a high level w/ operational policy that is enforced (dconde, 20:25:40)
    15. dconde asked about alignment w/ Neutron (dconde, 20:27:36)
    16. we want to create a general declarative model. (dconde, 20:27:59)
    17. lenrow says putting ikeeping network state in black box is better (dconde, 20:28:52)
    18. not on call but if you are talking about general declarative model, are you looking more at Congress? (regXboi, 20:28:57)
    19. dvorkinista says neutron mixes some concepts. (dconde, 20:29:27)
    20. alagalah says if we talking about steering, that's OK, but computation is different. (dconde, 20:31:58)
    21. then it's about Congress (dconde, 20:32:05)
    22. VMware says Congress is governance not orchestration (Heat) (dconde, 20:32:48)
    23. says dvorkinista (dconde, 20:32:57)

  2. questions to answer (dconde, 20:33:29)
    1. seeing lenrow 's next slide (dconde, 20:33:43)
    2. I presume so. It's lenrow who has it (dconde, 20:34:36)
    3. who is the audience for GBP? (dconde, 20:35:07)
    4. dvorkinista intent, governance and operational are three separate things. to be reasoned differently. (dconde, 20:35:34)
    5. dvorkinista says policies were defined without identifiers. EP's enable items to be attached to it. (dconde, 20:37:35)
    6. the group is persistent (dconde, 20:38:23)
    7. dvorkinista policies are meant to be devoid of identifiers. (dconde, 20:38:42)
    8. dvorkinista explained function of the end point registry. (dconde, 20:41:33)
    9. lenrow then direct vs. indirect approach may not be relevant as shown in slide #5. (dconde, 20:42:16)
    10. lenrow tallks about federation of controller. dvorkinista wants to solve it, but it's difficult. (dconde, 20:42:39)
    11. dvorkinista says unlikely to be in first cut (dconde, 20:42:53)

  3. other items to discuss (dconde, 20:43:21)
    1. prove policies for regulatiotory compliance? asks lenrow re: financial customers. (dconde, 20:43:59)
    2. dvorkinista that's tracability of rendering. (dconde, 20:44:42)
    3. dvorkinista that's not enough. people from Univ of Illinois are looking at that. wish we can do that but that's beyond scope. (dconde, 20:45:19)
    4. dvorkinista says it's a big deal, but worried "if you step wide, then your pants will run" (dconde, 20:46:10)
    5. we can do some user-side valdation of use cases (dconde, 20:48:31)
    6. dconde says we can have some canonical use casss we can show to customers. (dconde, 20:48:45)
    7. sanjay making comments on analytics and provability. (dconde, 20:49:26)
    8. it will items on reachability, routing, etc. that are beyond policy (dconde, 20:50:03)
    9. dvorkinista once we get into L4-L7 it beomes very complex. (dconde, 20:50:35)
    10. lenrow it would be great to get those validated from the "buy" side - as opposed to vendors (dconde, 20:51:13)
    11. sanjay agrawal says that it could be done here (the analytics part) but not the probing part. (dconde, 20:51:45)
    12. stuff like these EPs' will never talk to each other. That cab be analyzed. (dconde, 20:52:07)
    13. dvorkinista says there can be many more use cases wehre it will be useful, beyond GBP. (dconde, 20:52:40)

  4. audience slide (dconde, 20:54:41)
  5. methodology (dconde, 20:54:51)
    1. proposal 5 use cases (dconde, 20:54:58)
    2. of 5 use cases, 3 chosen by ONF (dconde, 20:55:58)
    3. multi-tier, NetVirt, DDOS traffic steerign are the three (dconde, 20:56:39)
    4. next two are UC&C and IETF SFC (dconde, 20:56:52)
    5. dconde asks itns NETVIRT a huge, broad topic? (dconde, 20:58:44)
    6. lenrow says netvirt of connectivity is simple. when you layer on SLA, QOS, ACL then it's policy (dconde, 20:59:23)
    7. dvorkinista and others saying we ought to drill down into what Netvirt means. (dconde, 21:01:05)
    8. dconde says if we choose a more concrete subset, it's OK. (dconde, 21:01:22)
    9. dvorkinista says lets put some bullet points under net virt (dconde, 21:01:52)
    10. sanjay wants to add global enterprise app access as a use case (dconde, 21:02:53)
    11. sanjay is taling about enteprise access control (dconde, 21:03:49)
    12. users come based on location, net posture, etc. (regXboi, 21:04:05)
    13. talking of more WAN use cases. lenrow says maybe chrisprice can add those? (dconde, 21:04:34)
    14. sanjay says enterprise WAN, but Chris may want service provider use cases too. (dconde, 21:05:00)
    15. chrisprice says let's look at enterprise first before doing service provider (100's of millions) (dconde, 21:06:25)
    16. AGREED: that we ought to do enterprise first as priority (dconde, 21:06:36)
    17. dconde asked about regXboi 's question on SFC (dconde, 21:08:08)
    18. multi tier IAAS is similar to ONF (dconde, 21:08:34)
    19. based on dvorkinista and Micorosft use cases. dvorkinista also talks of media companies' use cases tehre for IaaS (dconde, 21:08:57)
    20. multi-tier has snapshot/coine (dconde, 21:09:20)
    21. dconde asks about how we prioritize them? (dconde, 21:10:53)
    22. lenrow says ONF had done some prioritization already to avoid too much analysis paralysis. (dconde, 21:11:16)
    23. we ask whether these 5 are eough. Sanjay says these 5 covers the enterprise for the time being. (dconde, 21:12:57)
    24. lenrow as long as we describe them well, we are OK, sine UC&C use case is complete. (dconde, 21:13:19)
    25. we can spend a few hours over next two weeks to elaborate on the use-cases (dconde, 21:14:12)
    26. sanjay asks should we start with the description, rather than PPT? (dconde, 21:14:32)
    27. lenrow is open to methodology. (dconde, 21:15:07)
    28. dvorkinista says let's not create bureaucracy for sake of it. (dconde, 21:15:29)
    29. mickey_spiegel can we let people do doc ahead of time and meet to go over? (dconde, 21:15:59)
    30. lenrow concerned we will add tons of use cases in call. (dconde, 21:16:20)
    31. lenrow is willing to contribute some of thee use cases that have been examined for a long time. (dconde, 21:17:07)
    32. dvorkinista expected format? (dconde, 21:17:26)
    33. lenrow will do a sample based on ONF use-case doc. (dconde, 21:17:46)
    34. lenrow will make sure ONF doc is public (vs. private ) (dconde, 21:18:17)
    35. ACTION: lenrow will check if ONF use cases can be shared (dconde, 21:18:29)
    36. uchau1 are we describing it in terms of precise GBP starting points, or? (dconde, 21:21:34)
    37. dvorkinista let's descrbie the principles and then how it can be mapped into GBP. Quantitative /Qualittative requirements. (dconde, 21:22:01)
    38. so use first order principlles first. says dvorkinista (dconde, 21:22:24)
    39. dvorkinista next time let's do the UC&C (dconde, 21:25:58)
    40. if UC&C is done, let's try others as examples. but uchau1 asks about where we look at mapping into GBP from model standpoint (dconde, 21:27:46)
    41. uchau1 says diagram is enough, not JSON or YANG (dconde, 21:29:47)
    42. AGREED: next time we step through UC&C and see if requierements are at correct level (dconde, 21:31:19)
    43. not sure we can do that in two hours. (dconde, 21:31:42)


Meeting ended at 21:33:22 UTC (full logs).

Action items

  1. lenrow will check if ONF use cases can be shared


Action items, by person

  1. lenrow
    1. lenrow will check if ONF use cases can be shared


People present (lines said)

  1. dconde (113)
  2. regXboi (15)
  3. lenrow (4)
  4. odl_meetbot (4)
  5. s3wong (2)
  6. Bhushan_ (1)


Generated by MeetBot 0.1.4.