#opendaylight-group-policy: ODL-GBP-STATUS

Meeting started by dconde at 20:17:14 UTC (full logs).

Meeting summary

    1. revisit the goals and look at use cases (dconde, 20:17:50)
    2. we need to create a subgroup that focuses on requirements and use cases (dconde, 20:18:18)
    3. that will add displine and structure to the project. (dconde, 20:18:33)
    4. bhushan will help lead (dconde, 20:19:28)
    5. lenrow wants to join. (dconde, 20:19:52)
    6. lenrow wants to add an ease-of-use leader too. (dconde, 20:20:08)
    7. sanjay wants to participate too. (dconde, 20:20:25)
    8. adding uchau to that group (dconde, 20:20:51)
    9. we also need to have reprsentative from each party involved. (dconde, 20:21:12)
    10. from some people it's L4-7, for others it is switching, so let's make sure it's tangible and implementable (dconde, 20:21:32)
    11. kiran yedavilli wants to join (dconde, 20:22:31)
    12. mspegel asks the diff between the new group and the model group (dconde, 20:22:46)
    13. requirements are to be kept different from implementation (dconde, 20:22:56)
    14. the new group will review and approve with the model. (dconde, 20:23:07)
    15. we will call this group "REQUIREMENTS" group (dconde, 20:23:32)
    16. lenrow says this will avoid mistakes that may have happened in vairous ODL Groups. (dconde, 20:24:04)
    17. dvorkinista says we need to crystallize these concepts and for usability. (dconde, 20:24:21)
    18. dvorkini_ says that even though we have code written, but we will course correct. (dconde, 20:24:44)
    19. lenrow says we need to move quickly since we don't want to stop, so we need to get use cases for solution space. (dconde, 20:25:14)
    20. dvorkini_ says we want separate of this from other projects. like affinity services different purposes (dconde, 20:25:48)
    21. add prasadv into this group. (dconde, 20:26:09)
    22. please add me to the group (mspiegel, 20:26:33)
    23. we will need to figure out if we need to augment model or put into a different activity if we cannot agree into fitting into this model. (dconde, 20:26:49)
    24. we need to keep our mind open on this. (dconde, 20:27:04)
    25. this will be good to figure out what works in helium or can be done later as something we can evolve. (dconde, 20:27:28)
    26. we will look at extensibility than structural changes. That would lead to potpourri of APIs. (dconde, 20:27:56)
    27. it would be good to add security, multi-tenancy and such into the architecture group. (dconde, 20:28:28)
    28. but can involve other parts of the ODL group. (dconde, 20:28:37)
    29. dconde willl join this group too (dconde, 20:28:47)
    30. everyone's opinions are welcome in the requirements group (dconde, 20:28:57)
    31. lenrow says that this can map into work in the ONF NBI group too. (dconde, 20:29:13)
    32. that has its declarative intents (dconde, 20:29:22)
    33. mscohen is joining REQUIREMENTS Group (dconde, 20:29:38)
    34. lenrow -- let effort follow interest. for a declarative intent API and rendering behind it. (dconde, 20:30:10)
    35. dvorkini_ if you ask any party here, they will probably agree. (dconde, 20:30:28)
    36. lenrow prioritizing by committee may be difficult. (dconde, 20:30:43)
    37. dvorkini_ wants to see us be open minded -- we need to address needs for each company as well who we work for. (dconde, 20:31:07)
    38. tbachman will join the REQUIREMENTS Group (tbachman, 20:31:14)
    39. lets add items needed and then go into cleanup mode. We're all engineers and we can over engineer, so we need to take things out when necessary. (dconde, 20:31:57)
    40. things can get added for philosophical reasons, not because it's needed. IF we do all that, we can kick-ass (dconde, 20:32:24)
    41. everyone needs to be on ODL GBP mailing list, read wiki. if you need access, ask alagalah, lenrow or dconde (dconde, 20:33:19)
    42. we don't want this group to be as big as the STATUS group so let us be focused too. (dconde, 20:33:40)
    43. alagalah asks lenrow for use cases (dconde, 20:33:47)
    44. we need to pick a time that works. and who are the members. (dconde, 20:33:58)
    45. we will collect compile use cases and move forward. everyone is responsibilie for adding use cases, or if you are not a member, you can contact a team member and do it in a democrative way. (dconde, 20:34:31)
    46. lenrow says it's great to be inclusive. but we got here by getting stuck in requirements in a few use cases in a smaller group which talked about Unified Comm use case (dconde, 20:35:15)
    47. should we look at high speed/dynamic use cases as part of the workflow. and put tha tinto the intent API? (dconde, 20:35:35)
    48. dvorkini_ says we can try. We are limited by rules of physics. so let's try. (dconde, 20:35:56)
    49. lenrow - if we put in performance requirements, we will be explicit. (dconde, 20:36:16)
    50. lenrow says we can have a "naive" people timer and see if we can explain to them in 5 minutes (dconde, 20:37:51)
    51. just kidding -- (dconde, 20:38:07)
    52. mspiegel says that we will have to explain in phases. (dconde, 20:38:22)
    53. enterprise people care about some items and we need set of examples. (dconde, 20:39:09)
    54. readams tried to do that, but we need to have others. (dconde, 20:39:34)
    55. dconde says we need to add in true customer requirements -- avoid hypothesizing (dconde, 20:40:18)
    56. dvorkini_ says we need to separate areas: Data center vs. enterprise security vs. other needs (dconde, 20:40:42)
    57. dcone says we need a categories or taxonomy. (dconde, 20:41:24)
    58. we need to set up a time. (dconde, 20:41:31)
    59. we can take over end point registry time -- 9 am Monday PAcific (dconde, 20:41:56)
    60. does not collide with lunch for East Coasters? (dconde, 20:42:14)
    61. we can work it out. (dconde, 20:42:29)
    62. alagalah says 8 am Monday is OpenFlow call. (dconde, 20:42:45)
    63. alagalah says that meeting is 60 min (dconde, 20:43:01)
    64. dvorkoni_ says 9 am Tue? (dconde, 20:43:17)
    65. is Monday 1 pm PAcific OK? (dconde, 20:43:39)
    66. Monday 1 pm Pacific chosen (dconde, 20:43:56)
    67. if we cannot get requirements by November we are screwed. So let's use 1 pm PACIFIC and be DONE by November. (dconde, 20:45:39)
    68. so we can meet more frequently if needed. Until then, send email or use Wiki (dconde, 20:46:17)
    69. lenrow says 13:00 Pacific (dconde, 20:46:27)
    70. If you use case is in the GBP google doc or in the ONF A&F or NBI use cases please don't feel the need to send it in (lenrow, 20:46:35)
    71. we can meet next Tuesday (dconde, 20:46:45)
    72. ACTION: dconde will compile list of members. (dconde, 20:47:08)
    73. I will participate in the Mon 1300 call (Bhushan, 20:47:09)
    74. alagalah birthday today (dconde, 20:47:45)
    75. AGREED: 1 pm Pacific (dconde, 20:48:11)
    76. happy birthday @alagalah! (dvorkini_, 20:48:20)
    77. ACTION: Alagalah will set up a WebEx (dconde, 20:48:34)
    78. tbachman hands alagalah a birthday scotch (tbachman, 20:48:46)
    79. ghangout limitation is a problem, so we need to go to WebEx. (dconde, 20:49:09)
    80. so let's make sure we have ONE webEx link next time. (dconde, 20:50:02)
    81. all done! (dconde, 20:50:09)


Meeting ended at 20:50:15 UTC (full logs).

Action items

  1. dconde will compile list of members.
  2. Alagalah will set up a WebEx


Action items, by person

  1. alagalah
    1. Alagalah will set up a WebEx
  2. dconde
    1. dconde will compile list of members.


People present (lines said)

  1. dconde (83)
  2. Kiran (8)
  3. tbachman (4)
  4. odl_meetbot (4)
  5. python27 (3)
  6. mscohen (2)
  7. Bhushan (2)
  8. lenrow (1)
  9. dvorkini_ (1)
  10. uchau (1)
  11. banix (1)
  12. mspiegel (1)
  13. s3wong (1)
  14. alagalah (0)


Generated by MeetBot 0.1.4.