#opendaylight-group-policy: ODL STATUS

Meeting started by alagalah_ at 20:01:19 UTC (full logs).

Meeting summary

  1. mickey_spiegel having issues with POC (alagalah_, 20:04:55)
    1. on host2, as contracts are supposed to be entered he is not seeing the python output of contracts. (alagalah_, 20:05:18)
    2. REST http://{{controllerIp}}:{{port}}/restconf/config/policy:tenants (alagalah_, 20:07:43)
    3. http://{{controllerIp}}:{{port}}/restconf/operational/endpoint:endpoints (tbachman, 20:14:11)

  2. karaf update (tbachman, 20:16:00)
  3. Karaf and package update (alagalah_, 20:16:02)
    1. groupbasedpolicy project is in karaf, and will be part of Helium (tbachman, 20:18:33)
    2. The RC1 date is now the “code freeze” date (tbachman, 20:21:11)
    3. projects that aren’t part of the integration karaf build and code frozen by RC1 will be dropped from the Helium release (tbachman, 20:21:45)
    4. There is an outstanding bug in groupbasedpolicy that is preventing the demo from working (tbachman, 20:22:02)
    5. alagalah_ and tbachman are debugging (tbachman, 20:22:08)
    6. From a documentation perspective, we need to understand what the Helium release/integration documentation folks are doing (tbachman, 20:22:33)
    7. we’ll provide instructions on how to load and run the groupbasedpolicy feature (tbachman, 20:22:48)
    8. ACTION: Keith and Thomas to have fix done by next STATUS meeting with BugID (alagalah_, 20:23:25)
    9. ACTION: or at a minimum, identify who is responsible if not fixable within GBP (alagalah_, 20:23:42)
    10. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_RC0 <- instructions on how to test (tbachman, 20:26:20)
    11. the groupbasedpolicy feature is odl-groupbasedpolicy-ofoverlay (tbachman, 20:27:34)
    12. The command to load the groupbasedpolicy feature would be feature:install odl-groupbasedpolicy-ofoverlay odl-restconf (tbachman, 20:28:10)

  4. Roadmap brainstorming (alagalah_, 20:30:29)
    1. https://wiki.opendaylight.org/view/Group_Policy:Main#Other_Documents (alagalah_, 20:30:34)
    2. https://docs.google.com/document/d/1qEpcN-Iftw5LBM_9i716Q4w3qi4tPWZq5lMO45sE1Ok/edit?usp=sharing (alagalah_, 20:30:49)

  5. Docs (alagalah_, 20:31:39)
    1. tbachman asks mickey_spiegel: What do we need? Where are the gaps? (alagalah_, 20:31:53)
    2. mickey_spiegel says we need to convert our wiki stuff to ascii doc (tbachman, 20:32:12)
    3. ACTION: mickey_spiegel (docs) will pull content from wiki and format as ASCII docs (alagalah_, 20:32:17)
    4. mickey_spiegel needs POC working to pull data (alagalah_, 20:32:32)
    5. mickey_spiegel notes that since docs don’t go in the groupbasedpolicy project, but in the larger distribution, we need to understand what to do there (tbachman, 20:33:35)
    6. mickey_spiegel wasn’t sure how to make the preview work with the ASCII docs stuff (tbachman, 20:34:17)
    7. mickey_spiegel asks if we can move next week’s status meeting b/c of the congress policy meeting (tbachman, 20:35:23)
    8. alagalah_ says we’ll do status over the email list for next week (tbachman, 20:35:42)


Meeting ended at 20:37:40 UTC (full logs).

Action items

  1. Keith and Thomas to have fix done by next STATUS meeting with BugID
  2. or at a minimum, identify who is responsible if not fixable within GBP
  3. mickey_spiegel (docs) will pull content from wiki and format as ASCII docs


People present (lines said)

  1. tbachman (22)
  2. alagalah_ (15)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.