#opendaylight-group-policy: policy status

Meeting started by regXboi at 20:08:18 UTC (full logs).

Meeting summary

  1. requirements (regXboi, 20:08:29)
    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:REQUIREMENTS#Requirements_Sub-Group (regXboi, 20:08:40)
    2. requirements meeting to be set up (regXboi, 20:09:18)
    3. ACTION: dvokinista to set up requirements meetings (regXboi, 20:09:29)
    4. for those joining, the hangout is coming (regXboi, 20:10:43)
    5. https://plus.google.com/hangouts/_/noironetworks.com/odl-gbp-status (regXboi, 20:10:50)

  2. functional spec (regXboi, 20:12:08)
    1. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model (regXboi, 20:13:41)
    2. folks need to read the functional spec and comment, as implementation is under way (tbachman, 20:13:57)
    3. The Architecture page has a link to the Policy Model page (tbachman, 20:14:36)
    4. the main wiki page now has a subpages section (regXboi, 20:17:15)
    5. readams is working on renderer-commons framework (tbachman, 20:19:13)
    6. Trying to get to a point where a renderer can map a parir of endpoints into endpoint groups (tbachman, 20:19:47)
    7. demo-renderer will demonstrate that the basic framework “works" (tbachman, 20:20:55)
    8. likely a simple overlay (regXboi, 20:21:17)
    9. readams says anybody who wants to take a swing at it can feel free (regXboi, 20:22:20)
    10. readams thinks that will be more easily filled in as we understand what the renderers expect (regXboi, 20:22:47)
    11. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2014-May/000193.html <— dlenrow mentioning the renderer group (tbachman, 20:28:29)
    12. regXboi recalls that dvorkinista made a statement that portions of the model are optional (tbachman, 20:30:32)
    13. If that is true, regXboi looked at the current YANG in the repo, but nothing is tagged as a yang feature, which would indicate that it was optiona (tbachman, 20:31:03)
    14. readams notes that entire pieces of the model aren’t necesarrily optional, but that the renderer may not be able to render parts of the model (tbachman, 20:31:32)
    15. which would result in an exception, then having retries (tbachman, 20:31:45)
    16. resulting in parts of the model not being required to fulfil the policy requirement (tbachman, 20:32:14)
    17. dvorkinista says that there are things that require change of placement, and stuff that does not. (tbachman, 20:32:40)
    18. If there are endpoints that can’t be satisified, then the endpoint must be moved somewhere else (tbachman, 20:32:57)
    19. because we can’t move workloads (tbachman, 20:33:06)
    20. We may want the option to have a way of expressing whether the policy has to be “all-or-nothing” (tbachman, 20:35:09)
    21. dvorkinista feels that this can fall on the renderer. The renderer is responsible for achieving the desired state. (tbachman, 20:36:25)
    22. sanjay asks if the renderer architecture been decided on? (regXboi, 20:38:07)
    23. readams says that we’re creating a demo-renderer (tbachman, 20:38:41)
    24. readams says that demo will be based on *something* (regXboi, 20:38:43)
    25. regXboi points out that *something* is a bit nebulous (regXboi, 20:40:32)
    26. and that it should be nailed down by the to-be reconstituted renderer meetings (regXboi, 20:40:52)
    27. AGREED: renderer meetings will be restarted (regXboi, 20:41:03)


Meeting ended at 20:42:31 UTC (full logs).

Action items

  1. dvokinista to set up requirements meetings


People present (lines said)

  1. regXboi (25)
  2. tbachman (18)
  3. odl_meetbot (5)
  4. Youcef (5)
  5. Bhushan_ (2)
  6. dconde (2)
  7. alagalah (0)


Generated by MeetBot 0.1.4.