#opendaylight-group-policy: STATUS

Meeting started by alagalah at 20:04:34 UTC (full logs).

Meeting summary

    1. readams is looking at the karaf packaging (tbachman, 20:04:48)
    2. unfortunately the karaf packaging isn’t working yet — needs help from mlemay (tbachman, 20:05:05)
    3. The basic demo of the OpenFlow Overlay solution is working end-to-end, and is checked in (tbachman, 20:05:32)
    4. https://wiki.opendaylight.org/view/Group_Policy:Building_and_Running Rob's Demo (alagalah, 20:05:57)
    5. more can be done, but we need to figure out how far we want to take it (demo vs. productization) (tbachman, 20:06:01)
    6. tbachman can detach and attach endpoints. Waiting on Genie. Working with Adam Breck on the normalised policy model (alagalah, 20:09:08)
    7. readams gives tutorial on how high level policy is translated to an intermediate stage then down to the actual configuration of the endpoint ie OpenFlow for exaple (alagalah, 20:17:50)
    8. readams says that the eventing for the policy isn’t really well tested. Adam might be able to pick that up, but it’s tricky to test this in a clean way (tbachman, 20:21:09)
    9. readams was hoping to have a mock data store to facilitate this, like a mockito mock of an in-memory data store (tbachman, 20:21:45)
    10. where the mock has hooks for creating specific objects (tbachman, 20:22:06)

  1. documentation (tbachman, 20:26:07)
    1. no news on the docs stuff (tbachman, 20:26:16)
    2. mickey_spiegel asks dlenrow for pointer to GBP for dummies (tbachman, 20:26:31)
    3. dlenrow will be about for next ~10 days, but will see what he can do to contribute (tbachman, 20:26:55)
    4. mickey_spiegel looked at what readams provided on the wiki (tbachman, 20:27:07)
    5. https://www.youtube.com/watch?v=_e9iafRSi8E <= youtube demo of overlay renderer (tbachman, 20:27:58)
    6. https://wiki.opendaylight.org/view/Group_Policy:Building_and_Running <= provides instructions for running the overlay renderer demo (tbachman, 20:28:26)
    7. still waiting on a patch that allows the overlay renderer demo to run correctly (tbachman, 20:28:48)
    8. sanjay says he can help mickey_spiegel with the use case documentation (tbachman, 20:30:07)
    9. mickey_spiegel says that for the use cases we should have actual model content (tbachman, 20:30:16)
    10. readams notes that the scripts that are checked in for the overlay demo create example policy (tbachman, 20:30:37)
    11. dlenrow notes that since he’s out the next two mondays, the use case meeting can be used for other purposes (tbachman, 20:32:56)
    12. sanjay says he’d like to cover the flow-based use cases on monday’s meeting (tbachman, 20:33:08)
    13. ACTION: sanjay will send out an email for monday’s agenda (tbachman, 20:33:31)
    14. mickey_spiegel says that for Friday’s meeting, he’s put in the link for Paul Quinn’s group work (tbachman, 20:34:46)
    15. sanjay is interested in helping with DNAT (tbachman, 20:37:17)


Meeting ended at 20:38:04 UTC (full logs).

Action items

  1. sanjay will send out an email for monday’s agenda


People present (lines said)

  1. tbachman (25)
  2. alagalah (6)
  3. odl_meetbot (4)


Generated by MeetBot 0.1.4.