#opendaylight-integration: Integration Hack Fest @Brocade

Meeting started by catohornet1 at 16:21:58 UTC (full logs).

Meeting summary

  1. Introductions (catohornet1, 16:24:19)
    1. ACTION: LuisGomez to upload slides to Wiki (CASP3R, 16:33:11)
    2. History of the Integration group (CASP3R, 16:33:23)
    3. Integration strategy - each project handles JUnit and PAX-Exam test (CASP3R, 16:36:31)
    4. Integration group builds the distribution that triggers the CSIT which uses Robot framework. (CASP3R, 16:37:24)
    5. Community lab is the last step of the Integration group to do testing outside of Linux Foundation (CASP3R, 16:38:35)
    6. Tools used by the Integration group - Git/Gerrit, Nexus(Artifface Repo), Jenkins (Distribution Build), Robot (Test Automation), Bugzilla (Bug management), Testopia (Test management) (CASP3R, 16:42:05)
    7. Linux Foundation lab setup, Jenkins, Robot, Controller 1&2, Mininet Slave 1&2 (CASP3R, 16:43:55)
    8. Test work flow, Document test case in Testopia -- Write automation via Robot -- test locally -- upload to GIT repo (CASP3R, 16:47:24)
    9. Test Repo - Testopia Product = Integration, Test plan = ODL Distribution , Test Case = Feature under test (CASP3R, 16:49:27)
    10. Git project = Integration, Test Suites = test/csit/suites (CASP3R, 16:49:55)
    11. Deliverables for Hydrogen release (CASP3R, 16:51:10)
    12. Deliverables for Helium release (CASP3R, 16:55:50)
    13. M3 - Test Documentation and report in Testopia, OpenFlow 1.3 FlowMod test, OpenFlow 1.3 Performance test and NetConf (CASP3R, 16:56:26)
    14. M5 Neutron Test, Cluster Test, Tenancy Test, Longevity Test (CASP3R, 16:56:58)

  2. Tools (CASP3R, 17:08:49)
    1. GIT/Gerrit for code review (CASP3R, 17:14:31)
    2. Jenkins, Job Events are based on projects Merge (CASP3R, 17:15:00)
    3. checkout updated Integration test workflow (catohornet1, 17:15:09)
    4. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Test_Tools (catohornet1, 17:15:59)
    5. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Test_Tools (CASP3R, 17:16:12)
    6. https://jenkins.opendaylight.org/integration/job/integration-hydrogen-project-centralized-integration (CASP3R, 17:19:51)
    7. https://jenkins.opendaylight.org/integration/job/integration-master-project-centralized-integration (CASP3R, 17:19:55)
    8. Robot The automation engine for our CSIT (CASP3R, 17:21:51)
    9. Robot is keyword driven testing (CASP3R, 17:22:37)
    10. reports are created in the following output .html, .log and .xml (CASP3R, 17:24:28)
    11. Extended natively using Java and Python (CASP3R, 17:25:16)
    12. pybot will execute all .txt file in a test suite directory. (CASP3R, 17:26:58)
    13. Test case format, Setup - configuration detail, and topology used (CASP3R, 17:28:30)
    14. settings Describe the test case and what imported resource to use (CASP3R, 17:28:49)
    15. variables optional, created for the test case (CASP3R, 17:29:25)
    16. info test case - where you write the test cases (CASP3R, 17:29:58)
    17. Teardown - clean run for the next test case run (CASP3R, 17:30:47)

  3. Core project testing - round table (CASP3R, 19:47:51)
    1. Openflow - flowMod (Vendor extension), capabilities learning, Metering, grouping and TLS support (CASP3R, 19:49:21)
    2. switch consistency (when there is a disconnection of switch to controller) (CASP3R, 19:50:40)
    3. Netconf - Netopeer install (CASP3R, 19:53:42)
    4. Netconf - Inventory get-config, push-config, (CASP3R, 19:55:02)
    5. NetApp - Toaster, Ping (CASP3R, 20:04:58)
    6. Performance - Cbench (CASP3R, 20:06:21)
    7. Performance flows/sec, number of flows (flows in data store) (CASP3R, 20:07:26)
    8. Performance Inventory (switches and links) (CASP3R, 20:08:15)
    9. performance RESTApi (number of transcation) (CASP3R, 20:08:58)
    10. BGP - neighbors , topology (CASP3R, 20:10:42)
    11. Neutron - Openstack (2 Compute) (CASP3R, 20:12:58)
    12. neutron (VTN/OVSDB) (CASP3R, 20:13:14)
    13. sonar/jacoco - code converge, api converge (CASP3R, 20:15:48)
    14. testopia - Document update, and Robot plugin (CASP3R, 20:25:47)
    15. Netconf testing: Install Netopeer on Test VM; Test cases: Get conf, Push Conf, Mod Conf, Remote RPC. (catohornet1, 20:27:20)
    16. Sonar/ Jococo: Code coverage, API coverage (catohornet1, 20:29:01)

  4. For tommorow: We'll be working on Documenting, Mediawiki plugins, Code Coverage, OpenFlow --metering / Group, (CPQD), Netopeer install on test vm; Netconf Test cases, Net Apps: Toaster, ping; Performance: Cbench test, inventory swtch, links (catohornet1, 22:07:15)


Meeting ended at 22:07:24 UTC (full logs).

Action items

  1. LuisGomez to upload slides to Wiki


Action items, by person

  1. LuisGomez
    1. LuisGomez to upload slides to Wiki


People present (lines said)

  1. CASP3R (55)
  2. catohornet1 (13)
  3. odl_meetbot (8)
  4. dfarrell07 (5)
  5. Madhusudhan (2)
  6. catohornet (0)
  7. LuisGomez (0)


Generated by MeetBot 0.1.4.