#opendaylight-integration: Weekly Integration meeting

Meeting started by CASP3R at 15:03:55 UTC (full logs).

Meeting summary

  1. project update (CASP3R, 15:04:16)
    1. Luis to check the release plan about M2 (CASP3R, 15:04:59)
    2. service release is waiting on the automation release process. (CASP3R, 15:07:49)
    3. around 17 have sign up for Integration hackfest @ Brocade. (CASP3R, 15:10:54)

  2. Task progress (CASP3R, 15:11:14)
    1. Luis has push the test case re-org for all jenkin/robot jobs. (CASP3R, 15:12:19)
    2. we need to start documenting everything in Testopia. (CASP3R, 15:12:53)
    3. Everyone who has write testcase in the past are asked to write the document for Testopia (CASP3R, 15:13:30)
    4. OF13 plugin is pretty stable now. (CASP3R, 15:15:19)
    5. some test case fail in LF more than in other test labs. (CASP3R, 15:15:38)
    6. Chris has push the OF13 plugin test case. Wiki updated (CASP3R, 15:17:49)
    7. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:FlowMod_Test (CASP3R, 15:18:11)
    8. VTN Coordinator, it now working on mininet slave1, Job should be enabled at this time. (CASP3R, 15:19:16)
    9. ACTION: LuisGomez to setup the 2nd controller by copy the controller job over. (CASP3R, 15:21:42)
    10. CBench testing going well, (CASP3R, 15:22:54)
    11. NetConf testtool has been setup, Carol writing test case for it. (CASP3R, 15:23:59)
    12. ACTION: CASP3R to write some performance test to see if OF plugin is ready for IXIA VM testing (CASP3R, 15:26:58)

  3. TestON analysis (CASP3R, 15:31:50)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:TestON_Framework (CASP3R, 15:33:31)
    2. echo Test case needs 3 files. (CASP3R, 15:33:56)
    3. test case are created in OpenSpeak format (CASP3R, 15:37:47)
    4. test case are created in OpenSpeak format (CASP3R, 15:41:23)
    5. LF setup doesn't allow ssh access using username/password, is this going to be a problem? (CASP3R, 15:42:06)
    6. Right now in LF Jenkins run the controller, Robot (Test framework) doesn't have run the controller, TestOn ODL driver starts the controller. (CASP3R, 15:48:24)
    7. Test framework for OpenDaylight needs to be easy to run, change lots of stuff in script could be very hard if moving between setups. (CASP3R, 15:54:06)
    8. does it use Python 2.6 or 2.7. (CASP3R, 16:01:06)


Meeting ended at 16:05:07 UTC (full logs).

Action items

  1. LuisGomez to setup the 2nd controller by copy the controller job over.
  2. CASP3R to write some performance test to see if OF plugin is ready for IXIA VM testing


Action items, by person

  1. CASP3R
    1. CASP3R to write some performance test to see if OF plugin is ready for IXIA VM testing
  2. LuisGomez
    1. LuisGomez to setup the 2nd controller by copy the controller job over.


People present (lines said)

  1. CASP3R (29)
  2. odl_meetbot (4)
  3. LuisGomez (0)


Generated by MeetBot 0.1.4.