#opendaylight-integration: weekly integration meeting

Meeting started by CASP3R at 16:01:44 UTC (full logs).

Meeting summary

  1. Project update (CASP3R, 16:05:20)
    1. Release plan for next release has been voted on by the TSC (CASP3R, 16:06:11)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan Lithium Release plan (CASP3R, 16:06:39)
    3. M1 we need a test contact for all the project (CASP3R, 16:06:58)
    4. M2 If project wish to be using the CSIT tooling, and which tools needs to be installed (CASP3R, 16:07:54)
    5. project will need to do the request to helpdesk for new tools (CASP3R, 16:09:00)
    6. M3 project to have completed test template (CASP3R, 16:09:41)
    7. M4 project to have simple testing (CASP3R, 16:11:20)
    8. M5 user-facing feature must be completed should be running on code merge. (CASP3R, 16:11:43)
    9. offset 0 is for the base project like controller and yangtool (CASP3R, 16:14:14)
    10. offset 1 is for plugin that other porject will be used like OpenFlow and ovsdb (CASP3R, 16:14:31)
    11. offset 2 is for the rest of the projects (CASP3R, 16:14:45)

  2. task update (CASP3R, 16:18:20)
    1. default devstack driver for Openstack only supports ports, subnets and networks (CASP3R, 16:23:58)
    2. dave tucker's driver supports Router, FWaaS and LBaaS (CASP3R, 16:25:00)
    3. one test suite will test the default driver and the other test suite will support for dave's driver (CASP3R, 16:25:26)
    4. need help to automate spinning up devstack with dave's driver (CASP3R, 16:25:55)
    5. dynamic mounting of the device of netconf, doesn't work in master branch (CASP3R, 16:26:25)
    6. ACTION: LuisGomez to "hack" a job to check that what Andy did for netconf device works (CASP3R, 16:27:46)
    7. https://git.opendaylight.org/gerrit/#/c/12779/ for a template of the jenkin job builder (CASP3R, 16:30:42)
    8. Ekta has a setup for cluster working internal (CASP3R, 16:32:31)
    9. Ekta highlighted that cluster team can be use as a template for other teams to follow (CASP3R, 16:33:41)
    10. we need someone to look into BGP (CASP3R, 16:35:46)
    11. docker work packaging is ready for the TSC, but miss the cut off today (CASP3R, 16:36:58)
    12. work on upgrading wcbench for karaf (CASP3R, 16:37:12)
    13. there is a prototype of the Robot plugin ready for a demo (CASP3R, 16:37:37)
    14. git restructure is planned for next week (CASP3R, 16:39:27)
    15. https://git.opendaylight.org/gerrit/gitweb?p=releng/builder.git;a=tree;f=vagrant/integration-robotframework;h=5b5c662af3a698a9de2bd2e0c49a2ad9f893a229;hb=HEAD Vagrant for Robot framework (CASP3R, 16:43:16)
    16. CASP3R working with Spirent VCT (virtual cloud test) lab to put the performance testing to be run daily (CASP3R, 16:53:54)
    17. will spin the controller up with pinning the JVM to 2,4,8,16 cores and change the java heap size from 2G,4G and 8G (CASP3R, 16:54:41)


Meeting ended at 17:15:22 UTC (full logs).

Action items

  1. LuisGomez to "hack" a job to check that what Andy did for netconf device works


Action items, by person

  1. LuisGomez
    1. LuisGomez to "hack" a job to check that what Andy did for netconf device works


People present (lines said)

  1. CASP3R (40)
  2. odl_meetbot (7)
  3. dfarrell07 (4)
  4. tykeal (1)
  5. LuisGomez (0)


Generated by MeetBot 0.1.4.