#opendaylight-integration: cluster test

Meeting started by LuisGomez at 17:08:28 UTC (full logs).

Meeting summary

  1. action points (LuisGomez, 17:09:46)
    1. action point: clean the car-people test as well as file bugs (LuisGomez, 17:10:26)
    2. need to debug the stable/lithium cluster jobs. external problems in beryllium that are unrelated to clustering (jamoluhrsen, 17:13:56)
    3. bug 4037 is one of the cluster test failures (jamoluhrsen, 17:14:22)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=4037 (jamoluhrsen, 17:14:44)
    5. ssaxena1 has fixed some test issues in the past. still more to look at (jamoluhrsen, 17:19:46)
    6. -all cluster test for beryllium finally starting, but lots of failures. (jamoluhrsen, 17:24:11)
    7. "wait for controller up" is timing out, but it's not marking it as a failure. (jamoluhrsen, 17:27:01)
    8. checking cluster sync status is ok to know if clustering is ready, but doesn't indicate if application is ready for cluster configs. (jamoluhrsen, 17:37:44)
    9. each application needs to have their own way to determine if they are ready for cluster testing to start (jamoluhrsen, 17:39:19)

  2. cluster test plan for projects (LuisGomez, 17:39:53)
    1. LuisGomez has draft of cluster testplan in robot format (jamoluhrsen, 17:41:52)
    2. clustering concept of leader/follower is not coupled with SB concept (e.g. openflow) of master/slave (jamoluhrsen, 17:45:00)
    3. ACTION: need to verify that first controller that a southbound device is connected to will become the master (jamoluhrsen, 17:51:52)
    4. four combinations to test for CRUD (leader/master, leader/slave, follower/master, follower/slave) (jamoluhrsen, 17:52:49)
    5. will talk more cluster testing in thursday integration call (jamoluhrsen, 18:02:17)


Meeting ended at 18:03:03 UTC (full logs).

Action items

  1. need to verify that first controller that a southbound device is connected to will become the master


People present (lines said)

  1. jamoluhrsen (14)
  2. LuisGomez (6)
  3. odl_meetbot (4)
  4. dfarrell07_conf (1)


Generated by MeetBot 0.1.4.