#opendaylight-integration: cluster test

Meeting started by LuisGomez at 17:05:19 UTC (full logs).

Meeting summary

  1. review of action points (LuisGomez, 17:05:32)
  2. clean up car-people (LuisGomez, 17:05:54)
    1. LuisGomez has made some cleanup and changes are merged. (jamoluhrsen, 17:06:09)
    2. cars/people cluster tests now passing in -only- job. test issues resolved and we expect 100% passing. (jamoluhrsen, 17:08:19)
    3. bug 4037 not being seen any more (jamoluhrsen, 17:08:52)
    4. need to add config-pusher checks to controller deploy scripts (jamoluhrsen, 17:27:45)
    5. maybe check for server unhealthy instead of config-pusher (jamoluhrsen, 17:28:03)
    6. ACTION: jamoluhrsen to add server unhealthy check to deploy scripts (jamoluhrsen, 17:28:21)

  3. cluster deploy scripts (LuisGomez, 17:29:05)
    1. cluster config script is needed. (jamoluhrsen, 17:30:53)
    2. test needed to start cluster first and then start features (jamoluhrsen, 17:32:26)
    3. a script local to each controller that will handle setting up cluster configs, starting karaf is one idea. (jamoluhrsen, 17:42:59)
    4. end user only needs to edit karaf features.cfg file and then provide the IPs of the controllers in the cluster. (jamoluhrsen, 17:43:23)
    5. ACTION: ssaxena1 to write a POC script for cluster setup and controller start (jamoluhrsen, 17:46:06)

  4. cluster test plan (LuisGomez, 17:46:45)
    1. ericcson testplan and LuisGomez testplan was shared. need more reviews (jamoluhrsen, 17:47:32)
    2. different node failures (stop controller, kill java process, etc) (jamoluhrsen, 17:49:05)
    3. southbound scenarios should include cases where device only connects to 1, 2 or all (jamoluhrsen, 17:49:30)
    4. isolation keywords are there. we need write test cases that *isolate* as a form of failover (jamoluhrsen, 17:51:37)
    5. ACTION: LuisGomez testplan redo (jamoluhrsen, 17:59:00)
    6. ACTION: LuisGomez will update testplan for car-people test (LuisGomez, 17:59:46)


Meeting ended at 18:00:02 UTC (full logs).

Action items

  1. jamoluhrsen to add server unhealthy check to deploy scripts
  2. ssaxena1 to write a POC script for cluster setup and controller start
  3. LuisGomez testplan redo
  4. LuisGomez will update testplan for car-people test


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to add server unhealthy check to deploy scripts
  2. LuisGomez
    1. LuisGomez testplan redo
    2. LuisGomez will update testplan for car-people test


People present (lines said)

  1. jamoluhrsen (16)
  2. LuisGomez (7)
  3. odl_meetbot (3)
  4. odp-gerritbot (1)


Generated by MeetBot 0.1.4.