#opendaylight-integration: Integration

Meeting started by dfarrell07 at 17:01:45 UTC (full logs).

Meeting summary

    1. Jamo is not here this week, dfarrell07 and Luis to run meeting (dfarrell07, 17:02:11)
    2. Boron Dev Design Forum will be 2/29-3/1 in San Fran (dfarrell07, 17:04:05)
    3. Vratko sent a large update to the Integration/Test/Test Code Guidelines wiki. Others should also make contribs, give feedback. (dfarrell07, 17:04:41)
    4. https://wiki.opendaylight.org/view/Integration/Test/Test_Code_Guidelines Int/Test (Int/*?) code guidelines being refactoring (dfarrell07, 17:04:54)

  1. Int/Dist Updates (dfarrell07, 17:08:32)
    1. zxiiro and dfrarell07 briefly talked about maybe trying to include ODL's systemd .service file in the distribution (dfarrell07, 17:08:38)
    2. https://github.com/opendaylight/integration-packaging/tree/master/rpm/unitfiles Current location of ODL's systemd .service files (dfarrell07, 17:08:44)
    3. distro was broken for a while, errors going to karaf console vs log issue was fixed by a patch from jamo, going to be painful to debug at this point (remove some projects, try to build, try with different set of projects, repeat) (dfarrell07, 17:13:11)

  2. RelEng Updates (dfarrell07, 17:17:35)
    1. Discussion about Jenkins delay, how to speed it up or reduce load (dfarrell07, 17:17:40)
    2. tykeal points out that good smoke tests to run often, then full stuff less frequently, would help a lot (dfarrell07, 17:17:43)
    3. Since there's a lot of overlap between RelEng and Integration/*, both ppl and work, giving RelEng a portion of the Int/* meeting (dfarrell07, 17:17:52)
    4. Thanh has autorelease running as of Monday (dfarrell07, 17:17:59)
    5. https://nexus.opendaylight.org/content/repositories/staging/org/opendaylight/integration/distribution-karaf/0.4.0-Test-beryllium-v201512150335/ First Be autorelease artifacts (tmp repo) (dfarrell07, 17:18:06)
    6. dfarrell07's large JJB docs refactoring patch has been merged, more edits welcome in follow-up patches (dfarrell07, 17:18:15)
    7. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.builder/master/jenkins.html Current JJB docs (dfarrell07, 17:18:19)
    8. Vratko points out that some people push many, many patch-sets for new changes. When they don't need tests, they should mark that frequently-updating change as a draft to avoid kicking off verify jobs. (dfarrell07, 17:29:16)
    9. ACTION: Vratko to get that feedback/tip about reducing verify jobs using drafts into a wiki (dfarrell07, 17:30:20)

  3. Int/Pack Updates (dfarrell07, 17:31:00)
    1. dfarrell07 created "Experimental Release Preview" (ERP) ODL RPM based on the first successful Be autorelease build artifacts (dfarrell07, 17:31:11)
    2. ERP RPM is designed to allow OPNFV testing projects to start consuming ODL Be well before OPNFV Brahmaputra, which gives them confidence to include a flag to install OPNFV with ODL Be vs Li (dfarrell07, 17:33:47)
    3. sudo yum install -y http://cbs.centos.org/repos/nfv7-opendaylight-4-testing/x86_64/os/Packages/opendaylight-4.0.0-1.20151215033.el7.noarch.rpm (dfarrell07, 17:33:54)
    4. https://github.com/dfarrell07/vagrant-opendaylight/blob/1c69f5839f2f15965557c32521c4250fc805939a/Vagrantfile#L74-L92 CentOS 7 Vagrant box that installs ERP via repo config (dfarrell07, 17:34:40)
    5. https://git.opendaylight.org/gerrit/#/c/31376/1/rpm/example_repo_configs/opendaylight-4-testing.repo To-be-merged example repo config for installing Be ERPs (dfarrell07, 17:34:47)
    6. dfarrell07 would really appreciate it if someone would create a .deb package for ODL (dfarrell07, 17:34:54)

  4. General updates, questions, etc (dfarrell07, 17:35:08)
    1. Vratko asks if there's a good way to auto-remove a feature from autorelease if it's removed from integration (dfarrell07, 17:35:36)
    2. Discussion about having autorelease working from the very start of Boron (dfarrell07, 17:38:12)
    3. zxiiro points out that master currently works, so we should have a working autorelease once we branch (dfarrell07, 17:38:47)
    4. tykeal points out that autorelease didn't exist until mid-Li, hence the world-always-broken state before now (dfarrell07, 17:40:38)
    5. Discussion about new autorelease verify jobs that should help break autorelease breakages (dfarrell07, 17:41:10)
    6. LuisGomez points out that we need to make it clear that breaking autorelease == bad and we'll kick you out until you stop (dfarrell07, 17:41:56)
    7. LuisGomez points out that we need to make it clear when new projects need to be in autorelease. Maybe m2, since need to be in distribution by m3? (dfarrell07, 17:43:17)
    8. Discussion about opflex isn't really a part of the release "train" as zxiiro puts it, shouldn't really be a part of the SR (dfarrell07, 17:45:14)
    9. LuisGomez, dfarrell07, zxiiro and others want to make it clear to new projects that being part of the SR isn't a bad thing if you don't need it, no need to take part if bad fit (dfarrell07, 17:46:12)
    10. Int/Dist hasn't sent out M4, anipbu points out (dfarrell07, 17:46:35)
    11. ACTION: edwarnicke (or some other Int/Dist person?) to send Int/Dist M4 (dfarrell07, 17:47:10)
    12. Discussion about how autorelease likely shouldn't be part of the SR, since every field is NA (dfarrell07, 17:47:31)
    13. Vratko points out that Int/Dist needs to have a primary contact other than PTL (dfarrell07, 17:48:28)
    14. AGREED: Next two Int/* meetings (12/24 and 12/31) are canceled due to Christmas and New Years (dfarrell07, 17:50:28)
    15. dfarrell07 asks if we can start using JIRA for issue tracking, not sure if it's still a pilot or ready-for-use (dfarrell07, 17:51:47)
    16. dfarrell07 is interested in getting Int/*'s many Meetbot minutes dirs `cp/mv`'d into a single one (dfarrell07, 17:51:55)
    17. dfarrell07 says it makes it hard to find minutes for a date, have to know which dir to check (dfarrell07, 17:52:05)
    18. https://meetings.opendaylight.org/opendaylight-integration/2015/ Meetings minutes for this IRC chan, split incorrectly into many different dirs b/c of inconsistent meeting name (dfarrell07, 17:52:14)
    19. https://trello.com/b/ACYMpTVD/opendaylight-integration Trello for Int/* (dfarrell07, 17:52:40)
    20. https://meetings.opendaylight.org/opendaylight-integration/2015/ (tykeal, 17:57:49)
    21. ACTION: dfarrell07 to raise helpdesk ticket to refactor meeting minutes dir structure as described above (dfarrell07, 17:59:32)


Meeting ended at 18:01:33 UTC (full logs).

Action items

  1. Vratko to get that feedback/tip about reducing verify jobs using drafts into a wiki
  2. edwarnicke (or some other Int/Dist person?) to send Int/Dist M4
  3. dfarrell07 to raise helpdesk ticket to refactor meeting minutes dir structure as described above


Action items, by person

  1. dfarrell07
    1. dfarrell07 to raise helpdesk ticket to refactor meeting minutes dir structure as described above
  2. UNASSIGNED
    1. Vratko to get that feedback/tip about reducing verify jobs using drafts into a wiki
    2. edwarnicke (or some other Int/Dist person?) to send Int/Dist M4


People present (lines said)

  1. dfarrell07 (64)
  2. tykeal (8)
  3. odl_meetbot (6)
  4. anipbu (2)
  5. zxiiro (2)
  6. LuisGomez (1)
  7. odp-gerritbot (1)


Generated by MeetBot 0.1.4.