#opendaylight-integration: Integration Teem Weekly Meeting

Meeting started by dfarrell07 at 16:03:32 UTC (full logs).

Meeting summary

  1. news and updates (LuisGomez, 16:04:24)
    1. Integration team gathering on 1/27-28 (dfarrell07, 16:05:10)
    2. ACTION: LuisGomez will create agenda for gathering (dfarrell07, 16:06:27)
    3. Test plan was sent out last week. No push-back so far, looks good. (dfarrell07, 16:07:52)
    4. Future test work will likely be more use-case driven, per community input on important use-cases (dfarrell07, 16:09:21)
    5. LuisGomez talks about ODL features, features needed by our team for testing that shouldn't ship to users, how to achieve that state (dfarrell07, 16:19:41)
    6. icbts asks about test distro and if it'll include perf tools (dfarrell07, 16:19:57)
    7. dfarrell07 suggests that a test distro wouldn't include perf tools, as those are likely best treated as external tools to stand up beside an ODL distro (dfarrell07, 16:20:38)
    8. http://maven.apache.org/guides/introduction/introduction-to-profiles.html (icbts, 16:31:22)
    9. http://maven.apache.org/guides/introduction/introduction-to-profiles.html <— use profiles to simplify your builds here (icbts, 16:32:20)
    10. Need to put thought into how to do next gen of perf tests. Should run in CI for sure. Spirent perf tests could be done less frequently, not every merge. (dfarrell07, 16:35:33)
    11. Suggestion to ask projects about their perf test needs (dfarrell07, 16:37:36)
    12. Suggestion to create Vagrantfile to replace test tools VM (dfarrell07, 16:45:49)
    13. Tons of issues with having a full VM for test tools (can't reproduce, can't say exactly what's there, export issues, no version control) (dfarrell07, 16:46:13)
    14. ACTION: dfarrell07 will create Trello card for test tools Vagantfile, to be completed fairly far down the road (dfarrell07, 16:46:43)
    15. Discussion about state of Spirent lab (dfarrell07, 16:48:19)
    16. https://github.com/dfarrell07/dfarrell07-opendaylight ODL Puppet mod dfarrell07 is working on (dfarrell07, 16:48:57)
    17. ACTION: dfarrell07 to drop latest ODL RPM in int repo ASAP (dfarrell07, 16:49:10)
    18. phrobb asks LuisGomez about interactions with other projects to get support for testing use-cases, periodic "releases", etc (dfarrell07, 16:57:43)


Meeting ended at 17:03:17 UTC (full logs).

Action items

  1. LuisGomez will create agenda for gathering
  2. dfarrell07 will create Trello card for test tools Vagantfile, to be completed fairly far down the road
  3. dfarrell07 to drop latest ODL RPM in int repo ASAP


Action items, by person

  1. dfarrell07
    1. dfarrell07 will create Trello card for test tools Vagantfile, to be completed fairly far down the road
    2. dfarrell07 to drop latest ODL RPM in int repo ASAP
  2. LuisGomez
    1. LuisGomez will create agenda for gathering


People present (lines said)

  1. dfarrell07 (25)
  2. icbts (8)
  3. odl_meetbot (4)
  4. LuisGomez (1)


Generated by MeetBot 0.1.4.