#opendaylight-integration: Integration Weekly Meeting

Meeting started by dfarrell07 at 15:00:17 UTC (full logs).

Meeting summary

    1. https://trello.com/b/ACYMpTVD/opendaylight-integration Trello with relevant tasks (dfarrell07, 15:00:40)
    2. LuisGomez gives updates on ONS plugfest. Represented ODL, went well. (dfarrell07, 15:07:49)
    3. There's a new "link switch" OVS-related thing that we might want to include in our testing boxes (dfarrell07, 15:08:26)
    4. ODL is now using enough Rackspace stuff that we have a dedicated rep (dfarrell07, 15:09:55)

  1. Task updates (dfarrell07, 15:10:46)
    1. Long-run test basics are done. Need to do some infra work (stand up VA data center) before we can do the weekly 24 hour run we'd like to do initially. (dfarrell07, 15:13:23)
    2. tykeal suggests running Saturday early morning PT for now to avoid resource constraint above (dfarrell07, 15:14:00)
    3. torbit has some initial work done on the latest-OVS Mininet VM. dfarrell07 gave him a brain dump on releng/builder, he's now porting his work to that env. (dfarrell07, 15:16:32)
    4. tykeal recommends building Fedora or EL7 boxes when possible (relevant to new Mininet VM), Ubuntu support is a well-known TODO but not ready yet (dfarrell07, 15:17:35)
    5. We may also run Mininet in Docker containers if F20 or F21 doesn't work out for some reason. No one is actually sure if Mininet works in Docker. (dfarrell07, 15:19:46)
    6. ACTION: dfarrell07 to create a wiki with available Python modules on test systems (dfarrell07, 15:21:42)
    7. Sandeep has an initial scale test under review (dfarrell07, 15:22:16)
    8. dfarrell07 and Jamo are working on adding some IP/MAC address-related Python modules to the test boxes. Please use those vs writing your own painful logic for working with addresses! (dfarrell07, 15:23:18)
    9. https://wiki.opendaylight.org/view/GettingStarted:Pulling,_Hacking,_and_Pushing_All_the_Code_from_the_CLI Main wiki on contributing patches (dfarrell07, 15:35:26)
    10. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Hack_Code Integration-spicific wiki on contributing code (dfarrell07, 15:35:59)
    11. Question about process of sending patches. Answer, see links above, ping us on IRC. (dfarrell07, 15:36:22)
    12. dfarrell07 has been working with OPNFV Genesis to get pre-release version of Arno stable enough for our consumption for a large Neutron test. Painful, but some progress. (dfarrell07, 15:41:51)
    13. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Hack_Code Under-dev ODL Ansible role dfarrell07 is working on (making quick progress releative to Puppet mod) (dfarrell07, 15:42:26)
    14. Good overview of cluster deploy scripts from LuisGomez (dfarrell07, 15:48:39)
    15. Just because people are already assigned to TODO-list Trello cards doesn't mean they own them and don't want/need contributions from others. They are just interested in the TODO/want it done. Please feel free to jump on any card. :) (dfarrell07, 15:50:45)


Meeting ended at 15:52:07 UTC (full logs).

Action items

  1. dfarrell07 to create a wiki with available Python modules on test systems


Action items, by person

  1. dfarrell07
    1. dfarrell07 to create a wiki with available Python modules on test systems


People present (lines said)

  1. dfarrell07 (22)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)


Generated by MeetBot 0.1.4.