#opendaylight-integration: Integration Weekly Meeting

Meeting started by dfarrell07 at 16:04:38 UTC (full logs).

Meeting summary

  1. int/dist updates (dfarrell07, 16:04:55)
    1. Vrakto reports that there are issues with the builds, taking a long time and failing (dfarrell07, 16:05:14)
    2. Build issues are being debugged, YANG changes may be related, Vrakto et al are on it (dfarrell07, 16:05:59)

  2. int/pack updates (dfarrell07, 16:06:45)
    1. Not too much going on, still a large RPM refactoring patch on Gerrit that needs docs before merge (dfarrell07, 16:07:12)
    2. dfarrell07 is going to LinuxCon EU to speak on int/pack topics next week, will not be around IRC or email as much (no mobile data) (dfarrell07, 16:07:34)

  3. int/test updates (dfarrell07, 16:08:34)
    1. zxiiro has been working an Ubuntu VM with a newer version of OVS, jamoluhrsen will consume the next iteration soon to test out recent changes (dfarrell07, 16:09:40)
    2. This new Ubuntu VM (with newer OVS versions) will become the default for many mininet/ovs tets (dfarrell07, 16:10:22)
    3. ACTION: jamoluhrsen to go look at robot jobs and tell tykeal if they need the robot metadata (I kinda missed the details of this) (dfarrell07, 16:11:35)
    4. ACTION: jamoluhrsen will test the new Ubuntu/OVS/Mininet VM (dfarrell07, 16:12:15)
    5. stable/<tags> will be discussed over email (dfarrell07, 16:12:25)
    6. An Ho asks about long job queue, zxiiro reports it's still long, a number of people clarify that things should speed up and clear out (dfarrell07, 16:14:39)

  4. Trello (dfarrell07, 16:15:27)
    1. Vrakto reports that PCEP perf test is done and merged (dfarrell07, 16:15:49)
    2. jamoluhrsen reports that Docker container CI stuff is almost working, cleanup time. We can stand up multi containers on a CI VM and access them from other VMs. This is a big win, huzzah! (dfarrell07, 16:17:54)
    3. Fedora Mininet card abandoned because we're moving to Ubuntu for Mininet/OVS (dfarrell07, 16:18:16)
    4. Linux prompt discussion hasn't changed (dfarrell07, 16:18:53)
    5. Luis and Marcus aren't here today, can't cover their cards (dfarrell07, 16:19:07)
    6. There's a patch with proposals/discussions for better robot var names, hasn't changed much (dfarrell07, 16:19:42)
    7. There's a mailing list discussion about postman collections and adding them to the int/test repo (dfarrell07, 16:26:04)

  5. cluster test group updates (dfarrell07, 16:26:35)
    1. Second cluster test group meeting was this past Wednesday (dfarrell07, 16:26:54)
    2. https://wiki.opendaylight.org/view/Meetings#Cluster_Test Cluster meeting details (dfarrell07, 16:27:25)
    3. Cluster test group is planning template/keyword/other infra to help projects write cluster tests (dfarrell07, 16:27:55)
    4. https://lists.opendaylight.org/pipermail/integration-dev/2015-September/004676.html Cluster test call minutes (dfarrell07, 16:30:13)
    5. Radika points out that OVSDB has done some Docker cluster work, jamoluhrsen may benefit from checking out what they've done (dfarrell07, 16:32:23)
    6. http://vishnoianil.github.io/2015/09/ovsdb-clustering-development-environment-setup/ (jamoluhrsen, 16:32:34)
    7. http://vishnoianil.github.io/2015/09/ovsdb-clustering-development-environment-setup/ Docker cluster OVSDB work we may want to study (dfarrell07, 16:33:06)
    8. Still need someone to make a job to run the DSBenchmark tests in CI (dfarrell07, 16:34:59)
    9. Maven Sites docs is still a TODO, no updates this week that we know of, will be a good docs tool in the future (dfarrell07, 16:35:24)
    10. dfarrell07 pinged the Veryx perf testing tool eval thread to let the know we care, are talking about evaling the tool but don't have anyone with free cycles stepping up to do it (dfarrell07, 16:38:45)
    11. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Clustering Radhika has some good clustering docs, please check them out (dfarrell07, 16:39:55)
    12. zxiiro is working with the yangtools project to get maven-sites running (dfarrell07, 16:41:29)
    13. ACTION: jamoluhrsen to follow up with zxiiro about standing up maven-sites docs stuff for int/test (dfarrell07, 16:41:59)

  6. cookies (dfarrell07, 16:44:19)


Meeting ended at 16:44:21 UTC (full logs).

Action items

  1. jamoluhrsen to go look at robot jobs and tell tykeal if they need the robot metadata (I kinda missed the details of this)
  2. jamoluhrsen will test the new Ubuntu/OVS/Mininet VM
  3. jamoluhrsen to follow up with zxiiro about standing up maven-sites docs stuff for int/test


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to go look at robot jobs and tell tykeal if they need the robot metadata (I kinda missed the details of this)
    2. jamoluhrsen will test the new Ubuntu/OVS/Mininet VM
    3. jamoluhrsen to follow up with zxiiro about standing up maven-sites docs stuff for int/test
  2. zxiiro
    1. jamoluhrsen to follow up with zxiiro about standing up maven-sites docs stuff for int/test


People present (lines said)

  1. dfarrell07 (41)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)
  4. zxiiro (2)
  5. Radhika (2)
  6. jamoluhrsen (1)


Generated by MeetBot 0.1.4.